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Chapter 1: Welcome to Vista

Welcome to the User Guide for the Vista by Chroma-Q lighting and media control system.
This guide is intended to give you the information you need to get Vista up and running as
quickly as possible.

Note that this guide will be regularly updated as enhancements are made to Vista. A current
version of the manual is available at http://www.vistabychromaq.com/downloads.

The Vista Advantage

Vista brings lighting control into the 21st century through its graphical user interface and visual
presentation of fixtures, Cue lists, and Cues. While working with fixtures and programming
Cues and Cuelists can be achieved through command line entries, Vista’s ease of use and
short learning curve shine through the visual representation of these basic lighting control
building blocks and quick access to features through its GUI. With Vista, both the visual mode
of programming your show as well as the command-line mode of programming are equally
effective. Even those unfamiliar with lighting control systems quickly grasp how to work with a
lighting rig and program Cuelists when presented with Vista’s intuitive interface.

If you’ve ever worked with video or audio editing systems, one of the most powerful features
of Vista, the Timeline, will be instantly familiar to you. If not, don’t worry; once you start using it
you’ll pick it up very quickly and be amazed at how intricate Cue timings that would be
cumbersome and complicated to program in other lighting control systems are easy to create
in Vista.

“Think it. Create it. Do it.” It’s not just a catchy phrase—it’s Vista’s ease of use reality.

About the Generic Fixture Model
One thing about Vista that’s not immediately obvious is the “generic fixture model”. What is it?
It’s a part of the software that works in the background and enables all fixtures, no matter
what type or manufacturer, to be treated the same way.

Let’s say you’ve programmed a show using one brand of fixture but need to replace some of
them with a different kind. Normally this would be a major hassle because you’d have to find a
similar fixture then reprogram each and every Cue.

With Vista, you can replace a fixture with minimal reprogramming required. Why? Because
everything you’ve programmed is stored in generic form rather than as specific DMX channel

http://www.vistabychromaq.com/downloads
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values. For instance, if you’ve programmed the lights to be red, Vista can send that

information to any color-changing fixture and achieve the same color.

Sure, if you replace a fixture that has color mixing with a fixture that has a fixed color wheel,
you won’t expect to get the exact same result, but even in this case, Vista will adapt and
provide as near a match as the replacement fixture is capable of.

Conventions
We will use certain conventions throughout this manual to make it easier to read.

Menu References
When referring to a menu item, such as the “Lock Entire Console” option in the “Lock” sub-
menu under the “File” menu, we will simply use the following notation in bold print: File-

>Lock->Lock Entire Console. References to items in popup menus will be handled in the

same way, with a notation that a popup menu is being referenced. Menu items that feature a
trailing ellipsis, such as “Save Show As…”, will not include the ellipsis in this form of
reference.

Modifier Keys
With Vista’s support for multiple operating systems and hardware configurations, there are
slightly different ways of doing things based on how exactly you are running Vista. Some of
the buttons in the user interface and the functionality of controls on the hardware consoles
change based on if certain keys are pressed. Most of the Vista consoles have modifier
buttons which are color-coded: red, yellow, green, and blue. These are mapped to keys on
your computer keyboard as well, such that if you don’t own a Vista console, you still can
access all the functionality. These mappings are:

Console Modifier Button Windows Key MacOS Key

Red Shift Shift

Yellow Ctrl Command

Green Alt Option

Blue Ctrl+Alt Control

To simplify references to these modifier keys, we will present them as the three choices
within square brackets – the first is the Console modifier button; the second is the Windows
modifier keys option; and the third is the MacOS modifier keys option. For example, [red/shift],
or [blue/ctrl+alt/control].

Note that on some systems, the Blue modifier can also be achieved by pressing the AltGr
key. This key is common in European keyboards. Also, when running Vista in Console Mode
on a Windows-based platform, the Windows key will also act as the Blue modifier key.
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Screen Captures
Note that in some cases, when we present screen captures to illustrate a point in the manual,
we may have resized a window we captured to a smaller size than you might see when
running Vista yourself. This is to present the information in the manual in as concise and
readable a format as possible. So, the screen captures presented here may look slightly
different in size and configuration than is typical.

Vista Hardware
In addition to the Vista software, Chroma-Q sells a variety of hardware control systems that
either run Vista, or work with Vista. Generally speaking, when the software runs on the
hardware itself, we call that a console. When the hardware plugs into a computer running
Vista, that’s referred to as a console. In this manual, we will simply refer to any hardware
controls that work with Vista as a “console”.

Need More Information?
If you have questions about Vista or you’d like more information, go to our website at
www.vistabychromaq.com or email us at vistasupport@chroma-q.com.

https://www.vistabychromaq.com/
mailto:Vistasupport@chroma-q.com
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Chapter 2: Getting Started

To get started, Vista needs to be installed on the computer being used to run the application,
and any control surfaces need to be connected to the computer.

Setting up Vista

Consoles and Control Surfaces
For information on setting up Vista consoles or consoles, please refer to the documentation
for the specific hardware product you are using.

External displays
Vista is designed to work with up to three monitors (although more than three will work,
however window positions may not be remembered beyond three screens), any of which can
be touch screen displays. Vista is designed to work well with touch-enabled screens, and any
touchscreen supported by the host computer will work with Vista.

Installing Vista on Windows
To install Vista on your computer, first review the system requirements listed on the
vistabychromaq.com website and make sure that the computer you intend to install it on
meets the minimum hardware requirements. Ensure that your license dongle and any
consoles are not connected to your computer at this time. Then, download the latest

release’s installation program from vistabychromaq.com and run it. If you get prompted by
Windows to allow this program to make changes to your device, click the Yes button. If you
have a previous version of Vista installed, you will also be prompted as to whether you would
like to uninstall the previous version of Vista before proceeding. Note that uninstalling a
previous version will not delete your preferences or show files. Having multiple versions of

Vista 3 installed at one time on the same computer is not supported.

Follow the prompts of the installer. You will be asked for the application location, the user data
directory (where Vista stores Showfiles and other data created by the user) and the option of
whether to engage console mode (Refer to Chapter 3: Console Mode). If needed, further
instructions can be found on the vistabychromaq.com Q Downloads page.

Installing Vista on macOS
To install Vista on macOS, first review the system requirements listed on the
vistabychromaq.com website and make sure that the Apple computer you intend to install it
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on meets the minimum hardware requirements. Make sure that your license dongle and any
consoles are not connected to your computer at this time. Then, download the latest
release’s DMG file from vistabychromaq.com and run it. You may get prompted to enter the
password for the administrator’s account on your Mac; do so to continue the installation
process.

The installation window shown here will appear. Drag the Vista icon onto the Applications icon
to install.

Launching Vista
When you launch the Vista application or power on your console, Vista starts up and displays
the opening splash screen:

Network Interface Selection
Vista has features and lighting protocols that work over an Ethernet network. If there is more
than one viable Ethernet connection on the computer you are running Vista on, Vista will
prompt you for which network connection to use. It will also prompt you for a new network
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connection if the one it used previously is no longer available and more than one replacement
option is found:

Once Vista finishes initializing it offers you the option to open the last show used; open an
existing show; or create a new show. If you choose New Show, Vista prompts you for a show

name, and then displays the Patch window:

Creating and Loading Shows

Creating a Show
To create a new show at any time, select File->New Show.
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Loading Existing Shows
To load a show you’ve already created, select File->Open Show. Vista displays a standard

Open File window.

The Open Show window will show you the default show location folder selected during
installation; to load a show file stored in another location simply navigate to that folder. Then
click on the filename to select it and hit the Open button to load it.

Open Show can also open shows you’ve created on another computer or console. The
shows must be on a portable storage device that connects to the USB port (such as a flash
drive).

Saving Shows
As with any computer, it’s a good idea to save regularly in case of power failure.

To save a show at any time, choose the Save button from the User Softkey toolbar, or pick
File->Save Show. Vista will automatically save the show in your default Shows folder, selected
when you installed Vista. (You can find out the default location for storing Vista data though
Help->About Vista.) Once you’ve named the file, each time you choose the Save option from

then on, Vista overwrites that file with the new details without displaying this window.

To save your show file to a different location, pick File->Save Show As.

Saving Copies of Shows
File->Save a Copy As operates like File->Save Show As option, but the new show file does

not become the current show. This is useful for archiving off the current state of your show

but continue to save to your original show file going forward. It’s especially useful for backing
up your show file onto a flash drive that you intend on immediately removing from the
computer. 

We strongly recommend that, in addition to saving your show frequently, you make regular
backups of your work onto a storage device that you can connect via a USB port. This will
help you recover from a catastrophic computer failure by having a recent copy of your show
on removable media that can be loaded onto a new computer running Vista.

Deleting Shows
To delete a show from within Vista, choose File->Open, then right-click on the show folder

name and choose the delete option relevant for your operating system. Shows can also be
deleted by using the Windows Explorer or Mac Finder tools built-into your computer’s
operating system.

Password-Protecting Your Console or Show
You can lock your console or show file or disable certain functions with a password. To do
this, choose a File->Lock option. Vista displays a popup menu with four options:
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This option… does this…

Lock entire
console

The password is required to use any console functions or
controls.

Disable all
editing

The password is required to edit the patch, Cuelists, groups,
presets and all other show components.

Disable Merging This option prevents you from performing a Merge operation
(see Chapter 18 – Merging Showfiles), both preventing you
from merging a show file into this show, as well as merging
this show into another show file.

Disable Saving
(Write Protect)

The password is required to save changes to the show file.

Select an option from the popup menu. Vista displays the Lock Vista window:

Enter your password in both boxes and click OK Your show or console is now password
protected.

When the entire console is locked, an overlay will cover the entire screen until the password
is entered.

To unlock any other option, pick File->Lock and pick the option you want to unlock. (Locked

options are shown with a checkbox next to them.) The unlock window is displayed; enter the
unlock password and click OK.

User Preferences
There are a number of user preferences that configure and determine how Vista software
operates. To set these preferences, choose File->User Preferences; Vista displays the

User Preferences screen: 
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This window has nine sets of options available, presented each in their own tab. Common to
all tabs are “Use these settings for new shows”, which causes these options to become the
default for any new shows created; and “Reset to factory defaults”, which resets the options
for the selected tab to the factory default settings.

General
This tab includes options for startup, lock screen, patching, presets, fixture chooser,
command line, audio, and geographical location.

This option… does this…

Auto load show Specifies a show file to automatically open when
Vista launches. A related setting is “Auto-run on

show load” in the Cuelist properties; combining
these two would cause both a show to load and a
Cuelist to run when Vista starts. Pick Clear to stop

Vista from loading a show on startup.
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This option… does this…

Lock Screen Image Allows you to pick an image that will be displayed on
all monitors when the Lock Entire Console option is
active. Pick the Clear button to remove any custom
lock screen image.

Auto generate fixture
type groups

Automatically creates fixture groups containing all
fixtures of a given type whenever new fixture types
are added to the patch. If enabled, icons for these

groups will be displayed on the chooser layout
windows.

Preview Parked
Fixtures

Displays feature changes on the Fixture icons even
though the fixture(s) or some features are parked.

Enable Quick Picker
page filtering

When a preset containing multiple features (i.e.
Intensity, Position, Color, etc) is selected from a
filtered page (i.e. Presets > Color) only one feature
type will be applied to the selected fixture(s).

Use the Home
Preset when clearing
fixtures or features.

When fixtures or individual features of fixtures are
cleared, in the Editor, they will go to values saved in
the Home preset. If there are no values saved for the
fixture(s) they will go to their defaults.

Zoom with mouse
wheel

Allows you to zoom in and out on the chooser
window by using the scroll wheel on your mouse.

Show command line
in new show

The command line will automatically be shown when
a new show is created.

Mute audio on
tracking backup
slave

Audio output on the tracking backup is automatically
muted until the slave takes control of a master at
which point it is un-muted automatically.  If a master
becomes a slave, it will be muted.

Volume Sets the audio volume for audio files being played
from Cues.

Location Sets the geographical location for which sunrise and
sunset are calculated for Date & Time events. You
can set the longitude and latitude directly or select a
location via the Find Location button.
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Naming
Most components are identified by a number (ID) and name.  You can adjust how the names
of Cuelists, Cues, Fixtures, Groups, Presets, Extracts, SmartFX FX, FX Templates, Fixture
Layouts,  Snapshots, and FX Masters appear by setting a format for each component. 

This affects views where the item label is displayed, such as a list view in a Quick-picker, or a
Cuelist tab in the Editor.

This option… does this…

# displays the components ID number

$ displays the components name.

Console

The console preferences control how some of Vista hardware controls operate.
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This option… does this…

Date/Time This allows you to set the date & time of the system.
This option is only available when Vista is running in
Console mode.

Fader action
threshold – Bottom

and

Fader action
threshold – Top

These set how close to the actual bottom or top of
the fader movement a fader needs to be to be
considered the actual bottom or top. This provides a
little “wiggle room” in not requiring it to be perfectly
100% at the bottom or top, and thus can make fader
movement a little more forgiving.

Encoder sensitivity Adjusts how many times an encoder needs to be
rotated to go from minimum to maximum value.

Encoder acceleration Sets the encoders to make bigger changes the
faster they are turned.

Grand Master locked Locks the Grand Master at its current setting

Page holdover when
active

Prevents Cuelists and groups from being paged out
if they are contributing to the current output.
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This option… does this…

Components that are held over will be removed from
the new page when:

The component is released or fully over-ridden, or

You press the page up and page down buttons
simultaneously

Inhibit fader jitter Old or dirty faders may ”jitter” and cause small level
changes. Adjusting this setting to a higher level
reduces the effect of this problem.

Desklight brightness Enables you to adjust the brightness of the desklight
on consoles that support this. This option is only
available when Vista is running in Console mode.

Display Cue icons on
playbacks

If a cue is a blocking or superblocking cue, an icon
will be displayed next to the cue label on console
displays indicating this.

Serial Input
To trigger Cuelists with ASCII text messages, Vista’s serial port must be configured to match

the sending device.

For more details on using serial devices with Vista see Appendix 4 – Using Serial
Communication to Control Cuelists.

This option… does this…

Serial port Enables or disables the serial input
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This option… does this…

Baud rate Sets the speed used for the serial port. Use a lower
Baud rate for more reliable performance

Data bits Sets the number of data bits. 8 data bits is almost
always used in newer applications.

Stop bits Sets the number of stop bits. Most devices use one
stop bit.

Parity Sets the Parity to None, Odd, Even, Mark or Space.
The most common parity setting, is "none".

Flow control Sets whether signals are used to pause and resume
the transmission of data. Normally set to Off

MIDI Input
To use MIDI Timecode (MTC), MIDI Show Control (MSC) or MIDI Notes to control Vista the
MIDI preferences must be configured to match the sending device.

For more information on using timecode for controlling Cuelist playback, see Chapter 14:
Automating Playback and Appendix 3 – Using MIDI Show Control.

This option… does this…

Device ID Sets the MIDI device ID used for MSC messages. (0
– 128)
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This option… does this…

Channel ID Sets the channel ID used for MTC. (Any channel or 0
– 127)

MIDI Note Channel Sets the channel ID used for MIDI Note messages.
(Any channel or 0 – 16)

External MIDI Ports Displays a list of any external MIDI ports that are
available. To select an external port, tick the

corresponding checkbox.

Autosave
You can set Vista to automatically save copies of your show while you are programming
through the autosave and autobackup options. The creation of these files does not interrupt

show playback or editing.

This option… does this…

Auto save enabled Sets Autosave on or off for the current show. 

Autosave will create a single Autosave file for the
open show, updating it every five minutes if changes
to the show have been made since the last save
operation.

 

If Autosave is on a disk icon appears in menu bar: 

Grey: autosave is enabled but idle.
Blue: autosave is saving a copy of the show.
Red: autosave has not been able to save a copy of
the show for 2 x the specified interval because the
console has been busy with other tasks.
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This option… does this…

Automatically create
backups

Enable the automatic creation of backup files. Each
time an auto backup is initiated, a new backup file is
created.

Create backup every Sets the interval, in minutes, between backup file
creation. If autosave is on the color of the disk icon
indicates its status:

Backups to keep The number of automatic show backups to save.
Once the number of backups exceeds this number,
the oldest backup file is deleted.

Playback
The playback preferences set how some playback actions are performed.

This option… does this…

Play reasserts entire
Cuelist

Plays the tracked state of a Cue even if it has been
partially over-ridden by other playbacks.

Reassert uses Live
Time

Uses the Live Time setting, rather than the Cue
timing when a Cue is reasserted.

Spacebar acts as
Play 

Pressing the spacebar will play the default Cuelist. If
a Cuelist edit tab is open it will play the Editor
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This option… does this…

Cuelist. When a Cuelist edit tab is closed it will
return to the Default Cuelist. Additionally, pressing
the spacebar while [red/Shift] is held down will
release the selected Cuelist; pressing the spacebar
while [yellow/Ctrl/Command] is held down will pause
the currently running Cue, and cause it to play
backwards if pressed a second time.

Home stops effects Stops any effects running on a fixture feature when it
is sent to its Home setting.

DMX updates per
second

Sets the rate of DMX packets per second on
hardware that supports this option. This may be
useful on older fixtures that do not support higher
refresh rates.

Force refresh of all
features

Forces Vista to recalculate the output state more
regularly. Normally only required for troubleshooting
output errors on very large shows.

Set options for best
performance

Sets ”Reassert uses Live time” On and “Force
refresh” to Never. Has no effect on ”Home stops
effects” or ”Spacebar acts as Play”.

Network
This tab is used to set the options for networking and tracking backup.
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This option… does this…

Vista Network

Node Name Sets the name for this Vista instance.

Group Name Sets the name of the Group Vista device belongs to.
Devices in the same Group can operate together for
tracking backup and distributed processing.

Network Interface

Ethernet Select the Ethernet interface hardware to be used for
communication with the master/backup Vista
instance.

Network Settings – Consoles or Console Mode only
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This option… does this…

DHCP The system will get its IP address from the
network’s DHCP server.

Static The system will use the IP address, Subnet Mask
and Gateway settings specified here.

IP Address When set to Static, the system will use this IP
address.

Subnet Mask When set to Static, the system will use this Subnet
Mask.

Gateway When set to Static, the system will use this
Gateway.

Tracking Backup

Timeout (sec) After not receiving any communication, from the
tracking backup console, for the Timeout period, an

alert window opens. This window provides options for
dealing with the communication loss.

Auto Failover (sec) Sets the time, before the Tracking backup console
automatically takes over from a failed Master console.

Art-Net

Broadcast address Sets the broadcast address for Art-Net outputs. The
options are:

Subnet Directed – broadcast is on the local LAN
subnet

Art-Net Primary (IP 2.255.255.255) Art-Net Secondary
(IP 10.255.255.255)

Limited Broadcast (IP 255.255.255.255)

Editing
The Editing tab sets defaults for common editing operations.
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This option… does this…

Store Source Sets the default source for the Store Part operation.
The choices are all output of the console, which
includes output from other running Cuelists; or
Programmer, which includes only features of
fixtures currently active in the Programmer.
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This option… does this…

Store Selection Sets the default fixture selection for the Store Part
operation. The options are all fixtures with an active
feature, or only those fixtures currently selected.

Cue Deletion Mode Sets the default behavior for deleting Cues to be
Normal, which respects tracking from the cue prior;
or Cue Only, which makes the deletion cue only for
tracking purposes.

Extract Application
Mode

Sets the default behavior for applying extracts to a
Cuelist. Refer to Chapter 8: The Components Tab
for more details on what these options mean.

Intensity Increment
Amount

Sets the % increment amount when using the "+" or
"-" buttons within the intensity feature GUI controls.

Always Record
Absolute Values

When creating or updating a preset, if the current
output is derived from a different preset and this
option is checked, the absolute value will be
recorded; otherwise a reference to the other preset
will be recorded (embedded presets = active).

Startup
The startup tab is only available when Vista is running in Console mode. This tab allows you
to add external programs that should be run when Vista starts, and replaces the normal
Windows user startup options available in the operating system of the computer.

This option… does this…

Startup This is the list of programs that will run when Vista
launches in console mode.
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This option… does this…

Start Now This will launch the program selected in the Startup
list.



Chapter 3: Console Mode 23

Chapter 3: Console Mode

On Microsoft Windows computers only, Vista can be installed in Console Mode, which causes
Vista to immediately start when the computer is booted (or logged in) in Full Screen mode. It
also limits access to most common Windows programs and functions. This is advantageous
when the computer is to be used solely to run Vista. Some of the advantages include:

· It makes it difficult for a user to run software such as web browsers or file browsers

whose indiscriminate use could infect the computer with malware.

· It disables Windows Update on computers running Windows 10 Professional. This

keeps your lighting control system stable by not allowing changes that could affect
how Vista runs, nor cause interruptions in a show environment.

· It keeps the focus on Vista.

Please refer to Chapter 2 about the details of installing Vista in Console Mode.

New Options in Console Mode
When installed in Console Mode, there are some new menu options that appear under the
File menu:

At times you may desire to update the version of Vista on your console-mode computer. To
facilitate this, an update function is available on the File menu when Vista is run in console
mode. Simply place the Vista update file in the root of a USB flash drive, insert the flash drive
into your Vista computer’s USB port, and pick File->Software Update.

If you find that you want to restart Vista, select File->Restart Vista to do so. The Vista software
will exist and restart. This does not cause the computer to reboot. If you have made changes
to your show file, you will be prompted to save it or discard the changes.
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If you need to completely reboot the computer, select File->Reboot Console to do so. If you
have made changes to your show file, you will be prompted to save it or discard the changes.
The computer will then completely shutdown and reboot into Vista.

If you do need to gain access to the Windows Desktop temporarily, select File->Reboot to

Desktop. If you have made changes to your show file, you will be prompted to save it or
discard the changes. The computer will shut down, and reboot into the Windows desktop.
Note that the computer will also automatically log into the user account that was specified
when you installed the Vista software in Console mode. When you reboot the computer again,
it will boot into the Vista software as normal.

To shutdown the computer, pick File->Shutdown Console. If you have made changes to your
show file, you will be prompted to save it or discard the changes. The computer will then
shutdown.

To temporarily disable the computer from booting in Console Mode, select File->User

Preferences, and select the Console tab. Near the bottom of the options listed is “Stay in
desktop mode after Console mode exited”. When the computer is rebooted, it will boot in
Desktop mode, and subsequent reboots will boot to desktop mode. To go back to Console
mode, launch Vista, and Vista will ask you when it starts if you want to reboot back into
Console mode.

Blue Modifier Key in Console Mode
When operating in Console Mode, the Windows key on the keyboard will act as the Blue
modifier key. This can be more convenient than having to press Ctrl + Alt to get the Blue
modifier functionality.

Remove Console Mode Completely
To permanently remove Console Mode from your computer, take the following steps:

1. Boot the Vista computer.
2. Select  File->User Preferences.
3. Within the Console tab, check the “Stay in desktop mode after Console mode

exited” option.
4. Select the OK button.
5. Select File->Reboot to Desktop.
6. Uninstall the Vista application.
7. If you still want to run Vista on this computer, reinstall the Vista application, this

time without checking the option “Use console mode”.
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Chapter 4: Using the Interface

Vista’s application window has many features familiar to computer systems users, and some
that are specific to Vista’s visual way of working with your lighting rig. Like many software
applications, there can be multiple ways of achieving the same thing. For example, to create a
new Cuelist, you can choose Components->New Cuelist; pick the New button from the User

Softkey Toolbar; right-click in the Cuelists quick-picker window and select New Cuelist; hold
[yellow/Ctrl/Command] and click in the Cuelists components window; use the command line
to store a Cue to a new Cuelist; or hold [yellow/Ctrl/Command] and press the New button on
a console’s playback control. We will focus on the most expedient way of doing something as
we describe functions in this manual; be aware, however, that there are likely other ways to
achieve the same result. Experimenting a little may turn up a way of doing something that you
prefer.

Menu Bar
At the top of the window you’ll see the main menu bar. Click on any menu heading as one way
to access Vista’s dialog boxes, submenus and commands.

The main menu bar also shows:

· The show file name.

· The Grand Master level setting.

· The Autosave (disk) icon (Refer to the Autosave user preference in Chapter 2:

Getting Started).

· The time, or the timecode if the show is set up to receive timecode.

Window navigation
You switch between the main windows using the six buttons on the left side of the user
softkey toolbar, which by default is located at the bottom of the main window. 

You can also switch between windows by selecting View->Patch, View->Console, View-

>Fixture Chooser, View->Timeline, View->Playback, or View->User Configurable Window.

Hovering over an icon brings up a tooltip with the window name.



Vista User's Guide, Version 3.326

This button… does this…

 [blue/Ctrl+Alt/Control] 1

Displays the Patch window.

[blue/Ctrl+Alt/Control] 2

Displays the Virtual Console window, providing
hardware simulation of the various Vista consoles
and consoles.

[blue/Ctrl+Alt/Control] 3

Displays the Fixture Chooser Window.

[blue/Ctrl+Alt/Control] 4

Displays the Timeline window.

[blue/Ctrl+Alt/Control] 5

Displays the Playback control window.

[blue/Ctrl+Alt/Control] 6

Displays the User Configurable window.

User Softkey Toolbar
At the bottom of the main window you’ll see the user softkey toolbar which is common to all
windows. This toolbar contains the most frequently used buttons and is divided into three
sections. The center section contains 12 buttons that map to the function buttons on Vista
consoles and the function keys on your keyboard. 

The User Softkey Toolbar can be placed either at the bottom or top of the main window. For
Vista 3 Release 3, the default location is at the bottom of the main window. If you prefer it at
the top, you can click on the left side of the toolbar where the vertical line of dots is located
and drag the toolbar to its alternate location.

The Soft Buttons
The twelve buttons in the center of the User Softkey Toolbar toolbar provide quick access to
frequently used commands, functions and windows:

· If you are using an L series console these buttons are automatically mapped to the

function buttons, above the LCD / tablet.
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· If you are using an I or S series unit the first 6 (5 on the S3) buttons are

automatically mapped to the function buttons in the top center section of the
console.

· If you are using an EX console the buttons are mapped to the F1-F12 keys running

vertically down the far right side. 

· For all Vista systems you can use your keyboard F1-F12 keys to activate these

buttons.

You can display text labels, for the function buttons, at the top of your tablet or monitor. To do
this select View->Console Softkey Labels. This is particularly useful for Vista consoles.

The soft buttons provide different functions when you press the [red/Shift], [green/Alt/Option],
[yellow/Ctrl/Command], or [blue/Ctrl+Alt/Control] modifiers.

Standard Buttons

When you first start a new show, Vista loads the standard set of buttons, however you can

customize every button as described below. The buttons when no modifier key is pressed
are:

This button… does this…

Saves the show file to disk.

Creates a new empty Cuelist and immediately places you within
the Editor.

Opens an existing Cuelist in the Editor.

Turns on Highlight mode. When you are focusing or testing your
fixtures you can use Highlight to bring up the intensity of each
fixture that is (or becomes) selected automatically. If a fixture can
color change the color will also be temporarily changed to white.
Highlight mode stays active until you explicitly turn it off.

Refer to Chapter 8: The Components Tab to learn how to change
the Highlight mode preset settings.

Store Part provides the traditional console storing operation in
that, by default, it stores the contents of the Programmer. You
also have the opportunity of selecting other options such as
"selected fixtures" only and "feature" masks within this window. 
See Store Part in Chapter 9: Working with Cuelists.
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This button… does this…

Store all is a simplified store option where you can save the
complete output (the look on stage). Storing this way will ensure
that when you play a Cue back it will appear exactly as it did when
you saved it.

If the Live tab is selected pressing Clear will remove all
information coming from the Programmer.

If a Cuelist tab is selected Close will exit the Editor Cuelist.

Displays the Update window where information coming from the
Programmer (or an open Cuelist editor) can be used to update
one or more Cues and Presets.

Once engaged, stealth will not show changes you make in the
live tab onstage. While stealth is engaged, you can blind visualize
changes you make on the fixture icons. Once ready for your
changes to go to stage, press the Stealth button again. Any

changes will appear over Live Time.

Stops all running Smart Effects.

Displays the SmartFX window where you can create and edit
effects. For more information see Chapter 12: SmartFX

Clicking this button releases all running Cuelists, returning the
fixtures they were controlling to their home values if not under
control of the Live tab. (Cuelists and groups can be set to ignore

the Release All command if desired.)

Shift Set (Red Modifier)

Hold down [red/Shift] to access and display the Shift set.

This button… does this…

Used to step through fixtures, selects the last fixture (or the one
before the current selection) and de-selects the others. Each
subsequent press selects the previous fixture. Useful when
focusing fixtures with Hightlight engaged.
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This button… does this…

Used to step through fixtures, selects the 1st fixture (or the one after
the current selection) and de-selects the others. Each subsequent
press selects the next fixture. Useful when focusing fixtures with
Highlight engaged.

Inverts the fixture selection (i.e. all selected fixtures are de-
selected and all de-selected fixtures are selected).

Selects all the active fixtures (i.e. those that have Intensity) in the
current layout.

Select all the fixtures in the current layout that are programmed in
the current Cue of the open edit tab; or, if the Live tab is currently
selected, the fixtures programmed in the Live tab.

Selects every fixture in the current layout.

De-selects all fixtures in the current layout.

Vista remembers the last set of fixtures you selected; you use this
button to toggle back to your previous fixture selection.

If you have used the previous selection command this button will
toggle back to the fixture selection you had before pressing
previous selection.

Turns on the lamps in the selected fixtures that support this feature
(e.g. arc lamps).
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This button… does this…

Switches off the lamps in the selected fixtures that support this
feature (e.g. arc lamps).

Reset triggers a fixture-implemented reset function, which usually
causes the fixture to perform a full mechanical reset and
calibration. This is useful if a fixture has a control problem and you
need to get it ”back to normal”.

Alt Set (Green Modifier)

Hold down [green/Alt/Option] to access and display the Alt (Option) set.

This button… does this…

Opens an existing Cuelist for editing within the Editor. 

Creates a new empty Cuelist and immediately places you within
the Editor.

Adds a new Cue at the end of the Cuelist being edited.

Inserts a new Cue, before the Cue that is being edited.

Adds a new Cue after the Cue that is being edited.



Chapter 4: Using the Interface 31

This button… does this…

Deletes the selected Cues from the Cuelist.

Displays the Create New Preset dialog window.

Displays the Create Extract dialog window.

Displays the Create Snapshot dialog window.

Displays the Create Group dialog window.

Unassigned.

Inserts a new Cue following the Cue over which the Timeline
playhead is positioned. Its Cue timing will be set to “Start”, which

causes the Cue to start at a time offset (which results in the cue
starting when the playhead reaches this position). For example,

let’s say you have a Cue 5 that is three seconds long and in the
timeline window, you have the playhead positioned 1.5 seconds
into this Cue’s playback. You then press the “Insert at Playhead”
button. A new Cue is added after Cue 5, with its timing set to
Start, and with a time offset of 1.5 seconds.

Ctrl Set (Yellow Modifier)

Hold down [yellow/Ctrl/Command] to access and display the Control set.
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This button… does this…

Opens a properties window for the Live tab.

Opens the Cuelist properties window for the Editor Cuelist

Opens the Insert Command window where you can add a
command to the Cue you are editing (i.e. to play another Cue)

Sets the selected events to release the feature. Refer to
Chapter 7 for more information on release events.

Merges the events in 2 or more selected Cues into a single
Cue. Select the Cues in the Cue navigator bar.

Shows or hides tracked events in the timeline. Tracked events
are shown in a lighter, transparent color and cannot be
selected.

Clears all features from the selected fixtures so that they
return to their previous state.

Sends the selected fixtures to their Home settings

Blocking copies any tracked events into the selected Cue and
prevents any later changes to earlier Cues from tracking
through. This means no matter what changes are made to
other earlier Cues in the list, the Cue will play back the exact
look it had at the time it was blocked.

For more information on blocking, refer to Blocking a Cue in
Chapter 9: Working with Cuelists.



Chapter 4: Using the Interface 33

This button… does this…

When a Superblock Cue runs, any features for the fixtures in
the Cue that do not have values in this Cue are automatically
sent to their home value. This means that the Cue will look as
it would if no other Cuelist was playing.

Removes redundant events from the selected blocked Cue.
This means that if the selected Cue includes an event that is
exactly the same as an event that is tracking through from a
previous Cue, that event will be removed. Unblocking will not
change the Cue’s look.

Opens the Move in Black window where you can Mark a Cue
and add MIB events that pre-set the selected fixtures so that
when they turn on you don’t see them moving, changing color,
etc….

Ctrl + Alt Set (Blue Modifier)

Hold down [blue/Ctrl+Alt/Control] to access and display the Control-Alt set.

This button… does this…

Shows selection order numbers on the fixture icons.

Shows timeline events for tracked features.

When Cue Only editing is on all new Cue events will be
automatically undone (untracked) in the next Cue. For more

information on cue only editing, refer to Working in Cue Only
Mode in Chapter 9: Working with Cuelists.

Unused.

Unused.
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This button… does this…

Opens the event timing window to set timings for a specific event
(or selection of events) in the timeline.

Align the start point of all selected events in this Cue.

Align the end point of all selected events in this Cue.

Unused.

Unused.

Stops all running Smart Effects.

Unused.

Configuring the Soft Buttons
To change the function of a soft button, right-click on the button and choose a command or

function from the popup menu. Any command from any menu can be assigned to the soft
button. To change a button on one of the alternate button sets hold the appropriate modifier
key while right-clicking.

User Softkey Toolbar Labels
The soft buttons correspond to the hardware buttons above the main screen on L-series

consoles. To make it easier to identify the buttons you can add on-screen labels below the
buttons. To do this select View->Console Softkey Labels.

Vista places the softkey labels toolbar at the top of the window:
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The Sidebar

The sidebar provides access to different features depending on the window you have open:

· In the Patch window you use the sidebar to select fixtures from the library and

configure them.

· In the Console window you use the sidebar to select components (i.e. Cuelists,

Groups, Presets and more) and assign them to the Playback sets. You can also
assign fader and button functions to the playback controls.

· In the Fixture Chooser and Timeline the sidebar contains the Feature Browser (i.e.

Intensity, Position, Color, Gobo, Beam), Component panels (i.e. Groups, Presets,
Extracts, Effects and more) and the Smart FX panel.

There is no sidebar in the Playback Control and User Configurable windows.

Undocking and Re-docking the Sidebar Tabs
To undock any of the sidebar tabs, click on the title bar and drag it away from the sidebar or
select the Undock option from the panel’s menu.

To re-dock the window double-click on the title bar.

You can adjust the width of the sidebar by clicking on the window divider and dragging to the
left or right.

Toolbars
The Patch, Chooser, Timeline, and Playback windows have optional toolbars that provide
buttons for sets of menu commands. To show or hide any of the optional toolbars select
View->Toolbars when working in a window that supports them. For more information on the
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functions available via these toolbars, refer to the toolbar-specific sections in the Patching
Your Rig, The Fixture Chooser Window, and Playback Control Window chapters.

Dockable Windows
Many windows in Vista are “dockable windows”, These can be docked inside the main
window, docked to one of the external windows, or it can be positioned anywhere on any
monitor on your system in an “undocked” state.

To un-dock a dockable window, click on the header bar and drag it off the main window. To
dock a floating window, you can drag it inside the fixture layout or timeline panel and drop it on
the left, right, top, or bottom of the panel; or you can  re-dock a floating window to its previous
dock location by double-clicking on the window’s title bar.

The User Configurable Window
Each of the first five windows are explained in detail in their own chapters within this manual.
The User Configurable window, however, is a little different from the other main windows. As
the name implies, you can add any number of dockable windows to this window and lay it out
in a way that works best for you. Some of these dockable windows are for informational
display; others let you work with various aspects of Vista’s features. The windows you can
choose from include:

· A Quick Picker window

· A Fixture Chooser screen

· An Output display window (Refer to Chapter 17: The User Configurable, External,

and Dockable Windows)

· A Playback window

· A DMX display window

· A Multi-quick Picker window

· A Parked Fixtures window

· A Vista Statistics window

· A Clock window

· A Timecode window

· A Command Line keypad

The External Windows

In addition to the User Configurable window, there are also two external windows available via
the View menu. These bring up a new full-screen window on a second or third monitor

connected to your computer, containing a new User Configurable window (see above). These
let you add to the flexibility of the Vista system by providing access to more of Vista’s controls
and displays simultaneously. If these monitors are touch-screen monitors, Vista will
recognize the touch-screen input from these monitors.
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Window Workspaces

Vista allows you to store the arrangement and state of your user interface windows into a
Snapshot. This allows you to quickly recall a window layout that best suits your current mode
of working with Vista. For example, you may like on arrangement of windows when you are
patching and testing a rig; another layout when programming your show; and yet a third layout
when you move into the actual performances. Through the Snapshots, you can store these
three arrangements of windows for quick recall by activating its snapshot. For more
information, refer to the Snapshot section of Chapter 16: Using the Console Window.
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Chapter 5: Patching Your Rig

Once you’ve launched Vista and created a new show you can patch your fixtures the way you
want them using the Patch window. If it’s not already open click on the Patch icon from the
User Softkey Toolbar, or select View->Patch. Vista displays the Patch screen:

This is where you set up all the fixtures in your rig. You tell Vista which DMX channels each
fixture is assigned to, and in which universe, and can set a range of features to customize
how each fixture operates. 

Patch Window Toolbars
The toolbars available for the Patch window include View, Fixture Macro, and Connections.
These toolbars can be activated via View->Toolbars. Each of these tool bars will be described
in the sections they correspond to.
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Adding Fixtures to the Patch

Fixtures can be patched via a simple drag & drop approach; by utilizing the Patch tab in the
lower half of the sidebar; or by using the command line. For command line patching, refer to
Chapter 19 – The Vista Command Line.

The Fixture Library in the upper half of the sidebar gives you a few ways to add fixtures to the
patch. You can:

· Choose a fixture from the Factory folder, which lists the most up-to-date fixtures in

the Vista Fixture Library by manufacturer and then by fixture name in alphabetical
order.

· Choose a fixture from the Generic list, which includes fixture profiles that match

many common fixtures.

· Choose a fixture from the User list, which includes all fixtures that you have created

or imported.

· Choose a fixture by first typing in the Search box to filter the list down to just those

fixtures that match what you’ve typed.

Choosing a Fixture from the Fixture Library
To add a fixture from the Fixture Library:

· Click the ”+” symbol beside Factory, Generic, or User in the Fixture Library. Vista

displays a list of manufacturer’s folders for the Factory and User folders; it displays
a list of fixtures for the Generic folder.

· For the Factory and User folders, click the ”+” symbol beside the name of the

manufacturer for which you want to display the list of fixtures.

· Scroll down the list until you find the fixture you want. The number in parenthesis at

the end of the fixture profile name is the number of addresses (channels) that fixture
profile utilizes.

Adding the Fixture to the Patch Panel
Once you’ve selected the fixture you want, there are two ways to add it to the patch panel:

· You can drag and drop one or more copies of a Fixture Profile onto a specific DMX

location on the panel.

· You can use the Patch tab to place one or more copies of the fixture profile onto the

patch panel.

Dragging and Dropping Individual Fixtures
To patch fixtures this way, just click on the name of the fixture profile in the Fixture Library. If
desired, change the quantity in the Patch tab of the sidebar and set the desired starting fixture
ID number. Drag the fixture(s) over to the spot on the patch panel where you want it.
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When you drop the fixture, Vista fills the required number of DMX addresses with that fixture’s
details. This example shows eight Chroma-Q Color Force II 72 fixtures that use 24 DMX
addresses each, dropped onto addresses 1 of universe 1:

If you specified a fixture ID that is already in use, Vista will automatically change it to the next
available fixture ID.

Vista represents the fixture as a solid colored bar with an ID number before the name. The
colored bar fades darker at the start of the bar to make it clear where a new fixture begins in
the patch. The bar covers as many DMX addresses as the fixture needs, and some fixtures
will take up more addresses than others.

Fixtures that are selected will show in a different background color according to the Vista
Window Theme currently selected. In the Theme used for this manual, selected fixtures show
with a lighter blue background. If you click anywhere else in the patch panel, Vista de-selects
any selected fixtures.

In our example above the selected fixture is called ”2:CF27RA4”. This title consists of two
components:

· A unique ID number “2”, that Vista assigns automatically if you don’t specifically

specify a fixture number. This number identifies the fixture uniquely within the whole
system (i.e. no two fixtures will ever have the same unique ID number).

· A label (CF27RA4), which you can change if you want in the Label field on the

Properties tab. The default label is a short version of the fixture profile name.

Patching Multiple Fixtures with the Patch Tab
If you prefer not to use drag & drop to patch your fixtures you can use the Patch tab in the
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sidebar. You use this feature to add multiple instances of a fixture at once. To do this:

1. Select the fixture you want from the Fixture
Library.

2. If not already selected, click the Patch tab to
display the Patch box.

3. In the Quantity field, enter how many of this
type of fixture you want to add.

4. If you want to give the fixture a different name,
type it in the Label field.

5. If you want to assign a specific set of unique
ID numbers to this group of fixtures, click in
the Fixture Number field and set the unique ID
number (for example, 44) you want for the
first fixture in the group. If you don’t set this,
Vista assigns the next valid number. If you
accidentally specify an ID that’s already in
use, Vista will ignore this value and assign
the next valid fixture ID number instead.

6. Type a number in the Multi Patch box if you
want multiple copies to be patched as one fixture. Use this option, for example,
when patching multiple dimmers as a single fixture.

7. In the DMX Universe field, Vista automatically displays the number of the currently
selected universe. If you want to add these fixtures to another universe, enter the
universe number.

8. In the DMX Address field, set the number of the DMX addresses where you want
this group of fixtures to start. If you’ve already added any fixtures to this universe,
Vista displays the next available addresses.

9. If you prefer, you can patch fixtures to an absolute address—for example, typing
513 in the Absolute Address field automatically sets the DMX Universe to 2 and the
DMX Address to 1. If you’ve already added any fixtures to this universe, Vista
displays the next addresses in sequence.

In the Spacing field, Vista displays the number of addresses each instance of the fixture
you’ve selected will take up. If you want to leave empty addresses between each fixture you
can increase this number. For example, if a fixture normally uses twelve addresses and you
increase this number to 14, Vista leaves a gap of two addresses between each fixture in the
group.

When you’ve set all the fields the way you want them, click the Patch button. Vista adds the
group of fixtures to the patch panel.

If you’ve already added a number of fixtures between (for example) addresses 10 and channel
50, and you add another batch starting at address 1, Vista fits as many of them as it can into
addresses 1 to 9, then “flows” the rest over to address 51.
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Patching Multi-part Fixtures
Some fixtures can’t be patched in a consecutive block of addresses. For example, the
generic fixture CMY Scroller Dimmer represents a standard theatrical fixture with a color
scroller accessory attached to it. For this situation, the fixture’s lamp would be patched to a
standard dimmer channel, but the scroller accessory would likely have a completely different
DMX starting address—perhaps in a completely different DMX universe. Therefore, there is
an extra step in patching multi-part fixtures.

When you drag the CMY Scroller Dimmer profile over to the patch panel, the scroller part of
the fixture gets patched to where you drop it in the patch panel. The Dimmer part of the fixture
is added to the fixture pool window, a holding place for unpatched fixtures, right below the
Patch panel. This part of the fixture can then be dragged to the appropriate universe and
channel in the patch panel. 

Adding Custom Fixtures to the Fixture Type List
Occasionally you may encounter a fixture that’s so new a fixture profile hasn’t been added to
the stock Vista library of fixtures. In this case, you may receive a fixture profile from Vista
technical support, the manufacturer, or perhaps even another Vista user.

To add this fixture to the fixture library, simply pick Patch->Import Fixture Profiles. You’ll be

asked to select a folder where Vista can find the profile you wish to import. This folder can
contain fixture profile files, or it can contain folders representing fixture manufacturers, and
within those folders are the fixture profile files. Select the folder containing this folder & file
structure and click the Next button.

Vista now presents you with a collapsible list of manufacturers and fixture profiles it finds in
this folder structure. Place check marks next to the fixtures you desire to import and click the
Import button:
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The fixtures will now be added under the User folders in the Fixture Type list of the Patch
window:

Should you encounter a fixture for which there is no fixture profile available, you have several
options:

1. Check the Chroma-Q website to see if the fixture is available in a fixture library
update.

2. Request a fixture profile from Technical Support via the Chroma-Q website.
3. You can also create your own fixture profile using Vista’s Fixture Editor program.

Refer to Appendix 5 – The Fixture Editor to learn more about the Fixture Editor.

Changing Universes
Because a universe can only have a maximum of 512 addresses, each universe can only
handle a certain number of fixtures, dependent upon the number of DMX channels each
fixture needs. To add fixtures to another universe, click another Universe tab at the top of the
patch panel to display the DMX channels for that universe.
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Labelling Universes

Each universe can be assigned a label of your choosing to replace the Default “Universe 1”
style label. For example, if Universe 3 is used for all your Front of House fixtures, you could
rename that Universe “FOH”.

To do this, right-click anywhere within the patch panel and pick the Label Universe option. The
Label Universe window will appear; enter a new name and press the OK button.

Re-arranging Fixtures on the Patch Panel

Moving Fixtures Around the Patch Panel
Once you’ve added fixtures to the panel you can rearrange them however you want. Just
select the fixtures you want and drag them to a new address; when you drop them on the
screen, Vista re-arranges them all from that new starting address. To drag to a different

universe, first drag the fixture up to the tab for the destination universe and pause; after a
moment that universe will come to the foreground, and you can continue to drag the fixture to
the address you desire on that universe.

If there is a conflict or overlap of addresses, vista will indicate so, by turning the shading red.
Additionally, Vista will not allow you to place them in such a way that any of the channels will
“fall off” the end of the universe.

Fixture Pool
If you find yourself in a position where you need to temporarily remove a fixture from the patch
but don’t want to delete the fixture from your show—for example, perhaps you realize that you
have an address assignment conflict with your fixtures and haven’t figured out what a fixtures
new address should be, but need to free up the channels it’s currently assigned to—you can

drag that fixture from the patch panel down to the fixture pool to unpatch it. Then, when you
know what address that fixture is being reassigned to, you can drag it out of the fixture pool
and to its new address in the patch panel. Placing all the fixtures in the pool is also often used
after fixture swapping to a different fixture type, before moving to a new venue with a different
set of addresses.

Relabeling Fixtures
To relabel one or more fixtures, select them in the universe panel and choose the Properties
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tab in the sidebar.

Enter the label you want to give the selected fixtures in the
Label field and hit Enter. Vista relabels all the fixtures you had
selected. You can also assign a new label to the selected
fixtures by right-clicking and pick the Label Fixtures option.

Renumbering Fixtures
To change the unique system-wide ID number of a single fixture:

1. Select the fixture in the universe panel.
2. Choose the Properties tab in the sidebar.
3. In the ID field, enter the new ID number and hit Enter on your keyboard.

Renumbering Multiple Fixtures

To renumber more than one fixture:

1. Select the fixtures you want to renumber in the Patch panel.
2. Right-click and select renumber. Vista displays the Renumber window:

3. Set a start number for range of fixtures. If the selected number is already in use,
the text “(invalid)” will appear next to the number, in which case you need to change
the number to an unused fixture ID. 

4. Click OK to complete the renumbering.

Deleting Fixtures
You can delete fixtures from the patch at any time. To do this:

1. Select the patched fixture in the patch panel.
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2. Press the Delete key on your keyboard, or select Patch->Delete Fixtures, or right-
click in the Patch Table and select Delete Fixtures.

Customizing Gobo and Color Wheels
If you have changed the gobos or colors in fixture’s wheels you can customize the fixture so
that the correct images show in the chooser window. To do this:

1. Select the fixture(s) in the universe panel.
2. Select the Customize Gobo and Color wheels option from Properties tab in the

sidebar. Vista opens the Customize Gobo and Color Wheels window:

This field… does this…

Collection Name When you customize colors or gobos for one fixture,
a collection is automatically created and you can
apply it to other fixtures. Once a new collection is
created, the collection name will show up in the
Custom Wheel Collections list in the lower part of
this window.

Color Wheels Displays the colors in the fixture’s color wheel. To
change a color click on the existing color and select
a new color in the Selected Slot section.

Gobo Wheels Displays the gobos in the fixture’s gobo wheel(s). To
change a gobo click on the existing gobo and then
click the Select Image button in the Selected Slot
section. To use a gobo from the existing image
library navigate to the
FixtureTypeLibrary\Images\gobos folder in the Vista
3 program folder.

To use a custom pattern, create a 128x128px JPEG
or PNG file and select that image after clicking the
Select Image in the Selected Slot section. The
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This field… does this…

image file will be copied to the Fixtures\Images folder
in your Vista 3 data folder.

Selected Slot Name Allows a descriptive name to be added to the color
or gobo.

Slot Type Sets the slot type to a color or gobo. You can add
colors to gobo wheels and vice-versa.

Category Allows you to group a gobo into a category. This is
used to match similar gobos when swapping fixtures
or copying programming between fixtures that do not
have the same gobos.

Select
image/Select Color

Click this button to select a gobo image or color.

Custom Wheel
collections

Allows you to select a color or gobo collection and
apply it to the selected fixture.

Reset to Factory
defaults

Resets the color or gobo wheels in the selected
fixture to its factory default configuration.

Setting Fixture Properties
Once you’ve added the fixtures to the patch panel and placed them where you want them, you
can set a number of properties for each fixture using the Properties and Transforms tabs in
the sidebar.

To view and set the properties for one or more fixtures, select the fixtures you want on the
patch panel. Vista displays the details of those fixtures in the Properties and Transforms tabs:
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If you select multiple types of fixtures, Vista displays the details of the first type you selected. If

necessary, select the Properties tab to display the Properties box.

Properties Tab

This option… does this…

Label The name you entered or that Vista assigned to this fixture
when you dropped it onto to the patch panel. You can edit
this here if you want to.

ID The unique system-wide ID number assigned to this
fixture when you dropped it onto the patch panel. You can
change this number here if you want to, but be aware that
Vista won’t allow you to use a number that’s already
assigned to another fixture.

Type This field displays the fixture model type and is not
editable. To change the type of fixture without having to
remove the fixture click on the Change Fixture Type button
(see X Swapping a Fixture TypeX ).

Customize Gobo
and Color Wheels

Click this button to open the Customize Gobo and Color
wheels window. You can change the color and gobo
wheel settings for the selected fixture in this window.
These changes are saved with the show file—not to the

fixture file.

Change Fixture type Click this button to change the type of fixture without
having to remove it from the patch. (see X Swapping a
Fixture TypeX ).

Notes This field is used to display notes about the fixture. You
can add whatever you like in this field.

Transforms Tab

This option… does this…

Preheat A percentage value that sets a minimum intensity the
fixture lamp will sit at until you switch it on. This is useful
for lamps such as PAR64s that take time to switch on
from a cold start. For example, a 1% intensity probably
would not be visible on stage but would keep the filament
warm.

Limit A percentage value that determines the maximum
intensity the fixture will ever reach. This is useful if you
want to prolong lamp life or prevent fixtures from ever
reaching full intensity.

Dimmer Curve This popup lets you select a dimmer fade curve. Refer to
Chapter 10: The Timeline Window for a description of the
various fade curve options.
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This option… does this…

Preview in Chooser Check this box if you’d like the fixture icons, in the
chooser, to display the effects of the Intensity transforms.
If unchecked, the Chooser window will (for example)
always show a fixture fading up in linear time regardless of
the fixture’s dimmer curve property. If you check this
option, the Chooser window will visually represent the
dimmer curve set here.

Invert pan Selecting this checkbox reverses the sweep of the pan for
this fixture. This is useful when you’re coordinating the pan
directions of fixtures hung in different directions.

Invert tilt Selecting this checkbox reverses the sweep of the tilt for
this fixture. This is useful when you’re coordinating the tilt
directions of fixtures hung in different directions.

Swap pan/tilt Selecting this checkbox swaps the pan and tilt controls,
so the fixture will pan when given a tilt command and vice-
versa. This is useful for coordinating the movements of
fixtures hung on vertical trusses or pipes.

Preview Check this option to see the effect of the position
transforms shown on the fixture chooser icons. If
unchecked, the Chooser window fixture icons will (for
example) always show the directional arrow fixtures
position operating in the same way, regardless of whether
the user had (for example) set the tilt to inverted.

Invert Pan Encoder Inverts how the pan encoder knob affects the pan function
of this fixture.

Invert Tilt Encoder Inverts how the tilt encoder knob affects the tile function of
this fixture.

Advanced Transforms

The advanced button provides access to more Fixture ”Transformers” that allow you to
further customize fixtures. For example, the Pan and Tilt Offset features allow you to correct

the home position for fixtures that are hung at an angle.

To add a transform, click the Advanced button to open the Fixture Transforms window, then

click the Add button to choose a transformer.
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Some of the transformers are also available from Transforms tab as described above; setting
one of these options changes the setting in the Transform tab.

This option… does this…

Minimum Sets the minimum (percentage) value for this feature.
For example, setting a value of -25 on Pan means the

fixtures will only pan left 1/4 of their normal range.

Maximum Sets the maximum (percentage) value for this feature.
For example, setting a value of 25 on Pan means the

fixtures will only pan right 1/4 of their normal range.

Offset Sets the offset angle. For example, setting a Pan

offset of 45 would move the fixtures Home position by
45 degrees.

Value Curve This popup lets you select a fade curve. Refer to
Chapter 10: The Timeline Window for details of the
various curve settings.

Invert Tick this box to invert the output value.

Preview in Chooser Check this option to see the effect of the transform
shown on the fixture chooser icons. If unchecked, the
Chooser window will (for example) always show a
fixture fading up in linear time regardless of the
fixture’s Dimmer Curve property. If you check this
option, the Chooser window will visually represent the
dimmer curve set here.
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Channels Tab
This is a list of the features and channel numbers of the fixture and which DMX address is
controlling each feature. This is for informational purposes only and cannot be changed.

Macros Tab

This tab allows you to edit the Strike, Douse, and Reset macros for the selected fixture(s).

A macro consists of one or more commands separated by semicolons. 

The syntax of a command is:

[channel] @ [value] # [wait time (in milliseconds)] 

Part Definition

channel The channel of the fixture feature to be affected. This is not the DMX
address to which the fixture is patched. The channel number can be
found in the Channels tab in the “Fixture” column.

Value The decimal value to which the channel should be set. This value will
be held until the entire macro finishes running, or another command
changes the value.

Wait time The amount of time in milliseconds before the next command in the
macro runs. If this is the last command in the macro, it’s the amount of
time before the macro ends.

For example:

15@249#4000;15@0#2000
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This macro sets channel 15 to the value 249 and then waits for 4 seconds. Then, it sets
channel 15 to 0 and waits for 2 seconds. Then, the macro ends and channel 15 will return to
the value it was set at prior to the macro running.

Some fixtures require more complex macros. For example, a fixture might require; channel 1

to 255, ch4 to 17, channel 6 to 1, channel 8 to 0, channel 11 to 0, and channel 15 to 84, all

simultaneously and for these channels to be held for 6 seconds.

In this case each command must state a wait time. For the example above the macro would
be:

1@255#0;4@17#0;6@17#0;8@0#0;11@0#0;15@84#6000

Because the wait time for the first five commands is 0, the next command is run immediately.
And because the value of a channel is held until the entire macro completes or another
command in the macro changes it, the values for all these channels are held for 6 seconds
(set by the last command) until the macro ends.

If you add or modify a fixture macro the new setting is automatically applied to all fixtures of the
same type.

Viewing the Patch in Different Ways
Vista gives you three different views of your patch so you can get different types of information
about the patch. To change the view, select the Table, List, or DMX option from the View

menu or click one of the three corresponding buttons in the View toolbar:

Table View
The Patch screen defaults to the Table view, as shown earlier in this section. This is the view
you will use most of the time; here you can drag and drop fixtures into the patch panel for
each universe of 512 addresses and arrange them the way you want them.

List View
If you choose the List option Vista displays the fixtures as a list with columns for the fixture:
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You can choose the columns you want to show or hide by right-clicking in the header row and
choosing the fields you want from the popup menu. You can also re-arrange the columns by
clicking on the column name and dragging it to the left or right. The default column
arrangement is: 

1. Fixture label (as shown in the chooser window)
2. User ID number
3. Name 
4. Fixture Type
5. Patch part – for fixtures which re patched in 2 or more parts. For example, some

fixtures have an Intensity part that is patched separately from the other fixture
features.

6. DMX Universe
7. DMX Address

If you click on any of the column headings the list will sort by that column. Click again to
change the sort from ascending to descending or vice versa.

You can show or hide columns by right-clicking in the header area and selecting the columns
you want displayed, show all the columns, or search through the patch list.

DMX View
If you choose the DMX option Vista displays a table view where each cell shows the DMX
addresses and their output level:
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You use this screen to display the output values of all DMX addresses. Each cell displays the
channel number and it’s DMX output value. The cells are clear if there is no output and
change to a highlighted box if the output is adjusted. 

Fixture Macros and Parking
The Patch menu includes commands to control whatever fixtures are currently selected on
the Patch panel. There is also the Fixture Macros Toolbar for three of these commands:

Note that only some fixture types support these functions, lights with an LED source (for
example) will not. Refer to the user guide for your fixture types to see if they support these
functions. Fixtures that do support Lamp On, Lamp Off, and Reset will come with the macros

already defined in the fixture profile for these functions; should there be a need to modify
them, see the Macros section earlier in this chapter.

This command… does this…

 Lamp On

Ignites the lamps in the selected fixtures.

 Lamp Off

Switches the lamps in the selected fixtures off.

 Reset

Reset triggers a fixture-implemented reset function, which usually
causes the fixture to perform a full mechanical reset and
calibration. This is useful if a fixture has a mechanical problem and
you need to get it ”back to normal”.

Park Holds the fixture in its current settings. For example, you might
use this to provide fixed lighting for backstage, or to set your house
lighting to a specific level while programming your show during
rehearsals. Once you’ve parked a fixture it will ignore all
instructions until it is un-parked. You can, however, continue
program Cues with settings for these fixtures—you just won’t see
the fixtures reflect these settings until they are unparked.

Unpark Sets a parked fixture to operate normally again.
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These five commands are available through the Patch menu and by right-clicking on the fixture
icons in the Fixture Chooser or Patch window.

Cloning Fixtures
Cloning is a special way to add fixtures to your patch. This method is useful if you’ve already
programmed your show and want to include some new fixtures automatically in any Cuelists,
Groups, and Presets that you’ve created.

To clone one or more fixtures:

1. Select the fixture(s) you want to clone from the patch panel, list view, or fixture
pool.

2. Select Patch->Clone Fixtures or right-click on the patched fixture and select Clone

from the popup menu. Vista creates a clone of the selected fixture(s) in the fixture
pool at the bottom of the Patch window

3. Drag the cloned fixture(s) into the patch table at the universe and address they are
set to.

In every Cue and component where the original fixture appears, the clone will also be
represented with the same settings as the original. This is a huge timesaver if you need to
add a fixture into your show to provide additional coverage similar to a pre-existing fixture in
your show.

You can change the fixture type of the cloned fixture(s) by selecting Patch->Change Fixture

Type.

Exporting and Importing Patch Information
To save time, you can import and export patch information from comma-separated value
(CSV) files.

Exporting the Patch
You can export a CSV file containing your current show’s patch information. To do this, select
Patch-> Export Patch File.

Importing a Patch
You can also import a CSV file containing your patch information. You can import a file that
you have exported from another show or you can create a file in a text editor or spreadsheet
program. The easiest way to do this is to create a spreadsheet laid out as follows and save it
as a CSV file using the Save As function.

ID Univ:Adrs Fixture Type Fixture Name

11  1:1  Robin 1200 LEDWash Mode 1  Robin 1200

12  1:46  Robin 1200 LEDWash Mode 1  Robin 1200
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13  1:91  Robin 1200 LEDWash Mode 1  Robin 1200

1  2:1  Mac Viper Profile 16 bit  Viper 1

2  2:27  Mac Viper Profile 16 bit  Viper 2

3  2:53  Mac Viper Profile 16 bit  Viper 3

21  2:261  Robin Pointe Mode 1  pointe 1

22  2:285  Robin Pointe Mode 1  pointe 2

23  2:309  Robin Pointe Mode 1  pointe 3

111  4:1  Dimmer  Blue

113  4:2  Dimmer  Blue

115  4:101+4:3  Scroller Dimmer  Blue

204  4:401  LED - RGBAW  Stage 1

203  4:406  LED - RGBAW  Stage 2

101  4:421
 Source Four LED Series 2 Lustr
Direct - Strobe off - Fan auto  Profiles

102  4:429
 Source Four LED Series 2 Lustr
Direct - Strobe off - Fan auto  Profiles

In this example the spreadsheet has a header row, which is optional, but shown here for
explanation. The columns are laid out like this, with the first fixture from above used as an
example:

1. An ID (1), which determines the fixture’s unique ID.
2. A Universe : DMX address number (1:1), that sets the Universe and DMX start

address for this fixture.
3. A Fixture Type (Robin 1200 LEDWash Mode 1), that sets the type of fixture that will

be patched.
4. A Fixture Name (Robin 1200), that sets the fixture name.

For two-part fixtures (i.e. fixtures with an external dimmer that is patched separately) you
need to include both parts of the patch in the Universe/Address column. The format for the
two parts is Control+Intensity.

In the example above, Fixture ID 115 is a Scroller Dimmer with the scroller part patched to
Universe 4 Channel 101 and the Intensity part patched to Universe 4 channel 3.

The ID, Universe:DMX Address information and Fixture Type must be in the CSV file. If you
don’t specify a valid Vista Fixture Type, Vista prompts you to choose the correct fixture from a
list when you import the file. The fixture Name does not need to match the name used in Vista
 library.

To perform the import, select Patch->Import Patch File.

Configuring the DMX & Ethernet Outputs
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Vista automatically connects Universes to the DMX outputs on your console but not to
devices connected via Ethernet. To add or change connections you select Patch->Connect

Universes, or click the Connect Universes button on the Connections toolbar ( ),

to open the Connect Universes screen:

You use this screen to connect Vista’s DMX outputs to external Ethernet-DMX interface
boxes, and to broadcast Art-Net and streaming ACN (sACN).

Vista’s USB-to-DMX interfaces and consoles provide one or more 512-channel DMX outputs.
You can add more outputs by connecting your own external sACN, Art-Net, or PathPort

devices to the Ethernet network.

This window shows any devices connected via Ethernet or USB and the connection details of
the universe. You use it to set up the DMX connections for each of your universes and to
check that they are working correctly.

You can also connect more than one output to the same Universe. For instance, you can

connect Universe 1 to DMX output 1 and to an Art-Net broadcast device.

To disable the output of a specific protocol, uncheck the Output Enabled checkbox.

Connecting Universes to Hardware DMX & Ethernet Outputs
The Connect Universes window lists all the console DMX connections, USB-DMX, Ethernet-
DMX connection boxes, and Art-Net compatible devices attached and visible to Vista:
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In this example above you can see several entries: two are the built-in DMX connections for
the attached MV console, and two are the built-in DMX connections for the attached EX
console. There are also four Ethernet based streaming DMX universes shown as well.

If you can’t see a device that you’ve attached to your lighting Ethernet network, it is generally still
possible to connect to it by using the Art-Net broadcasting mode or by using sACN.

To connect a console or console DMX output:

1. Find the row that corresponds to the DMX output.
2. Click on the box in the DMX Universe column and either type a Universe number or

use the up and down arrow buttons to select the Universe you want.

To connect an external interface box:

1. Find the row that corresponds to the Interface box output. Some boxes will have
multiple outputs.

2. Click on the box in the DMX Universe column and either type a Universe number or
use the up and down arrow buttons to select the Universe you want.
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Disconnecting an Output

To disconnect a DMX output or interface box:

1. Find the row that corresponds to the DMX output
or interface box output.

2. Click on the box in the DMX Universe column and
either type 0 or use the down arrow buttons to
select the ”Not Assigned” option.

To change the settings of an interface box you may have to
disconnect it and re-connect it with the new settings.

Art-Net Broadcast Mode
Some Art-Net compatible devices may not appear in the Connect Universe window. In this
case you can set Vista to broadcast Art-Net information without first establishing
communication with the device. You can broadcast up to 256 universes. To add an Art-Net
Broadcast output do this:

1. In the Connect Universes window click on the Add Network Connection button.
2. Select “Art-net Broadcast port”.
3. Enter the Sub-net and Universe then click the Add button. Note that in Art-Net, the

first Sub-net and Universe are both 0, not 1.
4. Back in the Connect Universes window, click on the box in the DMX Universe

column and either type a DMX Universe number or use the up and down arrow
buttons to select the Universe you want to associate with the Art-Net broadcast
port.

Within any Art-Net subnet, the maximum number of universes is 16. But you can patch more
than 16 universes by using any of the 16 different subnets.
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Streaming ACN
sACN is another method used to carry DMX packets over
Ethernet and operates in much the same way as Art-Net. To
add an sACN multicast output you do this: 

1. In the Connect Universes window click on the Add
Network Connection button. 

2. Select “Streaming ACN”.
3. Enter the streaming ACN universe number and

priority then click the Add button.
4. Back in the Connect Universes window, click on

the box in the Universe column and either type a
DMX Universe number or use the up and down
arrow buttons to select the Universe you want to
associate with the sACN port.

If sACN devices are receiving information from more than one
console (or other controller) they will respond to the one with
the highest priority.

Pathport xDMX
Vista can output to Pathport Output Nodes via the Ethernet port
on your console or computer. To connect to Pathport output
nodes you do this:

1. In the Connect Universes window click on the Add
Network Connection button. 

2. Select the “Pathport xDMX Port“ button.
3. Use the up and down arrow buttons to select the

DMX Offset. The xDMX universe will start at the next
address after the offset number.

4. Click the Add button.
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Chapter 6: The Fixture Chooser Window

The Fixture Chooser Window is where you’ll work the most for controlling your fixtures and
creating stage looks. If this is the first time you’ve opened this window you should be in the
Live tab; otherwise, click on the Live tab to make it active.

This screen consists of four main elements:
1. The Fixture layout panel, where you can display and arrange the fixture icons to suit

your requirements. Vista supports multiple layout tabs to help you group your
fixtures in logical manners. You can also add a background image (for example, a
drawing of your stage, or a drawing of your lighting pipes and trusses) to help
create context for locating your fixture icons on the layout.

2. The sidebar where you can use the feature browser and component panels to
adjust Intensity, Position, Color, Gobo, Beam, and other settings for each fixture.

3. The Multi Quick Picker panel where you can select Presets, Groups, and other
components.

4. The Command Line, where Vista commands can be entered for execution.
5. The Editor control section where you can select to work with the Live tab or any

Cuelist you have open. If you have a Cuelist open this section expands to include
the Cue navigation controls. This will be described in detail in Chapter 9: Working
with Cuelists.
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The Sidebar and Multi Quick Picker are dockable windows, and can be placed at the top,
bottom, or either side of the Fixture Chooser window. They can also be undocked (turned into
floating windows) which can be positioned anywhere on any monitor.

The Live Tab
The Live tab of the fixture chooser act as Vista's Programmer. Any feature changes made
here will have priority over Cuelists, but are not a part of any Cue programming until you
chose to store it into a Cue.

The Live tab is called "Live" as it not only displays events coming from the Programmer but
also displays fixture output coming from active Cuelists. In other words, it shows you the live
stage output.

Additional tabs to the right of the Live tab may also appear when you are editing Cuelists,
extracts, or presets.

TIP: If you are working in one of these Cuelist tabs remember that the Live tab will still have
priority over these items, so you may need to clear events coming from the Live Programmer
tab to accurately see the output of your active Cuelists.

Fixture Icons
Each fixture in your patch is (by default) represented by an icon in the Chooser layout window.
If selected, the icon’s square border will be set to yellow. The icon’s halo, or circle within the
icon, will change based on feature settings for that icon. The color of the halo will be the color
the fixture is set to, or the gel color Vista has been told the fixture has installed (Right-click on
the fixture and pick Customize Gel Color).

If the fixture has a Gobo present, the halo will have 6 black dots drawn in the element halo.
This allows you to visually identify which fixtures have active gobos at low, or zero, intensity.

If the fixture has intensity set, the fixture brightness, color, and interior pattern will reflect the
Intensity, Color, and Gobo feature settings as well.
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For fixtures that support pan and tilt, the arrow drawn within the fixture icon (as shown above)
provides some feedback as to the pan/tilt settings.

For multi-element fixtures, each element is represented by an additional circle in the icon and
generally are arranged to represent the physical element layout in the fixture. If the elements
can have their color set independently, the element’s circle color will reflect its color.

Hovering the mouse over an icon will pop up fixture information showing the fixture number,
name, profile name, and patch address.

Arranging Fixtures in a Layout
Vista displays all of the fixtures you added on the Patch screen as icons within the Fixture
Chooser’s layout panel. When you first view this screen after creating your patch, the fixtures
are arranged in numerical order, by unique ID, as a bank of icons.

To re-arrange the fixtures:

1. If necessary, click on the Locked button at the bottom of the Fixture Chooser
screen so that it changes to Unlocked.

2. Drag the fixture icons around to new locations on the screen so that they suit you.
3. To undo a move press Ctrl + Z, or select Edit->Undo.

When you are finished, click on the Unlocked button so that it changes back to Locked. This

prevents you from accidentally rearranging your fixtures when selecting them to program your
show.

If you are moving a Group icon, click and hold on it while moving to avoid selecting and moving
the individual fixtures in the group.
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Zooming In and Out

You can adjust the magnification of the fixture layout panel or the size of individual fixture and
group icons.

To zoom the fixture layout panel in or out click on the magnify icons in the bottom left corner
of the Fixture Chooser screen:

You can also zoom the fixture layout panel on multi-touch displays by pinching or unpinching
in the window.

To zoom an individual fixture or group icon, select the items you want to zoom and hold down
[yellow/Ctrl/Command] while clicking the zoom icons.

This icon… does this…

Zooms in to the layout to see more detail and fewer fixtures.

Zooms out of the layout to see more fixtures and less detail.

Zooms to fit the selected fixtures in the view.

Zooms out to where all fixtures fit into the view.

You can also use the wheel feature on a suitable mouse to zoom the layout.

If you zoom in to the point that you can no longer see the entire layout, horizontal and vertical
scrollbars will be added to the layout window. Additionally, holding the [green/Alt/Option] key
will turn the mouse pointed into a hand, and you can use the mouse to drag the layout to
reposition it.

Working with Multiple Fixture Chooser Layouts

You can create multiple fixture layouts, each individually arranged to suit user preference, and

appear as a new tab along the bottom of the Fixture Chooser screen:

To create a new layout tab:



Chapter 6: The Fixture Chooser Window 65

1. Right-click in the Fixture Chooser screen and select Layouts->New Layout. Vista
opens the New Layout window. You can also right-click on a Layout Tab and pick
New Layout.

2. Type a name for the layout and click OK. Vista creates a new layout and adds a
corresponding tab at the bottom of the layout panel: 

3. Arrange the fixtures as described above.
4. When you are finished Click on the Unlocked button so that it changes back to

Locked.

To switch between layouts, click on the tab you want to use. Fixture selection is maintained

across layout tabs, so you can select fixtures on one tab, switch to another tab, and add more

fixtures to the selection.

You can re-arrange the order of layout tabs by clicking and dragging the tab left or right.

Managing Layout Views
You can add, rename, duplicate, delete, or modify a layout view. To do this select Chooser-

>Manage Layouts, or right-click on a Layout tab and pick Manage Layouts. Vista opens the
Layouts window:

The layout window is divided into three panels: Layouts, Layout Properties, and Item Visibility.

Layouts
The Layouts panel shows all the layouts you have created. You can:

1. Rename a layout by double-clicking on the name and typing a new one.
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2. Change the order of the layout tabs by selecting a layout and moving it up or down
within the list using the Move Up, Move Down, Move to Top and Move to Bottom
buttons.

3. Add a new Layout by clicking on the Add Layout button.
4. Delete a layout by selecting it and clicking on the Delete Layout button.

This icon… does this…

<< Moves the selected layout to the top.

<< Moves the selected layout up.

>> Moves the selected layout down.

>> Moves the selected layout to the bottom.

+ Adds a new Layout.

- Deletes the selected layout.

Layout Properties
The Layout properties panel lets you configure how a layout displays names, IDs, and other

properties. Select the layer you want to configure in the Layouts panel, and the properties for
that layout appear in the Layout Properties panel where they can be modified.

This option… does this…

Lock positions Locks the layout so the fixtures cannot be moved. You
can also lock and unlock a layout using the
Locked/Unlocked button beside the layout tabs in the
Fixture Chooser screen.

Fixtures Show
Intensity Value

Sets the intensity numeric value to display in the center
of the fixture icon.

Show Labels Sets the fixture icons to display the labels of the
fixtures.

Show IDs Sets the fixture icons to display the ID numbers of the
fixtures. If this is turned off, the fixture ID numbers for
single-element fixtures can be temporarily displayed by
pressing [yellow/Ctrl/Command].

Elements show IDs For multi-element fixtures, the element ID is displayed
in the center of the fixture. If both this option and
Fixtures Show Intensity Value is turned on, only the
Fixture Intensity Value will be displayed.
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This option… does this…

If this is turned off, element IDs can be temporarily
displayed by pressing [blue/Ctrl+Alt/Control].

Labels ignore rotation When set, if a fixture icon is rotated in the layout, the
label stays level underneath the icon. Otherwise, the
label rotates with the icon.

Labels ignore zoom The label size remains fixed when the layout is zoomed
in or out.

Notes ignore zoom The size of the notes remains fixed when the layout is
zoomed in or out.

Auto-show new
fixtures

Sets the layout to automatically include any new fixtures
added in the Patch window.

Auto-show new
groups

Sets the layout to automatically include any new fixture
groups.

Snap to Grid Fixtures will snap to the grid spacing set below. This is
helpful in keeping rows of fixtures aligned.

Show Gridlines Display a grid on the Fixture Chooser layout pane.

Grid Spacing Sets the space between the grid lines. The higher the
number, the larger the grid (and thus snap) spacing.

Save as Default Saves all options set in the current layout as the default
for any new layout.

You can also adjust some of these settings in Chooser->Layout Options.

Hiding and Un-hiding Fixtures and Groups
You can use the Item Visibility panel to hide any fixtures, fixture types, or groups in a layout.

This removes them from the display, but not from the patch.

To hide Fixtures, Group icons, or Notes:

1. Select the Layout you want to work with from the list in the Layouts panel.
2. Expand out the Fixtures, Groups, or Notes heading in the Item Visibility section to

show all the Fixtures types that you’ve patched, the Groups that have been created,
and any Notes.

3. To hide all Fixture icons of a type, un-tick the checkbox beside that fixture type.
4. To hide all Groups, un-tick the checkbox beside Groups.
5. To hide all Notes, un-tick the checkbox beside Notes.
6. To hide individual Fixtures, expand a fixture type to show all the individual Fixtures

of that type. Un-tick the checkbox beside the individual fixtures you want to hide.
7. To hide individual Groups or Notes, un-tick the checkbox beside the items you want

to hide.
8. To reveal (unhide) hidden fixtures, tick the checkbox beside the items you want to

reveal.
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You can also hide fixture and group icons and notes by right-clicking on the icon(s) or note(s)
in the layout and selecting Items->Hide. You must use the Layouts window, however, if you

decide you want them visible again.

Layout Options
The Layout options submenu lets you quickly configure some commonly used layout
properties. To do this:

Select the Layout you want to adjust by clicking on its tab at the bottom of the Fixture Chooser
screen.

Select Chooser->Layout Options. Vista displays the submenu:

This option… does this…

Show Selection Order Sets the icons to show a selection order number
whenever they are selected.

Show Grid Display a grid on the layout pane.

Snap to Grid Fixtures will snap to the grid spacing set below. This is
helpful in keeping rows of fixtures aligned.

Show Intensity Value Displays the intensity numeric value of the fixture in the
center of the fixture icon.

Show Names Sets the fixture icon text labels to show.

Show IDs Sets the fixture icon ID numbers to show.

Labels Ignore Rotation When set, if a fixture icon is rotated in the layout, the
label stays level underneath the icon. Otherwise, the
label rotates with the icon.

Auto-add New Fixtures Sets the layout to automatically include any new fixtures
added in the Patch window.

Preview Refresh Rate Sets the refresh rate for the icons. Higher refresh rates
and / or large numbers of icons use more processing
power.

Detail Level Set the amount of detail shown as the Fixture Chooser
screen is zoomed out. High can be more demanding on
the system but provides the most detailed view.

Activating Layout Views
To activate a layout view, click on the tab for the layout you want to display. The tabs are
located along the bottom of the Fixture Chooser screen.
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Duplicating a Layout

To duplicate a layout view, click on the tab for the layout you want to duplicate then select
Chooser->Duplicate Layout, right-click in the Fixture Chooser screen and pick Layouts-

>Duplicate Layout, or right-click on a Layout tab and pick Duplicate Layout. Vista displays the

Duplicate Layout window.

Type a name for the layout and click OK. Vista creates a copy of the layout and adds a
corresponding tab at the bottom of the layout panel.

Layout Organization

There are a number of ways to customize layouts and the way the fixture icons are displayed.
To make a change select an option from the Chooser menu.

This option… does this…

Colors and Background…

Background color Opens a color picker to set the background color of the layout
panel.

Background image Opens a window to select an image to use as a background of
the layout panel.

Erase Background
image

Removes the background image, if you’ve added one.

Resize
Background

Selects the background image which can be moved or resized
by dragging on the bottom right hand corner. Click outside the
background when finished.

Restore
Background Color
to Default

Restores the Fixture Chooser screen’s background color to
the color specified by the current window theme in effect.

Shrink to fit Zooms out the layout panel to fit all fixtures.

Label position Moves the icon label for the selected fixture(s) to the right, left,
top, or bottom of the icon.

Layout Organization Popup Menu

You can also adjust the layout and icon appearance by right-clicking on the layout or icon(s) or
note(s) and selecting an option from the popup menu. The following options available through
the Fixture Chooser screen’s popup menu affect the appearance of the layout. (There are
other popup-menu options as well that will be described in the appropriate sections of this
manual.) Several of these functions, indicated by an asterisk, can also be accessed by right-
clicking on a Layout tab to access the Layout popup menu.
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This option… does this…

Layouts…

Manage Layouts* Opens the Layouts window where you can add, delete,
organize and customize your layouts.

New Layout* Opens the New layout window.

Duplicate Layout* Duplicates the current layout and opens a window to name it.

Label Layout* Opens the Label Layout window where you can edit the name
of the current layout.

Delete Layout* Immediately deletes the current layout.

Label Opens the Label window where you can type a new name for
the selected items.

Renumber Opens the Renumber window where you can assign a new
unique identifier for the selected items. If multiple items are
selected, they are renumbered consecutively from the
number you specify.

Duplicate icon For fixture and group icons, Duplicate icon creates a second
icon representing the same fixture or group for placement in
the layout. This is useful if you have a single dimmer channel
that is hard patched to two physical fixtures, for example.

Remove duplicated
icon

To remove a duplicate icon, right click the icon you would like
to remove and select Remove duplicated icon.

Items…

Hide Hides the selected fixture or group icon or note in the current
layout.

Unhide all Reveals all hidden items in the current layout.

Resize Allows you to resize the selected matrix.

Rotate Allows you to rotate the fixture icon(s), using an onscreen
handle, to any angle.

Icon Color Opens a window to set the outline color of the selected
icon(s).

Gel Color Opens a window to set the intensity color of the selected
icon(s). Useful for simulating the color filter on a conventional
fixture.

Fixture Groups

New Fixture Group Creates a new fixture group containing all the currently
selected fixtures.

Update Fixture
Group

Updates the selected group to contain all the currently
selected fixtures.
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This option… does this…

Matrix…

Create Matrix Creates a new matrix grid that you can resize by dragging on
the bottom right hand corner.

Tip: Right-click a blank space in the layout panel to enable this
option.

Resize Matrix Allow you to resize the selected matrix.

Delete Matrix Deletes the selected Matrix

Notes…

Add Note Adds a text box to the layout panel. If a fixture icon is selected
a leader line will be drawn between the icon and the text box.

Delete Note Deletes the selected note from the layout.

Set Note Color Opens a window to set the color of the selected note(s).
Changes the leader and fill color.

Find in Patch Table Switches to the Patch window, selected the universe in which
the fixture is patched, and selected the fixture in the patch
window.

Align Allows you to align a group of fixture icons to the right, left, top
or bottom of the group.

Distribute Allows you to distribute a group of fixture icons vertically
between the top and bottom fixtures or horizontally between
the furthest left and furthest right fixture in the selection.

Flip Swaps the vertical or horizontal position of a group of fixture
icons. The left most fixture will move the right most and so on.

Arrange in Arc Arranges the selected fixtures in an arc and allows you to
scale the size of the arc. (More on this later in this chapter.)

Arrange in Circle Arranges the selected fixtures in a circle and allows you to
scale the size of the circle. (More on this later in this chapter.)

Arrange in Grid Opens the Grid window to arrange the selected items in a
grid. Items can be arranged into rows and columns and
sorted by ID or selection order. (More on this later in this
chapter.)

Background…

Background Color Opens a color picker to set the background color of the layout
panel.
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This option… does this…

Background Image Opens a window to select an image to use as a background
of the layout panel. 

Erase Background
Image

Removes the background image, if you’ve added one.

Resize/Move
Background

Selects the background image which can be moved or
resized by dragging on the bottom right hand corner. Click
outside the background when finished.

Restore
Background Color
to Default

Restores the Fixture Chooser screen’s background color to
the color specified by the current window theme in effect.

Customize gel color Lets you tell Vista what gel color is installed in the fixture.

Customize color and
gobo wheels

Brings up the Customize Gobo and Color Wheels window to
let you specify wheel information for the selected fixtures.
Refer to Chapter 5: Patching Your Rig for more information.

Customize Fixture
Arrangement

For multi-element fixtures, this allows you to arrange the
layout of the elements within the fixture icon. This layout will
be applied to all fixtures of that type.

Adding Notes to the Layout Window
You can add text boxes to the fixture window to help identify different fixture types or areas.
Notes can be either attached to an object on the layout, such as a fixture, or can be
independent.

To add a note you do this:

1. To attach a note to a fixture or group, first select the item. For an independent note
make sure no fixtures or groups are selected.

2. Right-click in the fixture window and select Add Note. Vista creates a note on the
layout.

3. Type the text for the note and then click on the layout background to finish.

To move a note, first unlock the layout then click on the text and drag it to a new location. To
edit a note, double-click on the text and edit the text. To hide or delete a note, right-click on it
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and pick either Items->Hide or Notes->Delete Note.  To restore a hidden note, tick the visibility

box for it in the right pane of the Manage Layouts window.

Arranging Fixtures in an Arc
To arrange a group of fixtures into an arc, select the fixtures you want to arrange, right-click in
the layout window, and select Arrange in Arc. The fixtures will be arranged into a preliminary
arc, and handles will be available to adjust the layout:

To adjust the angle of the arc, position the mouse over one of the two lower lines joined by the
red dot that form the base of the arc, press the mouse button, and drag to adjust. To adjust
the radius of the arc, position the mouse pointer over the arc line itself, press the mouse
button, and drag to adjust. To rotate the circle of fixtures, move the mouse pointer inward

from the edge of the arc until the mouse pointer changes to the Rotate icon, and then hold
down the mouse pointer and drag the arc until it reaches the rotation point you desire.

Arranging Fixtures in a Circle
To arrange a group of fixtures into a circle, select the fixtures you want to arrange, right-click
in a layout window, and select Arrange in Circle. The fixtures will be arranged into a
preliminary circle, and handles will be available to adjust the layout:

To adjust the diameter of the circle, position the mouse pointer over the line of the circle, hold
down the mouse button, and drag the circle to the desired diameter. To rotate the circle of
fixtures, move the mouse pointer inward from the edge of the circle until the mouse pointer
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changes to the Rotate icon, and then hold down the mouse pointer and drag the circle until it
reaches the rotation point you desire.

Arranging Fixtures in a Grid
You can arrange fixtures in rows and columns. To do this:

1. Select the fixtures you want to arrange into a grid.
2. Right-click in the fixture window and select Arrange in Grid. Vista opens the

Arrange in Grid window:

This option… does this…

Rows Specify the number of rows you want in the grid. If you
enter a value here the number of columns is calculated
automatically.

Columns Specify the number of columns you want in the grid. If you
enter a value here the number of rows is calculated
automatically.

Spacing –
Horizontal

Sets the amount of horizontal space between fixtures in the
grid

Spacing - Vertical Sets the amount of vertical space between fixtures in the
grid.

User ID Sort the fixtures by ID number.

Selection Order Sort the fixtures into the order they have been selected.

3. Click the OK button to arrange the fixtures.

Placing Fixtures in a Matrix
You can put fixtures in a special Matrix container so that they can be controlled individually, or

as a whole, in an X / Y configuration. This is often referred to as pixel-mapping or bitmapping.

When fixtures are placed on a matrix you can:
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· Select the matrix and apply settings to all fixtures within it.

· Select fixtures in the matrix and apply individual settings to just the ones you have

selected.

· Apply matrix effects that run on the X and Y axis of the matrix. For example, you can

have an intensity effect that runs across the matrix like a sliding door or a color
effect that runs around the matrix like a clock hand.

· Apply an animated GIF video effect.

To create a matrix container and place fixtures in it:

1. Right-click on the fixture layout panel and select Matrix->Create Matrix option from
the popup menu. You will be prompted to specify the matrix dimensions: 

2. Vista creates a matrix container on the current layout: 

3. Adjust the size of the matrix by clicking on the handle on the bottom right hand
corner and dragging to the size you want. You can also right-click the matrix and
choose Matrix->Resize Matrix to set a new number of rows and columns.

4. Drag your fixtures into the matrix. You can either drag them one by one or as a
group. If you drag a group of fixtures onto the matrix Vista places them across and
then down the matrix in ID order.
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Arranging Multi-element Fixtures
If you have a multi-element fixture (a fixture that has more than one independently-controllable
element) and the default layout of the multi-elements doesn’t reflect how you want to view that
fixture, Vista allows you to change the arrangement of the element within that fixture type. The
new arrangement will be used for all instances of that fixture type.

1. Select one of the fixtures and pick Patch->Customize Fixture Arrangement, or right-
click in the Fixture Chooser screen window and pick Customize Fixture

Arrangement. Vista will display the Custom Fixture Arrangement window:

2. Using the mouse, re-arrange the element icons into the desired pattern. It doesn’t
matter at this point which element is which – that will get assigned in the next step.
However, if you want to see which element is currently which, hold
[yellow/Ctrl/Command] and the element numbers will be displayed. 
Note: you can select a set of elements, right-click with the mouse, and access the
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same arrangement tools available for arranging fixtures in the layout that are
described earlier in this chapter.

3. Click the next button. You are now in the Renumber Elements screen.
4. If you desire to change the assignment of element numbers within the new layout,

click on the elements in the order you want them to be numbered:

5. Click the Finish button. Vista will now prompt you about also saving the new layout
in the Vista user data folder so it can be used by other shows:

6. Select Yes if you desire this new layout to be available to other show files.

Selecting Fixtures
The simplest way to select fixtures is to click on the fixture or group icons one by one. Each
time you click on a new fixture it will be added to the current selection. To remove a fixture
from the selection, click on it again. To deselect all fixtures, click a blank space in the layout or
choose Chooser->Deselect All Fixtures.

To select a number of fixtures you can draw a marquee around (or over) the fixtures you
want. Vista provides three marquee tools. To select the tool you want, click on one of the
icons in the lower right corner of the fixture layout panel or choose one of the selection tool
options from Chooser->Selection Tool:

This icon… does this…

Draws a rectangular marquee as you click and drag across a
group of fixtures.

Lets you select fixtures by drawing a freehand shape around
the ones you want.

Lets you select fixtures by drawing a line through the ones you
want.
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Sorting Fixtures

It’s often important to sort fixtures in a certain order. For example, when you are storing

groups, applying effects, fanning features, or copying and pasting information from one set of

fixtures to another.

Vista lets you show the selection order and quickly sort fixtures based on their ID, selection
order, layout position and more.

Displaying the Selection Order
To display the selection order, choose Chooser->Layout Options->Show selection order.

Vista displays the selection order number in a small circle on the top left side of the fixture
icon:

This option is turned on by default.

Sorting Fixtures
You can sort fixtures in a number of ways. To do this, select the fixtures then click the Sort
order dropdown on the User Softkey Toolbar. Vista displays the Sort popup window:

This option… sorts the fixtures in…

Selection The order in which you selected them in the Fixture Chooser
screen layout.

ID Fixture ID number order.



Chapter 6: The Fixture Chooser Window 79

This option… sorts the fixtures in…

Random Random order. Each time you de-select and re-select fixtures
they are sorted into another random order.

Position By columns and rows, from top left to bottom right, based on
their position in the layout window.

Odd/Even Fixtures are sorted into two groups: odd fixture ID numbers,
and even fixture ID numbers.

Custom Sorts This option opens the Custom Sorts window where you can
customize and save sorts.

Creating and Managing Sort Orders
 When you select the Custom Sort option Vista displays the Custom Sort window:

You can use this window to create a new sort that includes advanced
options for grouping fixtures together, repeating applied settings, and setting

the type of fan shape that will be used when fanning a value across the
selected fixtures. 

This option… does this…

Sort Preset You can select from one of five pre-defined, non-editable sort options,

or from a sort preset you create yourself.

New Create a new sort preset with a Vista-assigned name. To change the

name, double-click on the sort preset name.

Duplicate Duplicate the selected sort preset and give it the same name as the

original preset with the phrase “Copy of” prepended. To change the

name, double-click on the sort preset name.
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Delete Deletes the selected sort preset. This is only available for custom sort

presets.

Sort by Sets the basic sort type. The options are as described above –
ID, Selection, Random, and Position.

Sort Direction Sets the sort order to ascending or descending.

Multi-element
fixtures

Group Elements causes the sort to treat the entire fixture as
one unit for the sort; Split Elements causes the sort to treat
each element in a fixture as its own sortable entity.

Ganging Allows fixtures to be grouped together, so that if you spread or
fan a feature setting across some fixtures, the settings can be
in blocks and / or repeated throughout the selection. See the
examples below.

Ganging -
Blocking

Lets you group fixtures in "blocks" of consecutive fixtures. You
can set just one block size, for example, or set several
different block sizes (e.g. first block has 4 fixtures, second
block has 6 fixtures and so on).

To set complex blocking separate the block sizes with a /
(forward slash). For example 4/6 creates a group of 4 fixtures
and then a group of 6 fixtures, to create groups like AAAA
BBBBBB CCCC DDDDDD….

You can use more than one slash. Enter 2/4/5/3 to create a
grouping of two fixtures, then four, then five, then three,
repeated until all fixtures are used.

Ganging -
Repeat 

Lets you repeat feature ganging on every 2nd, 3rd, 4th or any
increment of fixtures. To set complex repeats separate the
increments with a / (forward slash). For a blocking of 4/6 as
described above, and a repeat of 1, fixtures will be grouped
AAAA BBBBBB AAAA BBBBBB

Include Fan Causes a Fanning option to be stored with this sort preset.
Refer to the fanning options later in this chapter.

To edit an existing custom sort, simply select that sort in the list and change its settings. To
delete a custom sort, select it in the list and click the Delete button. To rename a sort, double-
click the sort name and enter a new name.

Custom Ganging Examples
In these examples, there are 10 color-changing fixtures selected and color is fanned across
the fixtures using a Custom sort with the following Ganging (Blocking and Repeat) settings.

Blocking set to 3, Repeats left blank (No repeats):
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Blocking set to 3, Repeats set to 2: 

Blocking set to 1/2/3, Repeats left blank (No repeats): 

Blocking set to 2/1, Repeats set to 2. 

A great use of blocking is to create patterns in today’s multi-element fixtures where each
element is individually addressable. The PROLIGHTS Stark 1000 fixture has 19 LED emitters
arranged in concentric circles—1 center element; then a ring of 6 elements; then a ring of 12
elements. If you want to select the individual elements of the fixture and create three
concentric rings of different colors, you can create a custom sort with sort by ID; split
elements turned on; and a blocking set to 1/6/12. If you then fan the colors on this fixture,
you’ll obtain this effect:

Custom Fan Shapes
In these examples, there are 10 fixtures selected and intensity is fanned across the fixtures
using the following Fan shapes.

Fan from Center:

Fan from both ends:
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Note that the selected fan shape affects the selection order, and thus also the selection order
numbers displayed on the fixture icons.

Fan Shapes
The are several fan shapes that can be set and saved in a Custom sort.

This option… does this…

Linear Fan

Fanned values radiate in both positive and negative
directions from the base value, starting from the
center of the fixture selection.

Fan from End 

The fanned feature values radiate in one direction
from the base value, starting from the first selected
fixture. Ie., the first selected fixture remains at the
base value.

 

Fan from Start 

The fanned feature values radiate in one direction
from the base value, starting from the last selected
fixture. I.e., the last selected fixture remains at the
base value.

Fan from Center

The fanned feature values radiate in one direction
from the base value, starting from the first and last
selected fixtures. I.e., the end fixtures remain at the
base values.

Inverted Fan

The fanned values radiate in both positive and
negative directions from the base value, starting from
the first and last selected fixture. The first and last
selected fixture remain at the base value.

Fan from Both Ends

The fanned feature values radiate in one direction
from the base value, starting from the center of the
fixture selection. The center fixture remains at the
base value.

Displaying Fixture and Element IDs

Every fixture patched in Vista is assigned a Fixture ID. By default, Vista shows the fixture IDs
in the Fixture Chooser screen above the fixture names. (This can be changed through the
Manage Layouts option as described earlier in this chapter.) Multi-element fixtures not only
have fixture IDs, but also Element IDs within the fixture which identify the individually-
controllable elements.
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If you have the display of fixture IDs or element IDs turned off, or in situations such as fixture
matrixes where the IDs are not displayed, you can temporarily display these IDs by pressing
[blue/Ctrl+Alt/Control]. 

Highlight and Lowlight
When you are focusing or testing your fixtures you can use the Highlight feature to bring up
the intensity of each fixture automatically when you select it.

To do this, either:

· Click the Highlight button  on the User Softkey toolbar.

· Select Tools->Highlight (Ctrl+H).

You can alter how highlight works by updating the highlight and lowlight presets. See The
Highlight and Lowlight Presets in Chapter 8: The Components Tab.

When Highlight is on you can use the Next and Previous buttons on the Fixture Selection
toolbar, the next and last buttons on console above the Superplayback, or the left and right

arrow keys on your keyboard to step between fixtures. When using Next and Previous within a
selected set of fixtures, the fixtures not currently active will be set to the values stored in the
Lowlight preset, or to 0 intensity if no value is defined in the Lowlight preset.

Chooser & Timeline Window Toolbars
The toolbars available for the Programmer/Editor windows (Chooser and Timeline) include
Update, Edit, Undo, Fixture Selection, Fixture Macros, Fan, and Components. These toolbars
can be toggle in View>Toolbars.

Update Toolbar
All the buttons on this toolbar are available on the standard soft button set. However, if you
have re-configured the soft buttons this toolbar may be useful.

This button… does this…

Creates a new empty Cuelist and immediately places you within
the live edit mode.

Opens an existing Cuelist for editing within the live edit mode.

Displays the Store All window where you can save the complete
output (the look on stage). Storing this way will ensure that when
you play a Cue back it will appear exactly as it did when you
saved it.
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This button… does this…

Displays the Store Part window where you can save the
contents of the Programmer to any Cue in any Cuelist. Store
part provides many options and must be used for tracking to
operate correctly.

Displays the Update window where information coming from the
Programmer/Editor (the Live tab or any Cuelist tab) can be used
to update one or more Cues and Presets.

This button will close the currently selected Cuelist tab.

Once engaged, stealth will not show changes you make in the
live tab onstage. While stealth is engaged, you can blind
`visualize changes you make on the fixture icons. Once ready
for your changes to go to stage, press the Stealth button again.

Any changes will happen over Live Time.

Displays the Live Time window where you can set a fade time
that applies to any selections you make from the Editor panels
or presets.

Edit Toolbar
The Edit toolbar provides access to the traditional copy, cut, and paste commands.

This icon… does this…

(Ctrl+X)

Cuts the selected item.

(Ctrl+C)

Copies the selected item.

(Ctrl+V)

Pastes the selected item.

Undo Toolbar
The Undo toolbar provides access to the traditional Undo and Redo commands.
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This icon… does this…

(Ctrl+Z)

Undo the last action.

(Ctrl+Y)

Redo the last action.

Fixture Selection Toolbar
The fixture selection toolbar provides quick access to fixture selection options within Vista.

This icon… does this…

Previous Selection

Vista remembers the last set of fixtures you selected;
you use this button to toggle back to your previous fixture
selection.

 Next Selection

If you have used the previous selection command this
button will toggle back to the fixture selection you had
before pressing previous selection.

Previous Fixture

Used to step through fixtures, selects the last fixture (or
the one before the current selection) and de-selects the
others. Each subsequent press selects the previous
fixture. Useful when focusing fixtures with Hi-Lite

Next Fixture

Used to step through fixtures, selects the 1st fixture (or
the one after the current selection) and de-selects the
others. Each subsequent press selects the next fixture.
Useful when focusing fixtures with Hi-Lite

De-select all

De-selects all fixtures.

Invert

Inverts the fixture selection (i.e. all selected fixtures are
de-selected and all de-selected fixtures are selected).

All

Selects every fixture.

Active

Selects all the active fixtures (i.e. those that have
Intensity).

Programmed

Select all the fixtures that are programmed in the current
Cue.
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Fan Toolbar
The fan toolbar is used to set how feature values and event times are spread.

This option… does this…

Linear fan
Linear from Center

Fanned values radiate in both positive and negative
directions from the base value, starting from the
center of the fixture selection.

Fan from start
Linear from Start

The fanned feature values radiate in one direction from
the base value, starting from the first selected fixture.

 Fan from end
Linear from End

The fanned feature values radiate in one direction from
the base value, starting from the last selected fixture.

Fan from both ends
Linear from Ends

The fanned feature values radiate in one direction from
the base value, starting from the first and last selected
fixtures.

Inverted fan
Diverged from Ends

The fanned values radiate in both positive and negative
directions from the base value, starting from the first
and last selected fixture.

Fan from center
Linear from Center

The fanned feature values radiate in one direction from
the base value, starting from the center of the fixture
selection.

Selects multi-element
fixtures as one group

For a multi-element fixture, the entire fixture is treated
as one element for fixture selections, fanning, and
effects.

Selects multi-element
fixtures individually

For a multi-element fixture, the individual elements
within the fixture are treated as individual elements for
fixture selections, fanning, and effects.

To fan a feature or events, select the fan mode and hold [yellow/Ctrl/Command] while setting
the feature value or dragging the event bars.

Components Toolbar
The components toolbar includes buttons to create new Presets, Groups, and Extracts.
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This option… does this…

Opens the Create New Preset window.

Opens the Create New Group window.

Opens the Create New Extract window.

Live Time
If you are working live with features, Presets, or any of the Sidebar panels, the Live Time
window can be used to control crossfade time.

When you are applying a preset or simply selecting a value in the Features’ panel you can set
a time for the Preset or selected value to fade in. For example, you might be working in the
Live Editor tab and want to fade some lights into a color or position over several seconds.

There are two ways to set the live time. 

1. Click in the Live Time display of the User Softkey Toolbar to directly edit the current
live timing setting.

Enter the time in seconds you desire. You can split the Up and Down fade times by
entering the two values separated by a slash: “2/3” gives you a fade up time of 2
seconds and a fade down time of 3 seconds. 
2. Click Live Time drop down box and select one of the live time presets or Custom

Settings.

If desired, you can select the fade behavior of parameters set via the encoder wheels in the
Tools>Live Timing menus. Parameters can immediately “snap” to the new values, or fade in
over the Live Time setting.

If you have a Vista console with a Superplayback section, and the Superplayback section is
set to IPCG mode, the right hand fader of the SPB can be used to scale the live timing. The
Live Time display will reflect the scaling set by this fader.

You can also set any fader of a Vista console to be a Live Time scaling fader via the Console
Window. See the Console Window chapter for more information on this.

Live Time Templates
Vista comes with three Live Time templates: 0s, 2s, and 5s. But if you regularly use other
time settings you can save these as templates that appear on the drop down list. To do this:
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1. Click the Live Time drop-down button on the User Softkey Toolbar and select
Manage Custom Timings. Vista opens the Custom Timing window:

2. Click the New button to create a new custom timing or select an existing timing and
pick Duplicate to base your new timing on an existing one.

3. Set the Fade Time and Fade curve for each of the features: Intensity Up, Intensity
Down, Position, Color, Gobo, Beam, and Miscellaneous.

This field… Does this…

Time Sets the fade time in seconds. You can also set the fade
time by clicking on the timing bar and dragging the right
handle forwards or backwards.

Fade Curve Sets the fade curve. To set the fade curve click on the icon
and select an option from the popup list. For more
information about fade curves, see fade curves in Chapter
10: The Timeline Window.

4. Click the Close button when finished.

To manage the list of Live Time templates:

1. Click the Live button on the User Softkey Toolbar and select the Manage Custom
Timings option from the drop-down box. Vista opens the Custom Timings window.

2. The list of Custom Timing templates appears on the left, with three buttons to
manage the list directly underneath.

3. To delete a template, select it in the list and click the Delete button. (You cannot
delete a factory-defined template.)

4. To Duplicate a template, select it in the list and Press the Duplicate button. A copy
of the template appears in the list and is automatically selected; you can now
customize the timings for this template.

5. To create a new template, click the new button and customize the timings for the
new template.

6. To rename a template, double-click on a template name and enter a new name for
the template.
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Stealth Mode

Stealth Mode is the Live tab’s version of working with your fixtures in Blind mode. When in
Stealth mode, the Live tab’s icons will reflect the changes you make, however, the changes
are not output to your fixtures until you exit Stealth mode. This allows you to build a complete
look comprised of a number of different changes and then action them all together.

To enter Stealth mode, press the Stealth button that appears to the left of the Live tab (when
the Live tab is selected), or press the Stealth button on the User Softkey Toolbar.

When you turn off Stealth mode, any features set in the Live tab will fade in over Live time.

Using a Keypad in the Programmer Window

Vista includes a CLI (Command Line Interface) window that provides familiar keypad syntax
for selecting fixtures, setting features, and storing Cues. Refer to the chapter on the
Command Line Interface for details on commands associated with working with your fixtures.

The Programmer Hardware Controls

Some consoles and consoles provide physical buttons and encoders for adjusting features,
pressing function key buttons, and creating stage looks. Refer to the manual for your
hardware to read details on how it interacts with Vista.
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Chapter 7: Controlling Fixtures and Creating

Stage Looks

The Features Tab of the Sidebar is the primary way to work with your fixtures’ features. It is
normally docked to the right side of the Fixture Chooser and Timeline screens, but its tabs
can be docked to any side of the main window, or undocked completely and moved to other
locations or screens. It occupies the same space as the Components and SmartFX tabs
(described in subsequent chapters).

The Features tab includes panels to control all the main aspects of your lighting fixtures:
intensity, position, color, gobo, and beam.

If it’s not already selected, click on the Features tab in the sidebar.

All and Detailed Panels

You switch between the All panel, which summarizes all the feature categories, and the
detailed panels of the different feature category control panels using the seven buttons at the
top of the Features tab. Each of these we refer to as a panel. 

This button… does this…

Displays a combined view of the most commonly used
controls for Intensity, Position, Color, Gobo and Beam.

Displays a detailed view of the Intensity controls.

Displays a detailed view of the Position controls.

Displays a detailed view of the Color controls.
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This button… does this…

Displays a detailed view of the Gobo controls.

Displays a detailed view of the Beam controls.

Displays controls for every feature of the selected fixture. If
multiple fixtures are selected, only the features in common
will be displayed. These controls are mainly used to control
features that do not appear on the other panels or to set
channels to values that are normally not used.

Using the All Panel
The All Panel has controls for all the most commonly used features of your fixtures. It
provides a quick way to set Intensity, Position, Color, Gobo and Beam without swapping
panels. The same controls plus any advanced ones are available on the individual feature
panels. See Using the Detailed Panels later in this chapter.

Intensity Controls
In this view the intensity controls show the most frequently used intensity features:

In this view:

· The 0 to 100 buttons set the intensity of the selected fixtures to the corresponding

percentage value.

· The larger 0, 50, and 100 buttons also set these percentage values but offer a touch

screen friendly variant. 

· The -5 and +5 buttons increase the current percentage value by this amount. This

increment value can be set in the Editing tab in File->User Preferences.

· the Intensity slider allows you to control the intensity of the selected fixtures by

sliding the bar back and forth.

You’ll notice that as you change the intensity settings, the fixture icons on the Fixture panel
change to reflect this.

Position Controls
The position controls allow you to adjust the pan and tilt of the selected fixtures.
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To adjust the position, click on the round target symbol and drag it to the spot you want. You
can adjust Pan or Tilt independently by using the vertical or horizontal sliders. You’ll notice
that as you change the position the icons on the Fixture panel change to reflect this.

Fine Mode

Some features, such as position, can be difficult to control when the panel is in normal mode.
To switch to fine click on the Fine button. Repeat this to turn fine mode off. You can also
temporarily enter Fine mode by holding [red/Shift] while adjusting a control. You can achieve
an ultra-fine mode by engaging both the Fine button and also holding [red/Shift].

Color Controls
The Color Controls provide four buttons so you can choose the way you want to set your
colors:

· HSV: hue and saturation values.

· Sliders: Slider controls that let you set the color via the CMY, RGB, or HSV color

modes. 

· Swatch: colors by Lee name and number.

· Color wheel: for fixtures that have color wheels.

Hue and Saturation Values Color Picker

The HSV tab provides a color spectrum and a saturation slider: 

To pick a hue and its saturation, just click on the shade you want in the spectrum area and
drag the slider bar below the color panel to set the saturation level.
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For fixtures that contain amber or white LEDs, sliders for adjusting the effect these colors
have on the color output of the fixture will also appear under the saturation slider.

Sliders

This tab gives you the option of setting your color using either CMY, RGB, or HSV values:

Click the relevant “slider mode” button to choose the method you want, then adjust the sliders
to set the color.

For fixtures that contain amber or white LEDs, sliders for adjusting the effect these colors
have on the color output of the fixture will also appear under the RGB sliders.

Swatch

This tab provides gel colors, numbers, and names from the Lee swatchbook so you can pick

the color you want by gel filter:

Click in the Color, Number (#) or Name (N) button to sort the list by name, number, or color.

You can also search for a name or number by typing in the search box. Vista will attempt to
approximate the selected swatch color; how close the match will be is highly fixture-
dependent.

Color Wheel

When using fixtures with color wheels, you can use this tab to select the color slot (or
position) you want this fixture to use.
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Fixtures that have more than one color wheel will show a line of available colors for each
wheel. The colors are displayed in the same order as they are on the wheel. Just click on the
color swatch to select it.

You can move the color wheel by small increments on some fixtures, to create split colors, by
clicking on the Index button and adjusting the slider to rotate the wheel forwards or
backwards.

You can also spin the color wheel by clicking on the Rotate button and slider to spin the wheel
forwards or backwards. If the color wheel is spinning you can reverse the spin direction by

clicking on the  Reverse icon or stop it by clicking on the  Stop icon.

Gobo Controls
The Gobo summary panel displays icons of the gobos available on the selected fixtures:

Gobo Presentation and Selection

Vista creates a tab for each fixture type that is selected. Within each of these tabs, fixtures
that have more than one gobo wheel will show a line of available gobos for each wheel, up to
a maximum of three wheels. The gobos are displayed in the same order as they are on the
wheel. You can select a gobo from one wheel and leave the other wheel set to the open slot,
or select a gobo from each wheel to combine the patterns. If multiple fixture types are
selected, a gobo selection from a specific fixture type tab will not affect the fixtures that are
not of that fixture type.

Additionally, an All tab is created that is populated with all the gobo patterns from all the fixture
types, with no separation as to which wheel that pattern may be placed. Selecting a Gobo
from the All tab does the following:
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1. For the fixtures of the type from which that pattern was selected, that specific
pattern will be put into position on that wheel.

2. For fixtures not of that type, Vista will pick a gobo of the same category and put that
gobo into position.

3. For any additional gobo wheels in the selected fixtures, those wheels will be reset
to the Open position.

Wheel Rotation

Under the tabs for specific fixture types, you can move the gobo wheel by small increments
on fixtures that support this feature, to create split patterns, by clicking on the Wheel and
Index buttons and adjusting the slider to rotate the wheel forwards or backwards. Note: The

fixture icon in the Fixture Chooser screen will no longer update to reflect the patterns being
displayed when in this split mode.

You can also spin the Gobo wheel by clicking on the Wheel and Rotate buttons and adjusting
the slider to spin the wheel forwards or backwards. If the gobo wheel is spinning you can

reverse the spin direction by clicking on the  Reverse icon or stop it by clicking on the

 Stop icon. Note: The fixture icon in the Fixture Chooser screen will not reflect that the

gobo wheel is spinning.

Gobo Rotation

On some fixtures, and some gobo wheels, you can rotate and spin the individual gobos. For

these fixtures:

You can move the selected gobo by small increments, to rotate the image, by clicking on the
Gobo and Index buttons and adjusting the slider to rotate the gobo clockwise or
counterclockwise.

You can also spin the selected gobo by clicking on the Gobo and Rotate buttons and adjusting
the slider to spin the gobo clockwise or counterclockwise.

If the gobo slot is spinning you can reverse the spin direction by clicking on clicking on the

 Reverse icon or stop it by clicking on the  Stop icon.

Beam Controls
The summary Beam controls has two tabs for controlling the most often-used beam features.

Focus

Pressing the Focus button presents controls for adjusting the focus and zoom of the selected
fixtures. 
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Use the focus slider to soften or sharpen the beam shape. Use the Zoom slider to make the
beam spread larger or smaller. 

Iris

Pressing the Iris button presents controls for adjusting the iris and frost options of the
selected fixtures, if so equipped.

Use the iris slider to control the beam aperture size. Use the Frost slider to soften the light
from the fixture.

Using the Detailed Panels

While the All panel will provide quick access to the most commonly used features of your
fixtures, the detailed panel for each feature group will often provide access to additional
features, or provide better control over that feature set than is available in the All panel.

Common Features of the Detail Panels
All the specific detail panes have a couple aspects in common.

Feature Selection Number

Along the top of each detailed pane is a row of buttons with numbers:

For feature categories where there may be more than one of the same feature, this lets you
select between them. For example, there are many fixtures with more than one gobo wheel.
In the example shown above, this fixture has four gobo wheels. Therefore, the buttons one
through four are enabled and let you select which wheel you want to work with.

Custom Values

Some fixtures have special features that either don’t fall into a common category, or can be
used best by setting a channel to a particular DMX value. These features vary from fixture to
fixture and therefore aren’t included in Vista’s stock set of generic fixture model controls. The
Custom area at the bottom of each feature panel provides access to these features that fall
under the five common panel categories.
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Any custom features that fall outside of the five common panel categories can only be access
via the Custom panel.

See the section on the Custom Panel later in this chapter for more details on using the
custom control panels.

Common Features of the Panels
Each panel focuses on a particular set of features. For example, there is a panel for working
with Intensity features; another for color, etc….

All panels have a popup menu that you open by clicking the button in the top-left of that feature
category section. Each category’s popup menu button has the same icon image as the views
buttons described above, with a downward-facing arrow head in the lower right corner. For

example, the Intensity group’s popup menu button looks like this: 

This option… does this…

This option lets you clear from the Programmer all
events for that feature type. The Programmer or selected

cue will no longer be in control of that feature type for the
selected fixtures. Note that there is a user option
available that clears fixtures to the user-defined Home
values when cleared. 

This option sets the Programmer values for that feature
type to their default (or user-defined) home settings. It’s
important to note that unlike Clear, which removed the
value from the Programmer, the Home function sets
values in the Programmer. For example, 0% intensity,
50% pan and tilt, color white, etc… might be typical
default home values for an intelligent light.

This option adds a release event for this feature type for
the selected fixtures. Control of the features will return to
values from another running Cuelist, or to their home
values.

This option opens the Preset window so you can create
a new preset. Please note that the feature filter will
automatically be applied to only this feature by default
when opening the Preset window through this method.

Clicking on this option opens the Create effect window
where you can select an effect type, the features to
include, and enter a name for the effect.

This option lets you stop effects that are running for that
feature type.
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This option… does this…

Park Locks this feature category of the selected fixtures to
their current values and ignores any instructions from the
Programmer or Cue lists.

Unpark Unlocks this feature category of the selected fixtures and
causes them to resume following instructions from the
Programmer or Cue lists.

Tip: All of the above options are available on a per-feature basis as well as per feature type,
for example by right clicking the zoom slider and choosing park, you would park just the zoom
feature rather than all the beam features.

Many of the panels have slider bars that provide a quick and easy way to set a value:

To adjust a slider setting, either:

1. Click the arrows at the left- or right-hand end to go to 0% and 100% respectively.
2. Click and drag in the slider bar to set the value you want.
3. Click in the value box, type a value, and press enter using the keyboard.

More than one fixture can be adjusted at one time;
if a given feature of the selected fixtures has
different values for that feature, then the controls
visually represent the range of values. How they
do this varies depending on the control type.

The image here shows the All features panel with
three moving-head color-changing fixtures
selected. Each fixture has a different value for
intensity, position, and color.

The slider for intensity reflects the varied values by
showing a visual bar from the smallest to the
largest intensity, and numerically shows the range
by the minimum value and maximum value
(“20:60”).

The position panel reflects the three different
positions by a rectangle that encloses the three
pan-tilt positions.

The color panel reflects the three colors by
drawing a dashed rectangle that encloses the
three color values, and a range bar in the
Saturation bar that reflects the three saturation
values, as well as a numeric representation of the range in the Saturation value text box.
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Intensity Panel
Click on the Intensity button to select the detailed settings panel for all fixture channels in the
Intensity group:

In this view:

· The 0 through 100 buttons set the intensity

of the selected fixtures to the corresponding
percentage value.

· The larger 0, 50, and 100 buttons also set

these percentage values but offer a touch
screen friendly variant. 

· The "-5" and "+5" increase the current

percentage value by this amount. This
increment value can be set in the Editing tab
of User Preferences.

· The Intensity slider controls the intensity of

the selected fixtures in a percentile range.

· The arrow buttons at either end of the

Intensity slider control set the intensity to 0%
or 100%.

· The text box to the right of the slide control

represents the exact percentage value of the
fixture and can be set directly to an integer
percentage value.

· If the selected fixtures have a strobe

capability, the Strobe slider controls the
speed of the strobe. The left hand |< button
of the strobe slider stops the strobe.

· If the selected fixtures have blackout

shutters, the Opened and Closed buttons
set the shutter position.

Position Panel
The detailed Position panel provides a larger version of the position target panel.
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Pan/Tilt Sliders
You’ll notice that on this panel you can also adjust
just the pan or just the tilt by using the Pan and Tilt
sliders located on the bottom and left side of the
target panel.

Fine Mode
Position can sometimes be difficult to control when
the panel is in normal mode. Pressing the Fine
Mode button toggles the target panel and sliders into
a state where it takes a much larger movement of
the control to effect a smaller change, thus allowing
for detailed control over the pan and tilt of the fixture.
You can also use this Fine button in conjunction with
[red/Shift] for ultra-fine.

Flip
Click this button to rotate and invert the fixture(s) so
that it is pointing at the same position but from
inverted settings. Occasionally you may find that of

the five fixtures you have pointing in a particular
direction, one got to that position by using opposite
pan and tilt settings. Flip lets you quickly bring it
back into line with the other fixtures.

Color Panel
The detailed Color panel lets you choose how to control the color mixing mechanism and the
color wheel(s) in your fixtures. The buttons in the middle of the color panel select the color
mechanism. There are three options:

· HSV: Hue and saturation values.

· Lee: Lee color swatch.

· Wheel: Pick a color from the fixture’s color wheel.

If a fixture only has a color mixing mechanism you can choose a color from the HSV or Lee
swatch section and it will be applied to the mixer mechanism. The color wheel section will not
be available.

If a fixture has a color mixing mechanism and a Color Wheel you can choose a color from the
HSV or Lee swatch section and it will be applied to the mixer mechanism. You can also
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choose a color from the Wheel section of the color panel it will be applied to the color wheel.
This means you can set different colors for the mix mechanism and the wheel.

If a fixture only has a Color wheel you can choose a color from the HSV, Lee or Wheel section
of the color panel it will be applied to the color wheel. If you choose colors from the HSV or
Lee section, the color that’s the closest match on the wheel is selected.

Hue and Saturation Values

When you select the HSV color option the color panel provides a color picker panel and a set
of sliders:

To pick a color by selecting a hue and a
saturation value, just click on the shade you
want in the spectrum area, and drag around to
select a color and set the saturation level.

You can also adjust the color using the sliders.
Click the HSV, CMY, or RGB “slider mode”

button to choose the method you want, then
adjust the sliders to set the color. Note that if the
fixture supports Amber and White LEDs, sliders
for those will appear as well.

HSV Sliders:

CMY Sliders:

RGB Sliders:
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Note: The RGB and CMY sliders will dynamically change color along its travel to reflect what
color would be achieved by moving the slider to that point.

Lee Swatch

This option provides a list of Lee filters so you can pick a color by its name, number, or

swatch.

Click on the Color, Number (#) or Name (N)
buttons that appear below the swatch list to
sort the list by name number or color swatch:

You can also search for a name or number by
typing in the search box.

Note: The Lee Swatch picker is designed as a tool to get you as close to the lee color as
possible. Actual physical color output may vary depending on each fixture’s specific color
mixing system and the calibration data available from the manufacturer.

Wheel

When using fixtures with one or more color wheels, this option provides a graphic
representation of the color wheel so you can see exactly what colors are available and where
they are on the wheel.
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If a fixture has more than one color wheel the
buttons above the color wheel will be
available. To choose the color wheel you
want to work with click on the corresponding
button.

Choose a color on the wheel by selecting the
mimics of the wheel slots. The chosen color
will be shown in the center. You can move
the color wheel by small increments, if the
fixture supports this, to create split colors by
clicking on the Index button and adjusting the
slider to turn the wheel forwards or
backwards.

You can also rotate or spin the color wheel
by clicking on the Rotate buttons and
adjusting the slider to spin the wheel
forwards or backwards.

If the color wheel is spinning you can reverse
the spin direction by clicking on the Reverse
icon or stop it by clicking on the Stop icon.

If you have more than one type of fixture
selected, Vista displays a tab for each fixture
type at the top of the panel: 
To choose the fixture type you want to work
with, click on the corresponding tab.

Gobo Panel
The detailed Gobo panel provides a graphic representation of the gobo wheel so you can see
exactly what patterns are available and where they are on the wheel. 

Note: Prisms and Animation Wheels are also treated by Vista as a type of Gobo wheel and
will be found in the Gobo panels as additional wheels.
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Multiple Wheels

If a fixture has more than one gobo wheel, or also
contains a prism or animation wheel, the buttons above
the gobo wheel will be available. To choose the wheel
you want to work with click on the corresponding button.
Select a gobo for that wheel by clicking on its image.

Gobo Rotation and Spin
On some fixtures you can rotate the individual gobos.
For these fixtures:

You can rotate the selected gobo by small increments to
align the image by clicking on the Gobo and Index
buttons and adjusting the slider to rotate the gobo
clockwise or counterclockwise.

You can also spin the selected gobo by clicking on the
Gobo and Spin buttons and adjusting the slider to spin
the gobo clockwise or counterclockwise.

If the gobo slot is spinning you can reverse the spin

direction by clicking on the Reverse icon or stop it

by clicking on the Stop icon .

Wheel Rotation and Spin
You can move the gobo wheel by small increments, to
create split patterns, by clicking on the Wheel and Index
button and adjusting the slider to turn the wheel forwards
or backwards.

You can also rotate or spin the wheel by clicking on the
Wheel and Rotate buttons and adjusting the slider to
spin the wheel forwards or backwards. If the gobo wheel
is spinning you can reverse the spin direction by clicking

on the Reverse icon or stop it by clicking on the Home icon.

If you have more than one type of fixture selected, Vista displays a tab for each fixture type at
the top of the panel. To choose the fixture type you want to work with click on the
corresponding tab.

Beam Panel
The detailed Beam panel provides sliders for all the beam features and a graphic
representation of frame (shaping shutters), if the fixtures have this feature. The Focus tab
provides access to:
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Focus
Use the focus slider to soften or sharpen the beam
shape. 

Zoom
Use the Zoom slider to make the beam spread larger or
smaller. Note that when you adjust the zoom, you
frequently need to re-adjust focus if you desire to
maintain the same beam sharpness.

Iris
Pressing the Iris button presents controls for adjusting
the iris and frost options of the selected fixtures, if so
equipped.

Use the iris slider to control the beam size. Use the
Frost slider to soften the light from the fixture.

Note that while zoom and iris appear to do similar
things, there is a difference. When a fixture is zoomed,
the entire light output from the fixture is optically
concentrated into a smaller area, and therefore the light
will get brighter because more light is hitting a smaller
area. An Iris will also reduce the size of the beam, but it
does this by blocking the outer parts of the beam, not
concentrating them. Therefore, the brightness of the
beam will appear remain consistent as you adjust the
iris.

Frost
Use the Frost slider to soften the light from the fixture.

The Framing tab is specifically for fixtures that have beam shaping frames, enabling you to
shutter-off parts of the beam:
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To set the positions you want the frames to
be in on the selected fixtures, click and drag
each frame to the position you want, as
shown in this example. Dragging from the

center third of a shutter will allow to insert
and retract that shutter blade, dragging from
the left or right third will allow you to adjust
the angle of insertion.

You can also set the rotation angle of the
shape or continuously rotate the whole shape
using the slider:

Index: to turn the framing shutters to the
preferred angle click the Index button and
move the slider to set the position.

Rotate: to continuously rotate the whole
shutter assembly click the Rotate button and
move the slider to set the speed and
direction. 

Custom Panel
The detailed Custom panel provides a separate mini setting panel for every channel of the
selected fixture. The mini panels are arranged in sections according to their feature type—
Intensity, Position, Color, Gobo, Beam, and Misc (miscellaneous). The Misc section contains

all the mini control panels for all channels that don’t belong in the IPCGB feature groups. For
example, a hazer might have a Fan Speed setting under the Misc section.

Click on any of the Feature Type headings to open that section.

About Custom Values

Some fixtures have effects and other special features that can only be used by setting a
channel to a particular value. These features vary from fixture to fixture, so they aren’t

included in Vista’s pre-defined controls.
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For example, some fixtures have special settings for the Strobe channel that provide a

random strobe effect. Moving Vista’s strobe slider to the left or right will never set the effect
running because the slider only operates in the (generic) range that sets the strobe to fast or
slow.

To access the special features of your fixtures (as well as being able to access standard
features as well in a Custom feature manner) you use the Custom control panels. Feature-
type specific Custom areas are found at the bottom of each feature panel; there is also a
Custom feature panel which gives you access to all features, presented as Custom feature
small panels.

Custom Panels

The small custom panels are divided into three sections:

1. The top section shows the name of the channel in a color-coded bar.
2. The center section shows the channel range. This will normally be the same as the

channel name but will change if a special range is selected (see below).
3. The bottom section shows the channel value. Normally this is shown as a DMX

value (0-255) but can be changed to a % value by clicking the DMX button, which
then changed to be a Units button.

You can set a custom channel value in three ways:

1. Click on the up and down buttons, in the bottom section, to adjust the value by + or
– 1 each time you click a button.

2. Click on the value display to highlight it and type a new value with the keyboard.
3. Click on the value display to highlight it and while holding the mouse button down,

note that the cursor changes to an up/down arrow. Now move the pen or cursor up
or down as though you were adjusting a slider.

For many fixtures the Vista library includes information about what value channels need to be
set to for a particular effect. In this case you can click on the custom panel’s title bar or
double-click anywhere on the panel to open the Custom feature window, providing a more
detailed view of the options for that channel.



Vista User's Guide, Version 3.3108

Custom Feature Window

The custom feature window lets you select any special values or a value within a range that is
in the Vista library for the selected fixture.

This field… does this…

Range Buttons In this column there will always be one button that
selects the entire channel range (i.e. 0-255).

If Vista library includes information about the fixtures
custom values there will be a button for each of the
special values or value ranges. Clicking on the button
will set the channel to that value or range. If it’s a
range you can adjust the value, within that range,
using the top slider.

Name Shows the name of the channel or selected channel
range.

Range Fader (top) Adjusts the channel value within the selected range if
such a range exists.

Channel Fader (lower) Adjusts the channel value to any value in the DMX
range – 0-255.

Search For fixtures with large numbers of custom values (for
example, media servers) you can type in this field to

locate a special value or range by name.

Sort For fixtures with large numbers of custom channels
(for example media servers) you can sort the values
by ID# (usually as the values appear in the fixtures
DMX channel chart) or by Name.

Icon Size Adjusts the size of the custom value/range selector
buttons in the right-hand column.

DMX / Units This button selects between DMX values (0-255) and
units (normally 0-100)

Associated feature
panels

If there are other features that are associated with the
selected feature, they can be selected and adjusted
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This field… does this…

from within the window.

Fanning Features
To fan a feature or events, select the fan mode and hold [yellow/Ctrl/Command] while setting the
feature value or dragging the event bars. This will fan the feature across values based on the
Fan mode and Fixture Sort settings, as described in Chapter 6.

Working with Fixtures using a Vista Console
Some consoles and consoles provide physical buttons and encoders for adjusting features,
pressing function key buttons and creating stage looks. Refer to the manual for your hardware
to read details on how it interacts with Vista or to Chapter 16 for an overview on hardware
controls.
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Chapter 8: Components

If it’s not already selected, click on the Components tab at the top of the sidebar:

This is where you can store, select, and organize your Groups, Presets, Extracts, Effects,
Cuelists, and Snapshots. The window is divided into different areas that allow you to:

· Choose how you want to view the components.

· Choose the type of component you want to work with: Groups, Presets, Effects,

Extracts, or Snapshots.

· Choose a component and either activate it or modify it in some way.

· Create new pages that let you group components into custom sets.

Components Bar
This screen provides quick access to all the elements used for programming and playback of
a show. To choose the component type, you use the buttons at the top:

This button… does this…

QP1 Displays a multi-panel Quick Picker. The Quick Pickers
provide an easy way to arrange and select Presets, Groups,
Extracts, SmartFX, and more.

QP2 Displays a second multi-panel Quick Picker.

Groups Displays and lets you select or modify the groups you’ve
saved.

Presets Displays and lets you select or modify the presets you’ve
saved.

FX Displays and lets you select any of Vista’s built-in effects.
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This button… does this…

Extracts Displays and lets you select or modify the Extracts you’ve
saved.

The Feature Filter Bar
If you are working with Groups, Presets, Effects, or Extracts, the Feature Filter bar can be

used to filter the items that are displayed or the features that are stored.

This button… does this…

Selects all features for filtering.

Includes Intensity features in the filter.

Includes Position features in the filter.

Includes Color features in the filter.

Includes Gobo features in the filter.

Includes Beam features in the filter.

Includes Miscellaneous features in the filter.

Brings up the Filter Feature window in which checkboxes can
be used to select and deselect features for filtering. This
duplicates the functionality of the buttons in this Filter bar. 

The buttons on the filter bar will affect which items are displayed. If you only have the Intensity
filter button active, you will only see items for which there is intensity information included.
However, applying the item, even when you have filtered (for example) for items that include
intensity, will apply all features stored in the item—not merely the intensity features.

When you are applying presets from the Components panel the Preset will fade in over the
Live Time (described in more detail later in this chapter). For example, you might be working
in the Live Programmer tab and want to fade some lights into a color or position over several
seconds. To do so, use the Live Time option for setting the fade time.

If you are recording presets or extracts in the Components bar, the filter bar affects which

features will be recorded in the Extract or Preset. You can click on any of the icons to either
include it or exclude it. Included features are highlighted. Note that you can change this initial
selection in the Create Preset or Create Extract window.

For more information about Presets, Extracts, refer to their sections later in this chapter. More
information on SmartFX can be found in Chapter 12: SmartFX.
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Components Window Tools

If you are working with Groups, Presets, Effects, or Extracts, there is a toolbar at the bottom

of the panel that acts on the list of items.

This button… does this…

+ Creates a new component of the selected type. (Not applicable
for the FX panel.)

- Deletes the selected item from the list.

Search Typing in the Search box filters the list down to just the items
that match what you’ve typed.

X Clears the search box. (Only visible when a search term has
been entered.)

Quick Picker Panels

The Quick Picker panels provide an easy way to select any of the following items you’ve
created:

· Groups

· Presets

· FX templates

· Cuelists

· Extracts

· Favorites

· Snapshots

· FX Masters
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The Sidebar has two panels (QP1 and QP2) that
normally display three Quick Picker panels. To
adjust size of a Quick picker panel, click on the
divider bar and drag up or down. To hide one or
two of the Quick Pickers drag the divider to the
bottom of the panel.

You can set what a Quick Picker displays by
choosing an option from the drop-down menu at
the top-left side of each column. Once you’ve

chosen the type of information you want the
column to display, you can also select what page
you want to display within that column using the
second drop-down menu.

To add a page to a Quick Picker, right-click on an

empty space in the Picker, and select Add New

Page from the popup menu.

To delete a page from a Quick Picker, right-click

on an empty space in the Picker, and select
Remove Page. Deleting a page does not delete
the items on that page.

To copy an item to another page, first display that
page in one of the other Quick Picker panels.
Then, hold [green/Alt/Option] while dragging the
item from the first Quick Picker panel to the
other.

To delete an item from a user-created page,
right-click the item and pick Remove Item from

Page.

Quick Pickers are also available as individual panels via View->Add Dockable Window->Quick

Picker, or as an option in the external windows.

The Multi Quick Picker
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The Multi Quick Picker, a dockable window, contains four Quick Picker panels and normally
appears at the bottom of the Fixture Chooser and Timeline screens. If it’s not already open,
select View->Add Dockable Window->Multi Quick Picker.

The Multi Quick Picker normally displays four Quick Picker panels. To adjust the width of a
Quick Picker click on the divider bar and drag left or right. To hide one or two of the Quick
Pickers, drag the divider to the right of the panel.

To reduce the amount of vertical space the Multi Quick Picker takes up, you can select
Compact Mode from the Multi Quick Picker window menu. This removes the headers that
allow you to change what the Quick Picker panels display.

Quick Picker Popup Menu
Depending on the component there are various options available on the Quick Picker popup
menu. To open this menu right-click on the label area of any component. Vista displays the
popup menu:
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The options in the popup menu may change based on what type of item is selected,
therefore, not all the menu entries described below are available for each item type.

This option… does this…

Apply Applies or activates the item under the mouse pointer.

Edit Opens the selected item in the Editor.

Edit Blind Opens the selected item in the Editor in Blind mode,
which prevents this preset’s value from being output to
the stage while you are editing it. 

Duplicate (Cuelists only) Makes a copy of the selected item.

Label Opens a window where you can rename the selected
item.

Renumber Opens a window where you can renumber the
selected item.

Change Icon Opens a window where you change the icon for the
selected item.

Change Border Color Allows you to select a custom border color for the
selected items.

Delete Delete the selected item.

Remove Item from
Page

For items in a user-created page, this can be used to
remove the item from the page.

Properties Opens the Properties window for applicable items.

Add New Page Adds a new empty page to the selected Quick Picker
panel.

Remove Page Removes the selected page.

Label Page Opens a window where you can rename the selected
page.

Highlight For preset pages, this allows you to edit the built-in
Highlight preset. The fixture-specific values in this
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This option… does this…

preset are used when a fixture is selected while
Highlight mode is active.

Lowlight For preset pages, this allows you to edit the built-in
Lowlight preset. The fixture-specific values in this
preset are used when a fixture is selected while
Lowlight mode is active.

Home For preset pages, this allows you to edit the built-in
Home preset. The fixture-specific values in this preset
are used when a fixture is sent to its Home setting for
a feature.

You can also play and release Cuelists by selecting them in a Quick Picker that has been
configured for this option. Click on the Settings icon for the Quick Picker panel, and turn on

the option “Select to Play” at the bottom of this window. When this option is turned on, holding
[blue/Ctrl+Alt/Control] when clicking on the Cuelist will release that Cuelist.

You can open the Update Preset or Update Extract window by pressing
[yellow/Ctrl/Command] and selecting the preset or extract.

Additionally, you can update Groups or Snapshots by pressing [yellow/Ctrl/Command] and
selecting the Group or Snapshot. No update window will appear, but you will have immediately
updated the component.

Right-clicking in a Quick Picker window not on a component brings up a popup where you

can create a new component of that type displayed in that Quick Picker. Once the Create
window is open, you can assign the new component to a console’s playback control by
double-tapping on a playback control button.

Quick Picker Panel Settings
When you first display a Quick Picker panel, you’ll see the items are laid out as buttons in a

grid. You can change the format of how items are displayed as well as other properties of the

quick picker panel by clicking on the  settings icon for the panel you want to change. This

will open the Quick Picker settings window:
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This button… does this…

Icon size Adjusts the size of the icons displayed in the Quick Picker.

Text size Adjusts the font size for icon labels or the amount of space
available for the label when formatted as a list.

Spacing Adjusts the amount of space between the icons.

Icon Click this button to display just an icon for each item.

Label Click this button to display just a text label for each item.

Icon and Label Click this button to display both an icon and a text label for
each item.

Label as Icon Click this button to have the label appear in the center of the
icon image.

Multi-list Click this button to arrange the items in a multi column list.
The items are laid out across and then down.

Single list Click this button to arrange the items in a single column list.

Touch screen Click this button to arrange the items in a grid suitable for use
on a touchscreen.

Icon view Click this button to arrange the items in a compact grid of
icons without labels.

Auto-arrange Arrange the icons by Name (alphabetically) or by ID (number)
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Cuelist Icon
Click Behavior

Specifies what should happen when a Cuelist icon is clicked
(or pressed) in this Quick Picker. The options are:

No Action

Set Default Cuelist

Play; if [blue/Ctrl+Alt/Control] is being held, then Release

Play & Release: Play the Cuelist while held down; release
when button is released.

Flash

Apply to all Click this button to apply these settings to all Quick Picker
windows.

If you desire to re-arrange the items in a Quick Picker panel in a custom order, hold down
[green/Alt/Option] and drag items to the desired location in the Quick Picker panel.

Quick Picker Presets Labels
When you select some fixtures, the preset labels change to indicate which are available:

This label… indicates…

Dimmed This preset does not have any settings stored for the
selected fixtures.

Normal This preset has settings for some or all of the selected
fixtures.

Outlined This preset is being used on the selected fixtures.

Groups

If you have a lot of fixtures in your show, the last thing you want to do is manipulate dozens of
individual fixtures. To make it easy to control all the fixtures in your rig, Vista automatically

creates groups for each fixture type that you patch. You can also create your own groups.

A group can consist of any number of any type of fixtures; it’s entirely up to you what you put
in a group. Some typical groups might be all the even or odd fixtures of one type, all the wash
lights on the back truss, or all the fixtures you’re using on one part of the stage.

When you save a group, the fixture selection order is also stored. This can be useful if you
are fanning color or another feature or applying effects across a group and want a particular
order.

Groups can be assigned to playback controls on a console and used as submasters. When
assigned to a fader control, when you raise the fader up from zero, the fixtures assigned to
the group will be assigned that intensity in a HTP (highest takes precedence) priority. So,
fixtures assigned to a group which is assigned to a fader control will be set to a minimum of
50% if the group fader is brought to the 50% level. Any fixture that is receiving an intensity
property greater than 50% from another source will reflect that higher level.
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By default, a group assigned to a playback control is a HTP submaster; however, by changing
the fader type through the Console window, you can change the Group Fader operation to
instead be a Inhibitive Scaler or an Additive Scaler. Refer to Chapter 16: Using the Console
Window for more information on this.

Creating Groups
When you are first creating groups it’s easier to have a Picker window open with groups
selected in one of the panels. If you don’t always have a Picker open, select View->Add

Dockable Window->Quick Picker. A Quick Picker window will be displayed:

To create a group:

1. Select the fixtures you want in the group.
2. Then, do one of the following:

a. Right-click in the Groups panel and select Create New Group.

b. Hold [yellow/Ctrl/Command] and press the “+” button that will appear in the top-
right corner of the picker.

c. Press the  button on the Components toolbar.
d.  Select Components->New Fixture Group.

e. Right-click on one of the selected fixtures and pick Fixture Groups->New Fixture

Group.

3. Type a label for the Group and click OK or press Enter. If you don’t want to label the
Group right away, you can accept the suggested label and change it later.

You can create as many groups as you want, and you can also create any number of groups
of groups.

If you have a Vista console, when the Create Group window is open, you can assign the new
group to a playback control by double-tapping a playback key.

Updating Groups
You can use the Programmer or Editor to update the information stored in a group. To do this:
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1. Either in the Live tab or a Cuelist tab, select the fixture group you want to change.
Vista selects all fixtures in the group.

2. Select additional fixtures or deselect any already in the group.
3. Right-click on the group in the picker and select Update.

Note that groups created automatically as part of the patch process cannot be updated.

Group Properties

There are several properties that affect how groups respond to certain events when used as
a submaster. To edit these properties, right click on a group icon and select Properties. The
Group Properties window will appear:

This entry… does this…

Name The name of this group.

ID The unique ID number for this group.

Ignore “Release
All”

The group will ignore a Release All when used as a
submaster. This option is on by default.

Ignore
Snapshots

The fixtures in this group will ignore the settings in a
snapshot when a snapshot is recalled. This option is on by
default.

Exclude from
Store

The group’s levels as a submaster will be ignored when a
Store All Output operation is performed.

Presets

Presets are the building blocks that you use to create Cuelists. They represent common sets
of features that you know you’re going to want to use over and over again, such as a
particular color (e.g. Red) or position (e.g. on the drummer).

Presets are useful for two reasons. First, with presets you can quickly assign Intensity,
Position, Color, Gobo, Beam, and other values to any number of fixtures without having to

adjust the settings individually for each one. Second, if you store your Cues using presets you

can quickly update all your programming without having to edit every Cue across your whole
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show. By merely editing and updating the preset, every Cuelist that references it automatically

reflects the change.

Creating Presets
To create a Preset:

1. Select one or more fixtures.
2. Set any of the Intensity, Position, Color, Gobo, Beam, and Misc values on the panel

the way you want them.
3. Then either:

a. Click on any of the panel popup menu buttons (such as the color popup menu

button: ) and select Create Preset, or 
b. Select Components->New Preset, or

c. Click on the  button in the Components toolbar. (To open the
Components toolbar, choose View->Toolbar->Components), or

d. Right-click in a Presets Quick Picker and select the Create New Preset option. 
e. Hold [yellow/Ctrl/Command] and press the “+” button that will appear in the top-

right corner of a preset picker.

Vista displays the Create New Preset window:

Enter a name for the Preset in the name box.

Set the Preset store options:

This option… does this…

Label The name to be given to the new Preset. Duplicate
names are allowed; giving the new preset the same
name as an existing preset will not replace the
existing preset.

Global Values Tick Create Global Values if you want to be able to
use this preset on any fixture, of any type, even if it is
not selected when you store the preset.

Tick Create Fixture Type Values if you want to be able
to use this preset on any fixture, of the same type,
even if it is not selected when you store the preset.
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This option… does this…

Filter Fixtures Normally only the selected fixtures are included in the
Preset. If you want to include all fixtures in the preset,
click on the drop-down box and select the All option.

Filter Output Normally presets store the values that are outputting
from the current Cue or the programmer.

To store values no matter where they are coming
from, click on the drop-down box and select the All

option.

Filter Features The value recorded in the preset are, by default, per-
panel; i.e. the values that get recorded are filtered
based on whether you are recording into the Intensity
panel, the color panel, etc…. However, the filter bar

lets you include or exclude any features no matter to
which panel you are recording the preset. 

To include a feature, click on its icon so that it is
highlighted. To exclude a feature, click on its icon so
that it is not highlighted.
Note that unless you are specifically creating a Preset
in the Intensity panel group, the intensity filter is turned
off by default. If you want to include intensity, you
must specifically enable that filter option.

Display Preview panel Tick this checkbox to shows a preview of the fixtures
you have selected and the features that will be stored
in the preset.

Edit Opens the preset for editing in the Timeline view.
CuesThe output of Vista will be affected identically to
editing a regular Cuelist in this mode.

Edit Blind Opens the preset for editing in the Timeline view in
Blind mode. Editing in this mode will not affect the
output of Vista. Note that the fixture chooser icons will
not reflect the contents of the preset—only the feature
panels will show the features assigned to the fixtures
in the preset.

Click the OK button. Vista creates a new Preset that appears in the Presets panel of the
Component Sidebar and in Quick Pickers set to show All presets or ones containing the
feature type you’ve created.

If you have a Vista console, when the Create Preset window is open, you can assign the new
preset to a playback control by double-tapping a playback key.

Editing Presets
You can use the Editor to add, remove or change information stored in a preset. There are
two ways to open a preset for editing:
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· In the Sidebar Components tab you can right-click on the Preset and select Edit.

· In a Quick Picker panel you can right-click on the Preset and select Edit.

Once the Preset is open in the Editor you can make changes in the same way as you do
when editing a Cue (refer to the chapter on Cues and Cuelists):

· Select fixtures in the Fixture Chooser screen and add, remove, or change settings

using the panel or encoders, or

· Select fixtures or Event bars in the Timeline window add, remove, or change

settings using the panel or encoders.

To save changes to a Preset, choose Components->Save changes to Preset, or click the red
close icon on the tab for the preset you’re editing and you will be prompted to save or discard
the changes.

Updating Presets
You can use the Editor to update the information stored in a preset. To do this:

1. Either in the Live tab or a Cuelist tab, select the fixtures you want to change or add
to the preset.

2. Make the adjustments you want using the panels.
3. Either right-click on the preset and select Update from the popup menu, or if the

preset is assigned to a control in a console, hold [yellow/Ctrl/Command], and either
tap the control to which the preset is assigned or click on the Preset icon in a
picker.

4. Vista displays the Update Preset window:

5. Set the Preset update options just as you would for creating a new preset.
6. Select the Merge button if you want to add new information or update existing

information to the preset; select the Replace button if you want to discard the old
preset information and save the new settings.

7. Select OK to keep the changes, or Cancel to discard them.
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The Highlight and Lowlight Presets
The Highlight and Lowlight presets set the behavior of fixtures when Highlight mode is
activated:

· When you select a fixture, it goes to the Highlight preset.

· A fixture uses the Lowlight preset when it isn’t the primary focus of the current

selection. To activate lowlight, make a fixture selection of two or more fixtures and
then step forwards/backwards through your selection using the left/right fixture
selection arrow keys on a console or keyboard.

Note: To activate highlight mode, select Tools->Highlight, or select the Highlight button on the
User Softkey Toolbar (also by pressing the function key F4).

Updating the Highlight and Lowlight Presets

You can update the Highlight and Lowlight presets in the same way as you update other
presets. To do this:

1. Set the fixture(s) Intensity and any other features, such as color and beam, that you
want included in the Highlight setting.

2. Select Edit->Highlight->Update or Edit->Lowlight->Update. You can also right-click in
the Sidebar’s Components or Presets picker panel and select Update Highlight or
Update Lowlight. Vista opens the Update Preset window.

Editing the Highlight and Lowlight Presets

You can use the Editor to add, remove, or change information stored in these presets. To do

this:

1. Select Edit->Highlight->Edit or Edit->Lowlight->Edit. Vista opens the preset as a tab
in the Timeline window.

2. Once the Preset is open in the Editor you can make changes in the same way as
you do when editing other presets (see previous section).

3. Tap on the red Close icon on the Highlight or Lowlight Preset tab. Vista opens the
Save Preset Changes window.

4. Select Save to keep the changes.

You cannot change the name of the Highlight or Lowlight preset but otherwise updating the
High/Lowlight presets works the same way as for standard presets. For more information see
Updating Presets earlier in this chapter.

The Home Preset
The Home preset is used to set the behavior of fixtures when some or all of their features are
sent to their Home value. (Refer to the Common Features of the panels section in Chapter 7
for information on using the Home feature.)  For example, most fixtures with pan and tilt

features will go to their default values of 50% pan and 50% tilt when they are sent to the Home
position.
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If a fixture’s feature is not going to the setting you want when you set it to its Home value, you

can edit the Home preset to specify the value you want for those features.

Editing the Home Preset

You can use the Editor to add, remove or change information stored in the Home preset. To
do this, select Edit->Home->Edit. Vista opens the Home preset in the Timeline view of the Editor,
exactly like editing the Highlight and Lowlight Presets (or any other Preset):

1. Set any features (Intensity, Position, Color, etc…) of the fixture(s) you want to go to
non-default values.

2. Tap on the red Close icon on the Home Preset tab. Vista opens the Save Preset
changes window.

3. Select Save to keep the changes.

Updating the Home preset

You can update the Home preset in the same way as you update other presets. To do this:

1. Set the fixture(s) Position and any other features, such as color and beam, that you
want included in the Home setting.

2. Select Edit->Home->Update. You can also right-click in the Sidebar’s Component’s
Presets panel and select Update Home. Vista opens the Update Preset window:

You cannot change the name of the Home preset but otherwise updating the Home presets
works the same way as for standard presets. For more information see Updating presets
earlier in this chapter.
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SmartFX Templates

Vista comes with a number of built-in effects that you can use to quickly create dynamic looks

including intensity pulses, position shapes, color chases, and more.

To see the built-in effects, click on the Components tab and select the FX button, or set a

picker to display FX Templates. This lets you apply one of the built-in effects with just one
click but you can also use the SmartFX window to modify the built-in effect or create your own
effects from scratch.

See Chapter 12: SmartFX for more information about using effects in Vista.

Applying a Built-In Effect
To apply an effect:

1. Select the fixtures you want to work with.
2. Click the FX button on the Components tab. Vista displays a list of the built-in

effects:

The letters in the content column each effect tell you which features are in this
effect (e.g. I-Intensity, P-Position, C-Color, etc).

3. You can click on the filter bar icons to either include or exclude effects that include 
the corresponding feature types.

4. To apply an effect, click on the effect you want.
5. To adjust the features of an effect, open the SmartFX window and use the controls

to adjust it (see Effect Controls in Chapter 12: SmartFX).

Extracts
Extracts are like global programming templates and can contain any of the features you
define on the panels: intensity, color, beam, position, etc…. They also store any programmed
timing associated with the events.

An extract is a section of a Cuelist (or range of events) that you can save and re-apply in other
Cues, the live tab, and on different fixtures. By re-using existing material to build new Cues or
live looks you can save yourself a lot of time re-creating your favorite lighting effects.
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Creating Extracts
To create an extract:

1. Select the Cues of a Cuelist, or events on the timeline (discussed in Chapter 10: The

Timeline Window), that you want to use as an extract.
To select multiple Cues in the Editor:

a. Hold [yellow/Ctrl/Command] to select individual Cues.
b. Hold [red/shift] to select a range of Cues between the first and last. (Note that

Q view has to be active for both of these to work)

To select multiple events within a single cue:
a. Click and hold in an empty space in the timeline then drag over the multiple

events you would like to select. 

To select multiple events across a range of Cues:
a. Ensure Q view is active. 
b. Click and hold in an empty space in the timeline then drag over the multiple

events you would like to select. 
2. To store an extract, either:

a. In the Components tab of the sidebar, select the Extracts button. Then click on the
+ button, or

b. Hold [green/Alt/Option] and click on the New Extract button in the User Softkey
Toolbar, or

c. Right-click in a Quick Picker Extracts panel and select the Create Extract option.
d. Hold [yellow/Ctrl/Command] and press the + button that will appear in the top-right

corner of a preset picker.
3. The Create Extract window appears:

This field… Does this…

Label The name you decide to assign to this extract. Names do
not have to be unique, so be careful not to accidentally
assign duplicate names to an extract to avoid confusion.

Extract Type Determines what is stored in the extract:
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This field… Does this…

All Output: The current output of Vista is stored in the
extract, no matter where it comes from.

Selected Cues: The Cues that are currently selected are
stored in the extract. Features that are coming from
events in earlier Cues are not recorded in the
Extract.

Selected Cues with Tracking: The Cues that are currently
selected are stored in the extract. Active features
that are coming from events in earlier Cues and
tracked into the selected Cue(s) are also recorded in
the first Cue of the Extract. This gives you a
complete view of the output of these Cues stored in
the Extract.

Selected Events: Only the specific events selected in the
Timeline window will be stored.

Fixture Selection Controls whether data for all fixtures, or just the fixtures you
have selected, are stored in the Extract.

Filters Controls which features are stored in the extract.

Edit Opens the extract for editing in the Timeline view. Running
the Cues in the extract while editing in this mode will affect
the output of Vista identically to editing a regular Cuelist.

Edit Blind Opens the extract for editing in the Timeline view in Blind
mode. Running the Cues in the extract while editing in this
mode will not affect the output of Vista

4. Enter the name you want to give the new preset and select the options you desire and
click the OK button.

Vista adds the new extract to the extract list.

If you have a Vista console, when the Create Extract window is open, you can assign the new
extract directly to a playback control by double-tapping a playback key.

Applying Extracts
An extract can be later applied to the same set of fixtures it was programmed with, or a
completely different set of fixtures if they have matching features.

To apply an extract:

1. Select one or more fixtures.
2. Click the Extracts button on the Components tab of the sidebar, or set a Quick

Picker window to display extracts.
3. Find the extract you want and click on it to apply it.
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What happens when you apply an extract to a set of fixtures differs between applying an
extract in the Live tab, and applying an extract in a Cuelist tab.

When applying an extract in the Live tab, if the extract contains Cues, those Cues will be
played back with their programmed timing in sequence. If the extract contains event
information, those programmed events will be applied to the selected fixtures.

When applying an extract in a Cuelist tab, you will be presented with a window asking if you
want to insert or merge the extract into your Cuelist:

Note: The extract application preference can be defined in File->User Preferences, under the
Editing tab.

If you pick Insert, new Cues will be created to accommodate the information stored in the
extract after the currently selected Cue in the Cuelist. If the extract contains four Cues, for
example, four new Cues will be inserted into your Cuelist. If you pick Merge, the information in
the extract will be merged into the existing Cues starting at the selected Cue. If there are not
enough Cues to receive the extract data, then new Cues will be added to the end of your
Cuelist to accommodate the extract.

Editing Extracts
You can use the Editor to add, remove, or change information stored in an extract. To open an

extract for editing, either in the Sidebar Component tab, or in a Quick Picker Extracts panel,
right-click on the Extract you want to edit and select Edit.

Once the Extract is open in the Editor you can make changes in the same way as you do
when editing a Cue:

1. Select fixtures in the Fixture Chooser screen and add, clear, or change settings
using the panels and encoders, or

2. Select fixtures or Event bars in the Timeline window to add, remove, or change
settings using the panels and encoders.

To save the changes to the Extract, either choose Components->Save Changes to Extract

option from the Components menu,  type [green/Alt/Option] S, or close the Extract tab in the
Editor and select Save when prompted.
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Chapter 9: Working With and Storing

Cuelists

Once you’ve set up your patch, arranged your fixtures, assigned them to groups, and created
the presets you want, you’re ready to create a Cuelist. A Cuelist is a sequence of Cues, each

of which contain lighting changes that you’ve programmed into it.

It is important to note that Vista is by default a Tracking console. When you store a Cue, only
the values that have changed are saved in a Cue. Values will track forward into subsequent
Cues until changed.  More information about tracking can be found later in this chapter.

Vista offers four ways to start a new Cuelist. You can either:

1. Store a Cue directly to one of the playback controls on a console with as few as
three button presses. With this method the Cuelist is automatically given a name
and number and the Cue you’ve stored is ready to play. Later you can add more
Cues to the same Cuelist, change fade times, and modify other settings by
opening it in the Editor.

2. Use either of the two Store buttons in the User Softkey Toolbar to store directly to a
console playback or to an existing Cuelist. Store All is a quick way to store the
entire console output and automatically sets the most popular options. Store Part
provides access to more advanced options and filtering.

3. Open a new, empty Cuelist in the Editor and create one or more Cues in it. With
this method you can edit as you go refining the Cue fade times and every other
aspect of the Cuelist. 

4. Storing from the Command Line (refer to Chapter 19 – The Vista Command Line).

Store All
The Store All function is arguably Vista's simplest storing method. The reason for this is that it
records the active stage values, exactly as you are seeing them at the time of pressing Store
All. Store all does not care about where the source programming is coming from. It will record
all values coming from the Editor, any active Cuelists, and Group faders.

To store a cue using the Store All method, click on Store All on the User Softkey Toolbar, or
select Tools->Store All. Vista displays the Store All window.
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The first two boxes at the top tell you where you are about to store to. The left box specifies
the Cuelist, and the right box tells you the Cue within that Cuelist. It is important to mention
that you do not name the Cuelist or Cues within these two entry boxes. These two boxes tell
you the destination information only. If you would like to label the Cuelist or cue, this is done in

the bottom two boxes.

You can also store directly to a console playback instead of pressing OK in the Store All
window by double-tapping a playback button.

There are several important features of Store All:

· All the feature settings that the console is sending to your fixtures are saved. The

settings could be coming from the Live tab, any other Cuelist being played, a
playback control, or any other control on the console.

· Feature settings for fixture features that are at their default will not be stored. For

example, if a fixture has 100% intensity, and in color blue, Store All saves those
settings but doesn’t save anything for Gobo, Position, or any other feature of the
fixture if the user had not at any point changed them from their default values. This
means that if you play the Cue back, it’s possible that another Cue will influence
what you see.

· The default operation is to append a new Cue at the end of the current default

Cuelist (see Default Cuelist later in this chapter).

· If you choose to store to an existing Cue, that cue will be replaced. For example, if

you have a Cuelist with 10 Cues, Store All will default to saving to Cue 11. If you
choose to save to Cue 4, whatever was in that Cue will be replaced when you store.

· If you insert a Cue before an existing Cue, its settings will not change the look you’ve

have saved in the existing Cue. This is called “Cue only” and means that any
settings in the inserted Cue are automatically undone in the following Cue.

· When you Store All directly to a Playback, it will immediately take control of the Cue

and any setting coming from the Live tab will be cleared. Because Store All includes
all output of the console, this won’t change anything the fixtures are doing—just
where the control is coming from. (Note that if you have the Cuelist assigned to a
Playback Control, you need to have the fader turned up to 100% for this to be true.)
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Storing a Look in Three Clicks
If you have the Fixture Chooser window open and you are working in the Live tab you’ve
probably already selected some lights, given them Intensity, Color and so on. To create a new
Cuelist fast, you do this:

1. Click on Store All on the User Softkey Toolbar, or select Tools->Store All. Vista
displays the Store All window with all the store options preset.

2. Double-tap on the select button of an empty playback on your console. If you are
using the PC version, switch to the Console window and double-click one the
select buttons there.

3. The new Cuelist is ready to use. You can move the fader to bring the intensity
levels stored in the Cue down and back up. Note that the fader only affects intensity
—it does not affect other features such as color, position, etc….

When you Store All using this method to a playback control with a fader, the fader is
automatically configured to be a Submaster.

Storing a Look with Options
When you want to adjust the timing of a Cue or give it a new name or number before storing
you use the Store All window. To do this:

1. Click on the Store All button or select the Store All option on the Tools menu. Vista
displays the Store All window:
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2. Vista sets the Store To Cuelist to the current default Cuelist. If you want to store to
a new Cuelist, or another Cuelist you’ve already started, you can either:
a. Press Browse and select a different Cuelist, or press New to start a new Cuelist
b. Type a few numbers or letters from the name and select the Cuelist you want

from the popup window. Vista displays all the Cuelists that include the letters or
numbers you type:

3. Vista sets the Store To Cue to a new cue number at the end of the default Cuelist.
If you want to a choose a different cue number, or want to store over an existing
cue, you can either:
a. Type a new number, or
b. Type a few numbers or letters from the name and select the Cue you want from

the popup window. Vista displays all the Cues that include the text you type:

4. If you want to store to an existing Cuelist but aren’t sure of its name or number,
click the Browse button. Vista displays the Cuelist and Cues window where you
can select from all your saved Cuelists:
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This option… does this…

All Filters the browser to show all the Cuelists you’ve stored.

Recent Filters the browser to show just the last few Cuelists you’ve
stored.

Playing Filters the browser to show just the Cuelists that you are
playing back.

Console Filters the browser to show just the Cuelists that you are
visible on the console—i.e., Cuelists that are on the

playback pages you can see.

New Creates a New Cuelist with the next available number.

Cuelist number
field

Displays the Cuelist number to save. You can enter a new
number in this field.

Search (Cuelists) Typing a few letters or numbers in the search box filters the
browser to show just the Cuelists that match what you type.

Select Cue Displays all the Cues already stored in the selected Cuelist.
Normally the ‘New Cue’ line will be highlighted indicating
that you will be storing to a new Cue at the end of the
Cuelist.

To store over an existing Cue, highlight the one you want.

Inserts a new Cue before the line the icon is on.

Search (Cues) Typing a few letters or numbers in the search box filters the
browser to show just the Cues that match what you type.

5. Click on the icon in the Cue Start Mode section to set how the Cue will start, the
options are: 

a. Halt: Press the Go button to play the Cue.
b. Follow: Play “n” seconds after the previous Cue has ended.
c. Start: Play “n” seconds after the previous Cue has started.
d. Timecode: Play at the specified Timecode (i.e. 01:02:03:04 would start the Cue

when timecode 1 Hour, 2 Minutes, 3 Seconds and 4 Frames is received through
a Timecode interface). 

6. If you’ve made the Cue start mode “Follow” or “Start”, enter the time (in seconds)
after the previous Cue has ended or started to start this Cue.

7. Set the fade times for the Cue. To do this you can either:



Chapter 9: Working With and Storing Cuelists 135

a. Set the up and down fade time by typing in the time box. For example, typing 2/3
sets the fade-up time for all features to 2 seconds and the fade-down time for
Intensity to 3 seconds or, 

b. Click on the timing drop down and select from the list of preset times or,

c. Click on the timing bars and drag them to the fade times you want or,

d. Click on the  expand icon to reveal the detailed timing view:
In the detailed view you can set a fade time, delay time, and fade curve for each
of the six feature types: Intensity (up and down), Position, Color, Gobo, Beam,
and Miscellaneous channels. To set times either type in the boxes or click on
the timing bars and adjust them. To change the fade curve, click on the icon and
select from the popup list.

8. If you are storing to a New Cuelist, you can give it a label in the Cuelist Label box. If
you are storing to a New Cue, you can give it a title, in the Cue Label box.
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9. Click OK to complete the Store All operation or double-tap on a playback’s Select
button to store the Cuelist to that playback.

Tip: to store to a hardware playback control and open it immediately for editing, hold down
[yellow/Ctrl/Command] and press the Select button on an empty playback to Store your look
and open the Cuelist in an Editor window.

Store Part
The Store Part function provides you with the opportunity to choose which part of the stage
look you would like to store, and from which specific sources. Thus, it allows you to store the
“part” of Vista’s output that you desire to store.

“Store part” is also the traditional lighting console store operation in that, by default, it only
stores events coming from the Programmer, and events programmed within Cues will track
forward into subsequent Cues. (See the section on Tracking later in this chapter.)

If you’ve created information in the Live tab of the Editor (or another Cuelist), you can add it or
merge it into an existing Cuelist, or use it to replace a Cue altogether. You can also start a
new Cuelist using the Store Part method.

To utilize Store Part, click on the Store Part button in the User Softkey Toolbar or select Tools-

>Store Part. Vista displays the Store Part window:
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Selecting the Cuelist in Which to Store
Vista automatically sets the Store To Cuelist to the default Cuelist. If you want to store to a
new Cuelist, or another Cuelist you’ve already started, you can either:

1. Click on the New button in the Cuelists panel to start a new Cuelist, or

2. Tap on a Console’s playback’s Select button to select the Cuelist on that playback, or

3. Click on the Cuelist you want in Cuelists panel, which displays all your saved Cuelists.

To help find a particular Cuelist, you can filter using the source and search options:

This option… does this…

All Filters the browser to show all the Cuelists you’ve stored.

Recent Filters the browser to show just the last few Cuelists you’ve
stored.

Playing Filters the browser to show just the Cuelists that you are
currently playing back.

Console Filters the browser to show just the Cuelists that are visible
on the console or console—i.e. Cuelists that are on the
playback pages you can see.

New Creates a New Cuelist with the next available Cuelist
number.

Search (Cuelists) Typing a few letters or numbers in the search box filters the
browser to show just the Cuelists that match what you type.

Selecting the Cue and Store Options
You can add a new Cue, merge to an existing Cue, or replace the contents of an existing
Cue. When you first open the Store Part window, the Cue Add button will be selected

automatically. The Merge and Replace options will not be available unless you select an
existing Cue first.
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1. If you are adding a new Cue you can either accept the Cue number Vista suggests
or type a number in the Cue Number box or click on one of the insert icons in the

list of Cues to set the insert location:  
2. If you are Merging or Replacing you can either type a number in the Cue Number

box or click on any Cue in the Cue list panel. Once you select a Cue from a
Cuelist, you can pick Merge or Replace as the top of the Store Current Events
window.

3. For a new Cue enter the Cue number and name.
4. Click on the icon in the Cue Start Mode section to set how the Cue will start. The

options are:

a. Halt: Press the Go button to play the Cue
b. Follow: Play ”n” seconds after the previous Cue has ended.
c. Start: Play “n” seconds after the previous Cue has started.
d. Timecode: Play at the specified Timecode (i.e. 01:02:03:04 would start the Cue

when timecode 1 Hour, 2 Minutes, 3 Seconds and 4 Frames is received)
5. If you’ve made the Cue start mode Follow or Start, enter the time in seconds after

the previous Cue has ended or started to start this Cue.

6. Select the timing option to apply to the Cue. The options are: 
a. Destination - use the timing of the Cue you are saving to.
b. Custom - set  a time manually.

7. Select the Contents options:
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This option… does this…

All Fixtures Includes all fixtures that have features set in the store
operation.

Selected Fixtures Includes only selected fixtures in the store operation.

All Output Select this button to store all features, from both the
Programmer and any active playbacks, including Cuelists or
Group Masters.

Programmer Store only features currently set in the Programmer.

8. Select the features to store using the filter bar:

Click on any of the Intensity, Position, Color, Gobo, Beam, or Miscellaneous icons

to mask or un-mask that feature.

9. Select the tracking options:

Click the Cue Only checkbox to undo any changes in the following Cue. This option
will not have any effect unless there is at least one Cue after the one you are
editing.

10.Select the Blocking options: 

This option… does this…

No Blocking The Cue is stored normally.

Normal Blocking Ensures that events that are tracking through to the Cue
being stored will not be changed even if they are modified in
the earlier Cue(s) once the block is assigned.

Superblocking When a Superblock Cue runs, any features for the fixtures
in the Cue that aren’t already included in the Cue are
automatically sent to their home value. This means that the
Cue will look as it would if no other Cuelist is playing.
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Opening a Cuelist in the Editor

The Store All and Store Part methods let you store Cues to an existing (or new) Cuelist
without first opening the Cuelist in the Editor.

You can also start a new Cuelist from scratch or open an existing one in the editor. To do
open a new Cuelist for editing, click on the New Cuelist button in the User Softkey Toolbar
(normally F2), or select Components->New Cuelist.

Whichever method you choose, Vista creates a new Cuelist tab and displays the Fixture
Chooser screen.

To open an existing Cuelist in the Editor, you can either:

1. Click the Edit Cuelist button from the User Softkey Toolbar (normally F1), or
2. Click Components->Edit Cuelist, or
3. Right-click on a Cuelist in a quick-picker window and pick the Edit option.

The Cuelist will be opened in a new Editor tab.

Cuelist Editor Tabs

When you first open the Fixture Chooser or Timeline screens, you’ll see the Live tab—this is
the equivalent of what other consoles call the Programmer. If you open a Cuelist or start a
new one from scratch, Vista adds a new Editor tab labelled with the Cuelist name. You can
have several Cuelists open at once and switch between them by clicking on the tab you want
to work on:

When an Editor tab is selected, this becomes the Editor Cuelist and changes you make will
go directly into that Cuelist. 

To commit the changes made to a Cuelist to the Showfile at any time, select Components-

>Save Changes to Cuelist, or type [green/Alt/Option]+S. Alternatively, you will be prompted if
you want to include the Cuelist changes if you select File->Save.

To close a Cuelist tab, choose Components->Close Cuelist, or click the close icon on the
Cuelist tab. If the Cuelist has unsaved changes, you will be prompted as to whether you want
to save or discard those changes.

When there is information in the Live tab that is affecting the output, a red clear icon

 is added to the tab. Click on it to clear the Live tab output, or while the Live tab is
selected, select the Clear button from the User Softkey Toolbar.
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The Default Cuelist

There are some operations in Vista, such as storing / labelling or setting times to Cues from
the command line that operate on the “Default” Cuelist. If you have a hardware control surface
such as the Vista EX (or are using a virtual control surface in the Console window), the
Superplayback control section of the control surface works on the default Cuelist if there are
no Cues open in the Editor.  If you do not have a console, the spacebar will perform this
action.

The Default Cuelist is always the first Cuelist created in your show. To change the current
default Cuelist, you can do one of the following operations:

· If you are using a control surface (or a virtual control surface in the Console

window), press the Select button for the controls which have the desired Cuelist
assigned to it.

· Right-click on a Cuelist in a Cuelist Quick Picker panel and pick Select.

· Type W followed by the Cuelist number in the command line and press Enter. (W is

the keyboard shortcut for Cuelist.)

If the Cuelist is open in the Editor, select that Cuelist’s tab and press the select button next to
the Cuelist name:

Note that this button will be red if the Cuelist in the Editor is already the Default Cuelist.

Playing and Moving Around in a Cuelist

To the left of the Live and Cuelist tabs in the Timeline and Fixture Chooser screens there is a
set of player controls for controlling the Cuelist tab that is selected:

This button… does this...

Jumps to the first Cue in a Cuelist over the Live time.

Pressing it a second time releases the Cuelist such that the
first Play keypress plays the first Cue.
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This button… does this...

Jumps backwards to the previous Cue in a Cuelist over the
Live time.

Pauses the playback of a transitioning Cue. If pressed a
second time, the current Cue returns to the previous cue
using the timing of that cue. 
If a cue has completed its transition and the “pause” button
is pressed the Cuelist will play backwards using cue time.

Starts playback of the next Cue in the Cuelist, or the first
Cue if the Cuelist is not active yet.

Jumps forwards to the next Cue in a Cuelist over the Live
time.

Jumps to the last Cue in a Cuelist over the Live time.

Cuelist Navigator
The Cuelist navigation section shows you an overview of all the Cues in a Cuelist.

Each Cue is represented by a mini Cue icon in a scrollbar so you can see all the Cues you’ve
stored. As you add more Cues more icons are added to the scrollbar. If there are more Cues
than can fit in the Cue tile (or table or layout) view the scroll bar becomes shaded. You can
drag the shaded area to show different parts of the Cuelist in the list, table, and layout views.

The Cue scrollbar includes buttons to switch the navigator view and to add or delete Cues: 

This icon… does this…

Tiles view

Shows the Cues as a series of tiles.

Table view

Shows the Cues as a table with columns for the Cue’s
name, number, fade time, follow time, blocking status,
included features, fixture count, and SmartFX.

Layout view

Shows the Cues on a timeline. This view is useful if have
Cues with follow times that mean they overlap other Cues.
You can move Cues and set follow times by dragging Cues
on the timeline.

Zoom

Zooms the layout view to fit all the Cues in available space.
To zoom to a specific level, click and hold on this icon and
then move your mouse up and down or left and right.



Chapter 9: Working With and Storing Cuelists 143

Tiles View

In the Tiles view:

· Each Cue tile shows the number, name, duration, and start of Cue action. If there is

a different Upfade vs. Downfade time, both times are shown separated by a slash
(e.g. “2/4s”).

· The Cue or Cues that are visible in the Timeline window (Described in Chapter 10:

The Timeline Window) are shown with a green underline.

· Cues that have played show with a green fill color.

· The selected Cue shows with a yellow outline and with yellow text. Click on a Cue’s

tile to select it; shift-click or ctrl-click to select a range or group of Cues. Note that
ctrl-click will not work while Link is engaged.

You can click on a tile’s start action, Cue number, label or duration and enter a new value.
The Cue number cannot be changed to a value that would mean changing the order of the

Cue tiles.

You can right-click on a selected Cue or in the blank area to the right of the Cue list to open a
popup menu:



Vista User's Guide, Version 3.3144

With these options you can:
· Open the Cue or Cuelist properties window.

· Set the Cue Follow mode (aka Cue start

action) for the selected Cue(s).

· Block, superblock, or unblock the selected

Cue.

· Set the Cue to be a Mark (Move in Black) Cue.

· Append a Cue at the end of the Cuelist, or

insert a new Cue before or after the selected
Cue, or at the playhead position.

· Delete or renumber the selected Cue(s).

· Revert (or undo) changes to the selected

Cue(s).

· Change the start time of the selected Cue(s).

· Remove any alias Cue links (without deleting

any Cues or events).

· Add an audio file.

· Cut or copy and paste or paste special (paste

with options) the selected Cues.

· Change the appearance of the Cue tiles by adding or removing fields.

Table View

In the Table view:

· Each Cue shows as a row in a spreadsheet style view.

· The selected Cue shows with a red fill and white text. Click on a row to select a

Cue, shift-click or ctrl-click to select a range or group of Cues.

You can double-click on a Cue number, name or duration label and enter a new value. The
Cue number cannot be changed to a value that would mean changing the order of the Cues.

Layout View

In the Layout view:
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· The Cues are laid out end to end, in timeline view. Cues that are set to start before

the previous Cue finishes overlap and appear on a separate line.

· The selected Cue shows with a red outline. Click on a Cue to select it; shift-click or

ctrl-click on other Cues to select a range or group of Cues.

You can double-click on a Cue’s name and enter a new value. To move a Cue click and hold
while dragging the Cue to the left or right.

Cuelist and Cue Search Boxes
You can quickly select a specific Cuelist for editing, or select a Cue within the current Cuelist
for editing, by using the Cuelist search boxes located below the Cuelist navigator:

This consists of two edit boxes, one displaying the current Cuelist, and the other showing the
current Cue within that list. 

To edit a different Cuelist, click in the Cuelist search box and start typing either the number of
the Cuelist or part of the name of the Cuelist. Vista will display a list of Cuelists filtered to
those that contain the text you are typing. Select the desired Cuelist, and that Cuelist’s edit tab
will be opened.

To edit a specific Cue within the editor Cuelist, click on the Cue search box and start typing
either the cue number or Cue name. A list of Cues that match the text you are typing will
appear; Select the Cue you wish to edit and the Editor tab will make that Cue the current
editor Cue.

Adding and Deleting Cues

Inserting Cues
A Cuelist can contain as many Cues as you like. To add a new Cue after the one that’s
currently selected:

· Click on the  New Cue icon at the end of the Cuelist scrollbar, or

· Choose the Tools->Cues->Insert Cue After Selected.

You can also insert Cues before or after an existing Cue by first selecting a Cue then clicking

and holding the  New Cue icon until the insert popup appears:
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The popup provides options to:

· Insert a new Cue before the selected Cue.

· Insert a new Cue after the selected Cue.

· Append a new Cue at the end of the Cuelist.

These options are also available on the Tools->Cues menu.

Deleting Cues
To delete a Cue, first select it and then either:

· Click on the  Delete Cue icon at the end of the Cuelist scrollbar.

· Select the Tools->Cues->Delete Cues.

Merging Cues
Sometimes it’s useful to merge the contents of two or more Cues. To do this:

1. Select the Cues with the pen or mouse. Shift-click or ctrl-click to extend the
selection to include the Cues you wish to merge.

2. Select Tools->Cues->Merge Cues.

Cues always merge to the lowest Cue number.

Moving and Copying Cues
Often you’ll have a look in one or more Cues of a Cuelist that you’d like to use in another place
or another Cuelist. You can do this using the Cuelist navigator panel.

To do this:

1. Select one or more Cues by clicking on the Cue tiles.
2. Choose Edit->Copy Cue or Edit->Cut Cue, or type Ctrl-Shift-C or Ctrl-Shift-X, or

right-click on the Cue(s) and select Copy Cue or Cut Cue from the popup menu.
3. Click on the Cue before the location you want to move or copy to.
4. Choose Edit->Paste, type Ctrl-V, or right-click on the Cue(s) and select Paste from

the popup menu. The default paste action will restore the look of the copied Cue by
inserting release events for any features added in the intervening Cues. To paste
just the events or an alias of the Cue, use Edit->Paste Special option.
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Alternatively, a much quicker way of performing a copy/paste action is to click and hold on the
cue(s) that you would like to copy and drag them to where you would like to paste them. You
will notice a red line appear in between your Cues—let go when the line is at the position
where you would like the Cues to be copied. Hold down [red/Shift] while performing this

operation to bring up special options including Move Cue and Alias Original Cue

If you want to move or copy just the events in the original Cue without releasing any other
events that occur in previous Cues, you can use Edit->Paste Special, or by typing Ctrl-Shift-V

This brings up the Paste Special window with these options:

This option… does this…

Paste the entire look of the
original Cue

Restores the look of the original Cue by inserting
release events for any features added in the
intervening Cues.

Paste only the events of the
original Cue (non-tracked)

Pastes the events in the original Cue without
adding any release events.

Alias original Cue Pastes an alias of the original Cue. Any changes
made to the original Cue will also be reflected in
any aliases.

Alias Cues
If you want to use the same Cue in a Cuelist several times you can make an Alias. This way if
you update any one of the associated alias Cues, they will all update.

Creating an Alias Cue

To create an alias Cue:

1. Copy the Cue by selecting it and choosing Edit->Copy, or press Ctrl-Shift-C.
2. Navigate to the Cue before the position you want the new Cue to appear.
3. Choose Edit->Paste, or type Ctrl-Shift-V. Vista opens the Paste Special window.
4. Select the Alias Cue option and click OK. Vista pastes an Alias Cue after the

selected Cue.

Alias Cue tiles are marked with a small Alias icon and you can view the Cues that are aliased
to each other in the Aliased Cues section of the Cue properties window.

Removing the Link to an Alias Cue

An Alias Cue can be changed to normal Cue. To do this:

1. Select the Cue tile to be changed.
2. Select Edit->Remove Cue Alias, or right-click on the Cue tile and pick Remove Cue

Alias.
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Tracking Concepts

It is important to note that Vista is by default a Tracking console. When you store a Cue, only
the settings that have changed are saved in a Cue. For example, if a fixture is set to 50%
Intensity in Cue 1 and is not changed until Cue 5, there won’t be any Intensity events stored in
Cues 2-4 for that fixture, and yet it will remain at 50%. That means if you later change the
intensity for that fixture in Cue 1, it will affect the look of Cues 2–4.

The important difference in a tracking system is that when a parameter change is stored for a
fixture, that change stays in affect through future Cues (i.e., “tracks” through future Cues) until
it’s changed again or released, even though that value is not recorded in those Cues. Think of
it like the cruise control system in your car—if you set your cruise control at 80 on mile 5,
you’re still going 80 at mile 6, 7, 8, …, even though you’re not actively doing anything to keep
the car at 80 at those miles. The speed remains in effect until you specifically take an action
to change your speed again.

Making Changes to a Cue Without Affecting the Next Cue

It’s often useful to make changes to a Cue without those changes tracking through to the
following Cue. For example, you might have a Cuelist where the lights change to color blue in
Cue 1 and stay that way until they change to red in Cue 10. If you then decide you want them
to be yellow in just Cue 5 you could make that change but since there are no color events in
Cues 6-9 the lights will stay yellow when you really want them to revert back to blue in Cue 6.

For this situation Vista provides a method to make changes that affect only that cue.

Working in Cue Only Mode

1. Select Tools->Cue Only Editing, or hold down [blue/Ctrl+Alt/Control] and pick Cue
Only Editing from the User Softkey Toolbar.

2. Make your cue edits as normal. Using the same example as mentioned above, if
you change cue 5 to yellow, you will notice that as soon as you do this cue 6 will
automatically return to blue. 

Cue only will remain activated until you manually turn the feature off again. You can also
create entire new Cues when working in this mode.

Untracking events
If you have already made a change to a cue and then later realize that you need this not to
track through into the next cue you can use “untrack events” 

To do this:

1. In the Timeline window select the events you would like to untrack—they will
normally be highlighted already.

2. Right-click on one of the selected events and select Untrack Events. Vista inserts
events in the following Cue to set the lights back to the state they were in before the
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change. If there were no events of that type originally, Vista inserts release events
instead.

Blocking a Cue
Sometimes it’s useful to “block” a Cue so that any changes that are subsequently made to
previous Cues will not affect the final look of the chosen Cue—for example, a blackout at the

end of a show that must remain a blackout, even if you add a new light into the mix in an
earlier cue.

To do this:

1. Select the Cue with the look that you want to keep exactly as it is.

2. Hold [yellow/Ctrl/Command] and choose the ‘Block’ button on the User Softkey

Toolbar or select Tools->Block Cue, or right-click on the Cue tile and select Block

Cue.

Vista duplicates all tracked information into the selected Cue. There is an Unblock Cue option

which can be found below the Block option should you wish to remove a Block.

Creating a Mark (Move in Black) Cue
Sometimes you will want fixtures to move to a position, change to a color, add a gobo, or get

set up in some other way while their intensities are at zero. You could do this by programming
the necessary events, but you can also do it quickly using the Mark Cue option.

To Mark a Cue and add "Move in Black" events:

1. Select the Cue you want to work with.
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2. Choose Tools->Mark Cue, or right-click the cue and select Mark Cue. Vista opens
the Move in Black window: 

3. This screen shows the options available. Use it to set the way Vista stores the
Move in Black event. Note that some of these options are only visible if a parent
option is selected.

This option… does this…

Move in black
destination Cue

Most of the time it should be fine to leave this at the
default “Select existing cue” to mark the event in the
cue prior. 

If the “Select Cue” button is not greyed out you can
click it to select any Cue earlier in the Cuelist in which
the Move in Black events will be placed. This may be

useful to hide the MIB fixture noise under a noisy part
of the show.

When working with this method the features that are
moving in black will do so using the same timing as
cue they are contained within.

If you prefer to create a new Cue dedicated for the MIB
events, select the “Insert a new move in black Cue”
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This option… does this…

option. When working with this method you have the
option of adjusting the cue duration.

Cue Details – Name Sets the name for the new Cue that will be created.
The default name is MIB.

Cue Details – Duration Sets the duration for the new Cue.

Start action Sets how the MIB Cue is started, the options are: 
Halt: Press the Go button to play this Cue.

Auto Follow: the Cue plays automatically after the
previous Cue.

Finish with preceding: the Cue plays automatically and
is set to finish at the same time as the previous Cue.

Disable Move in Black Removes the Move in Black events from the MIB Cue
but does not delete it.

Marked Features

- Feature filter

Only the selected features will be marked for move in
black.

Marked Fixtures

All Fixtures

Current selection

Enables you to choose to mark all fixtures or just the
ones currently selected.

4. Click OK to create the Move in Black Cue:

The Move In Black events are shown as “ghosted” events (dimmed out) and display the "MIB"
icon. These events appear greyed out and cannot be selected or manipulated. Move In Black
Cues show “MIB” in the tiled Cue display and “[M]” in other views.

Individual events in a marked Cue can also be excluded from move in black. To do this, select
the events in the timeline view and select Timeline->Ignore Move In Black->Ignore Move In

Black. Ignored events show a MIB icon with a red cross running through it.
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Cue Properties

Each Cue has a number, name, and fade time that you can set by clicking on the Cue tiles

and editing the fields. You can also set these properties and other advanced options more in
the Cue Properties window.

To do this:

1. Select the Cue you want in the Cuelist navigator.
2. Choose the Cue Properties option from the edit menu or right-click on the Cue tile

and select the Cue properties option from the popup menu.

By default, the Timing section of the Cue Properties window is twirled open. To twirl open or

close other sections, click the round button with the arrow in it that’s next to the section name.

Modifying Cue Name, Duration, and End of Cue Action
The Cue’s name, number and how it starts can be set in the properties section of the window:

This option… does this…

Label Sets the name for this Cue.

Cue number Sets the number for this Cue The Cue number cannot be
changed to a value that would mean changing the order of the
Cue tiles.

Follow Time
(Cue Start
Mode)

Sets how the Cue will start, the options are:

 (Halt) Press the Go button to play this Cue.
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 (Follow) Play ”n” seconds after the previous Cue ends.

 (Start) Play “n” seconds after the start of the previous

Cue.

 (Timecode) Play when the timecode is received.

Default timing Sets the timing for all events in the cue that have not been
manually adjusted. The popup window lets you select from the
saved timing sets or customize a new one.

Ignore Learn
Timing

Tick this checkbox to ignore this Cue when using the Learn
Timing feature.

Making a Cue Loop Back
A Cue can be set to loop back to a previous Cue and to repeat the loop any number of times.
Looping is set in the loop section of the Cue Properties window:

This option… does this…

Loop iterations Sets how many times the loop will repeat before the Cuelist
proceeds normally.

Loop to Cue Sets the Cue that will play next.

Loop tracking Sets whether the events stored in the Cues after the Loop
to Cue will track through to the loop Cue.

Loop direction Sets the direction of the loop. The options are:

Forwards - loops from last to first.

Backwards - loops from last to previous.

Bounce - loops backwards then forwards.

Random - loops to a random Cue between the first and last
Cue in the loops.

Cues set to loop don’t play automatically like a chase would. If you want any of the Cues in a
loop to play without pressing Go, you need to set the Cue start mode.
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Alias Cues
Alias Cue tiles are marked with a small Alias icon and you can view the Cues that are aliased
to each other in the Aliased Cues section of the Cue Properties window:

Blocking / Tracking
Normally features that are stored in any Cue track forward until they are replaced by a new
event or released. If you only want some events to play in one Cue and not track forward, you

can turn tracking off for one or more Cues. To do this, open the Blocking / Tracking section of

the Cue properties window and tick the Non-Tracking checkbox:

Normally only changed features are stored in any Cue and information tracks forward until it is
replaced by a new event or cleared. Sometimes it’s useful to “block” a Cue so that any
changes that are subsequently made to previous Cues will not affect the final look of the
chosen Cue.

To view or modify the blocking for a Cue, open the Blocking/Tracking section of the Cue

Properties window:

This option… does this…

None The Cue is stored normally.
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This option… does this…

Blocking Ensures that events that are tracking through to the Cue
being stored will not be changed even if they are modified
in the earlier Cue(s).

Superblocking Ensures that events that are tracking through to the Cue
being stored will not be changed, even if other Cuelists

that include the same feature types are played prior to this
Cue being played.

Block Features Sets which feature types are blocked. Click on the
Intensity, Position, Color, Gobo, Beam, and Miscellaneous

icons to turn that feature on or off.

Block Fixtures Sets which fixtures are blocked. You can choose either All
Fixtures or Current Select (the ones you have selected in
the Editor).

Free Effects Mode
In Vista effects can either have a “basepoint” or be “free”. A Free effect is designed to run on
top of a feature setting coming from any source. For example, a free circle effect will cause

fixtures to move in a circle around whatever position has been set by another Cue or setting
from the console.

To view or modify the Event mode for a Cue open the Free Effects section of the Cue
properties window:

This option… does this…

Events provide
Basepoint

Events in the Cue will be used as a base point for any
baseless effects that are running.

Events stop Free
effects

If the Cue includes an event that a baseless effect would
act on, the effect instead will be stopped.

Audio Playback
To play an audio file when the selected Cue plays, click on the Audio Playback heading to

open that section.
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This property… does this…

Browse Opens the Select Audio window where you can
choose an audio file.

Clear Removes the audio file from the Cue.

Audio files added to the show are automatically copied to the Show Resources folder located
in the Vista storage folder selected during installation. By default, this is the “Vista 3” folder in
the user’s Documents folder.

Note: To add an audio file that plays through all Cues, use the Cuelist Properties window.

Defaults
If you have a set of Cue properties that you use frequently, for example the cue time, you can

save them as your Show default and they will be used for all future Cues. You can also
quickly reset a Cue’s properties to the factory defaults or to your show defaults.

This option… does this…

Reset to show
defaults

Reset all Cue properties to the settings you have saved as
the show defaults (see below).

Reset to factory
defaults

Reset all Cue properties to their standard (factory)
settings.

Save as show
defaults

Saves the current Cue settings as a default for all new
Cues.
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Notes

The Notes section is merely a place where you can type in comments, reminders, etc…
about this Cue. This note will appear in the Playback window:

Cuelist Properties
Each Cuelist has a set of properties that control how it plays back and interacts with other
Cuelists. You can set these properties in the Cuelist Properties window.

To do this, right-click on a Cuelist in a Quickpicker and pick Properties, or while editing a
Cuelist, pick Edit->Cuelist Properties.

At the top of the Cue Properties window, the Label and ID number for this Cuelist is displayed:

While the ID field is not editable, the label of the Cuelist can be changed here.

The Options Tab
The Options tab provides access to the general properties of all Cuelists:
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This property… does this…

Priority Sets the priority for the Cuelist. A Cuelist set to High
priority can’t be overridden by normal or low priority
Cuelists. Only a Cuelist set to Programmer priority
can override the Programmer.

Play at end option Determines what happens after the last Cue is
played and fully over-ridden. The options are:

Restart: The Cuelist starts again at the first Cue.

Release: The Cuelist is released.

Ignore: Do nothing.

Ignore Release All The Cuelist will ignore the Release All command.

Ignore Snapshots The Cuelist will not be affected by a snapshot being
loaded.

Release in Black A Cuelist will first release intensity values before
non-intensity values when being given a release
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This property… does this…

command.

HTP Enabled Causes the intensities of a Cuelist to work on a
highest-takes-precedence behavior. 

Fader Type Normally the fader on a playback set will adjust the
Intensity of a Cue list. To fade all features (Intensity,
Position, Color, Gobo, Beam and Custom) in or out
with the fader set this property to “All Features”.

Fader Auto Play Sets the fader play and release actions. The options
are:

None: the fader only controls intensity.

Auto Play: raising the fader above 0% also plays the
Cue (aka “Go on fader up”).

Auto Play & Release: raising the fader above 0%
also plays the Cue (aka ”Go on fader up”). Lowering
the fader to 0% releases the Cue (aka ”Release on
fader down”).

Auto Release: lowering the fader to 0% releases the
Cue (aka ”Release on fader down”).

Flash Auto Play When “Auto play next cue after a flash” is set, upon
the completion of the Flash decay the Cuelist will
advance to the next cue.

Fader Intensity Time Controls how the initial fader move on an Auto-play
fader is timed.

Programmed: The move up from zero triggers the
fade to follow the timing of the first Cue in the
Cuelist.

Manual: Fade time is based on the amount of time
you take to move the fader.

Note that this only affects the playing of the first Cue
in an auto-play Cuelist. The timing of all other fader
changes follow the manual movements of the fader.

Release on Override Releases a Cuelist that is completely over-ridden.
(i.e. is not contributing to the console output.)

Auto Move in Black Sets any Cue in this Cuelist to automatically MIB if
Intensity is off in the previous Cue.

Minimum MIB Cue
length

Sets the minimum required time for MIB events. If
the duration of the preceding Cue is less than this
time, the move in black won’t occur.

Auto-run on show load When set to On, this Cuelist will run its first Cue
when the show file is loaded.

Exclude from store The output from this Cuelist will be excluded from
any store operation.
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The Timing Tab
The Timing tab lets you set timing-related options for your Cuelist:

This property… does this…

Release Timing Sets the fade time for when the Cuelist is released.

Playback rate % Playback rate for the Cuelist. Normally 100%.

Timecode Sets up this Cuelist to received Timecode.

Timecode Armed If set to Armed, and Timecode is enabled (see
previous option), this Cuelist will respond to
incoming Timecode. To arm the Cuelist either set
this property to Armed or press the play button on
the Cuelist.

Flash Attack / Dwell /
Decay

Set a user-configurable fade time for the Flash

button action.  A different fade time and fade curve
can be set for:

Attack: How long it takes to fade up

Dwell: How long it should hold before decaying.
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This property… does this…

Decay: How long it take to fade down.

Within the virtual LCD view you will see a blue
countdown for the Attack time, an orange
countdown for the Dwell time, and a green
countdown for the Decay time.

Live time can also be used in place of a custom
fade time.

Default Cue Follow Mode Sets the default follow mode for new Cues added
to this Cuelist.

Chase Tab
This tab lets you set a Cuelist to be a chase sequence and adjust the chase properties.

This property… does this…

Chase Enabled Turns chase mode on or off.

Chase direction Sets the step order for chases: forward, backward,
bounce, or random.

Chase Tracking Turns tracking, within the Cuelist on or off. For a
chase tracking is normally set to Not Tracking.

Chase crossfade % Proportion of time spent fading vs. time spent at
each step of a chase.

Rate (BPM) Playback rate for the Cuelist.

The MIDI Tab
This tab lets you set a Cuelist to be controlled by MIDI notes.
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This property… does this…

Play Sets the MIDI Note that will Play the next Cue in the
Cuelist. Timing is set by the cue properties.

Release Sets the MIDI Note that will Release the Cuelist.
Timing is set in the Timing tab.

Play / Release Sets the MIDI Note that will Play the next Cue in the
Cuelist or Release the Cuelist if it is already playing.

Flash Sets the MIDI Note that will Flash the current Cue in
the Cuelist. Note that Flash will not play a Cuelist
unless it set to Autoplay. Timing is set in the Timing
tab.

To set a MIDI note you can either:

· Click in the Note field and select from the popup list, or

· Click the Learn button to open the MIDI Learn window. You can then play a note on

your MIDI device and the note will be automatically entered.

To clear the Note field, click the [X] icon.

The MIDI port and Channel number may need to be configured before you can use MIDI notes
with your console. To do this, please refer to the MIDI tab in the User Preferences window,
described in Chapter 2.

The Audio Tab
The Audio tab allows you to set an audio file to begin playing when this Cuelist is played.
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This property… does this…

Browse Opens the Select Audio window where you can
choose an audio file.

Clear Removes the audio file from the Cuelist.

Audio files added to the show are automatically copied to the Show Resources folder located
in the Vista storage folder selected during installation. By default, this is the “Vista 3” folder in
the user’s Documents folder.

The Notes Tab
You can add notes about a Cuelist.

These notes will also appear in the Playback window, and therefore can be a convenient way
to add show-time notes about a Cuelist:

Cuelist Property Defaults
At the bottom of the Cuelist Properties window are options that let you affect the default
property values for Cuelists:

This property… does this…

Save as Default Saves the current settings as a default for all new
Cuelists.

Reset to Default Reset all properties to the settings you have saved
as the show default (see above).

Reset to Factory Default Reset all properties to their standard (factory)
settings.
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Updating Presets and Cuelists During Playback

When you make changes in the Programmer Live tab while a Cuelist is being played back,
you can make those changes apply to the presets from which you constructed the Cuelist,
and/or make the changes to the Cuelists from which those fixtures are currently receiving
their attributes themselves.

Update is designed to change settings that are already in a Cuelist and does not

automatically add new events or fixtures to a Cuelist.

To tell Vista to take the changes you’ve made and apply them to the Cues and/or presets
where those fixtures are currently being controlled:

1. While a Cuelist(s) is playing, go to the Live tab in the Programmer window and
select the fixtures you want to change.

2. Make the adjustments you want using the panels or hardware controls.

3. Click the Update icon  from the User Softkey Toolbar, or choose Tools-

>Update.

4. Vista displays the Update window: 

5. Here you can choose whether to apply the changes to Cuelists or Presets if they
are in use. You can also filter the changes by fixtures and features. By default,
Vista selects both Presets and Cuelists.

6. To make the changes to all Fixtures in the Cuelist or Preset, click the All Fixtures
button. To make the changes to just the selected fixtures click Selected Fixtures
button.

7. You can use the feature filter icons to select or de-select the features you want to
include in the preset: Intensity, Position, Color, Gobo, Beam, and Misc. (For more

information about the feature filter bar refer to the Presets section of Chapter 6:
The Fixture Chooser Screen.)

8. To apply the changes to presets, click the checkboxes beside the preset names in
the Presets pane.
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9. To apply the changes to Cuelists, click the checkboxes beside the Cuelist names
in the Cuelists pane to apply the changes to one or more Cuelists rather than to the
presets.

10.When you’ve defined how you want to apply your changes, click the OK button to
return to the Editor screen.

For any new information that you’ve put in the Editor for features that are currently not being
controlled by a Cuelist or Preset, the Destination section of the Update windows tells Vista
what to do with this. You can select Nowhere, which causes Vista to discard the information,
or you can tell vista what Cuelist to insert this new information into.

Exporting Cuelists
Vista enables you to export your Cuelist information as a CSV (Comma Separated Values)
file, which can then be (for example) opened as a spreadsheet. Cue features and optionally
the intensity of any fixture in your rig that is changed in each cue are exported into the
specified file. The CSV file can be opened by any text editor or spreadsheet application that
supports CSV files.

To export your Cuelists, pick File->Export Show Summary. Vista will open the Export Show
Summary window:

Choose the Cuelists and fixtures you want exported and click the Export as CSV button. You
will be prompted for a location and filename under which to store the export data.
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Chapter 10: The Timeline Window

When you select fixtures and apply intensity, position, color, and other features, events are
created which can be viewed in the Timeline window:

This screen consists of three main elements:

· The Editor control section where you can select to work with the Live tab or any

Cuelist you have open. If you have a Cuelist open this section expands to include the
Cue navigation controls.

· The Cue navigation section, where you can see all the Cues in your Cuelist, make

selections, add and delete Cues, and manage how your edits affect output when
you are editing a Cue that’s playing back.

· The Timeline section where you can view and manipulate the fade times for all the

features that are being applied to your fixtures.
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About the Timeline

Vista uses a ”timeline” concept that will be familiar to you if you’ve used any modern sound or
video editing software on a personal computer. When you edit a Cue or store into a Cue, Vista

creates an event for each modified feature of each fixture that you use in the Cue. Each Cue’s
events are laid out in sequence horizontally on the timeline. 

The idea is simple: you create a series of lighting events that occur in sequence when you hit
the Play button. With Vista you can move back and forth through the timing of a Cuelist, just

like you can in an audio or video editing application, and edit any aspect of the events that
occur.

Default Times

At the top of the timing section there’s a timeline ruler that controls the over-all fade times for
all events in a Cue—except the ones you explicitly set elsewhere as will be explained below.
When you first open the Timeline (or Fixture Chooser) screen the ruler will be in its collapsed
form, as shown here:

The Up time determines how long it will take for all feature types to fade from their previous
value to the value in this Cue.

The Down time is only used for Intensity events where fixtures are fading out (i.e. getting
darker or turning off). It determines how long it will take for Intensity to fade from their previous
value to the value in this Cue.

To adjust the Up or Down fade time, click on the end point of the bar and when the cursor
changes to a double arrow drag it horizontally to increase or decrease the time: 

To set a delay time, click on the bar, and when the cursor changes to a hand drag to move the

bar so that it starts after the 0s mark of the Cue:

You can also set the up and down fade time by typing in the Timing box. For example, typing 3/4
sets the Up (or infade) time to 3 seconds and the Down (or outfade) time to 4 seconds:
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Expanded Default Time View and Fade Curves
You can set individual default fade times, delay times, and fade curves for the different feature
types (Intensity, Position, Color, Gobo, Beam, Misc.) in the expanded default time view.

To do this:

1. Click on the expand arrow at the left end of the ruler bar.

2. Vista displays the expanded view:

3. To adjust a feature type fade time, click on the on the end point of the bar and when

the cursor changes to a double arrow drag to increase or decrease the time. Or
type a value in the corresponding Time box.

4. To adjust a feature type delay time, click on the bar and when the cursor changes

to a hand drag to move the bar so that it starts after the 0s mark. Or type a value in
the corresponding Delay box.
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5. To adjust a feature type fade curve, click on the fade icon and select from the drop-

down list:

This icon… does this…

Linear

Sets the curve to a normal linear fade. The feature fades
evenly from the old setting to the new setting over time.

Damp

The fade is slower at the start.

Snap start

The feature goes to the end state immediately.

Snap end

The feature doesn’t change until the very end of the fade
time.

Square law

The feature starts slowly, then slides more quickly up to the
end state.

Inverse square
law

The feature starts quickly and the finishes slowly.

Switch

The feature goes to the end state with no fade at the mid-
point of cue playback.

Hot power

The feature goes to the end state immediately.

Fluorescent

Similar to linear, slower at end of fade.

Sinus

Similar to linear, faster at end of fade.
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Note that If you make any adjustments to the default times for Position, Color, Gobo, Beam, or

Miscellaneous, that feature type will no longer be changed when you adjust the Up fade time in

the condensed timeline ruler.

Saving and Re-applying Timing Configurations
When you’ve set up a set of default fade times that you like, you can save it so you can apply
it to other Cues.

Saving Timing Sets

To save a default timing set:

1. Click on the arrow in the timing drop down box:

2. Click on the Custom Timing option. Vista opens the Custom timing window:

3. Click the New button to create a new custom timing, or select an existing timing
and pick Duplicate to create a new timing based on the selected timing. 

4. Adjust the feature type fade times using the timing bars or by entering values in the
time and delay boxes.

5. To change the label of a timing, double-click on the timing label and enter the new
label desired.

6. Click Close to dismiss the Custom Timing window.

Applying Saved Timing Configurations

To apply a timing set to a Cue:

1. Select the Cue.

2. Select the timing set you want from the Timing drop-down list.
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3. Vista applies the timing set to the Cue. This will not change the timing of any

individual events in the Cue that have already been adjusted in some way.

Modifying the Cue Number, Name, and Duration
To change Cue name, duration, and the Start-of-Cue action of a Cue, in the tiles or layout

view:

1. Select the Cue with the mouse. Shift-click or ctrl-click to extend the selection.
2. Click on number, name or duration field. The field switches to edit mode:

          
3. Enter a new value and press Enter on the keyboard.

Events on the Timeline
The default timing section, located right below the Filter area, lets you set the timing for all the
fixtures in a Cue. However, sometimes you want to make timing changes for individual

fixtures or events in the timeline panel. When you select a fixture in the Editor and set
Intensity, Color, or any other feature, Vista creates a horizontal event bar on the timeline. 

The event bars represent the activities of those fixtures over time. As you can see in this
example, the bars go from the 0s point on the timeline scale to the 2s point. This means that
these fixtures are changing to a new setting over two seconds:

The settings you’ve applied to these fixtures on the panels (e.g. Intensity, Color, etc…) control
the fixtures themselves. The event bars in the timeline simply represent the length of time it
will take those fixtures to get to the desired state, and provides an extraordinarily easy way to
edit the timings compared to most other lighting control systems.

Once the fixtures get to their new state they will stay like that until they receive another
command telling them to do something else (e.g. change to another color or fade out).

By placing the event bars where you want them on the Timeline, you’re giving commands to

those fixtures that tell them how long a feature will take to fade in. The feature is determined
by the panels; the timeline only controls when the fade starts and ends.

Using the Summary Views
You can view the events on the timeline in several ways:
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· Summarized by feature, i.e. intensity, position and color.

· Summarized by fixture type.

· Filtered by feature type (Intensity, Position, Color, etc.…) or fixture type.

· Filtered by fixture selection.

· Filtered by fade path, event type and event timing.

You choose these views from the Filter view drop-down menu at the left-hand end of the ruler

bar. You can also switch between the minimized/maximized setting of each summary view
using the + and – buttons beside the feature or fixture names in the left column.

Summary by Feature
This view shows a set of fixtures grouped by their features:

This is useful if you are primarily wanting to edit a common feature for multiple fixtures, such
as wanting to work with the timing of just the Intensity of your fixtures. 

By default, the view shows each bar minimized. To expand each feature and see the details,
click the ”+” symbol beside the feature name (e.g. Color). Vista displays the details of that
feature:

Summary by Fixtures
The fixture type view shows the same information but sorted by fixture rather than feature:
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This is useful for working on the timing of multiple features, one fixture at a time.

The default fixture view has all the features minimized. To expand each fixture bar and see
the details, click the ”+” symbol beside the fixture you want to see. Vista displays the details of
that feature:

To quickly expand all items, right-click in the left-hand column and select Expand all Default

Items.

Filtering the All Events View
As well as displaying the Feature and Fixture views, you can also choose to filter out different
classes of information on the timeline. To do this, choose an option from the list below the line
in the View drop-down menu:

When you choose a filter, Vista displays only those types of events. You can create your own
filters to show only those combinations of events you want to see. To create a filter:

Choose the Custom View Filters option from the menu. Vista displays the Custom View Filter
window:
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Create a new filter by pressing the New button. 

With this window you can filter by fixtures, event features, and advanced options:

This option… does this…

View Type Fixtures: Shows fixtures in the left column.

Features: Shows feature types in the left column.

Fixtures: All: Filters the timeline to show All fixtures.

Selected Fixtures: Filters the timeline to show only the
fixtures that are selected in the Fixture Chooser
window.

In the Current Cue: Filters the timeline to show only the
fixtures that have programming in the current
Cue.

With New Programming: Filters the timeline to show only
fixtures that have new have been edited since the
Cue was last saved.

Groups Shows just the fixtures that are members of the groups
that are ticked. This filter is applied after the other Fixture
filters.

Event Types Filters the timeline to show only the feature types that
are ticked. Click on the arrowhead beside a feature type
to select just a subset of that feature.

Fade Path Filters the timeline to show only events that are (or are
not) set to a particular fade path (i.e. Linear, Snap, etc).
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This option… does this…

Event type Filters the timeline to show only events that are (or are
not) a particular type (i.e. Preset, Release, Move in
Black, etc).

Event Timing Filters the timeline to show only events that are set to:

· Follow the default times.

· Do not follow the default fade times.

· A Zero fade time.

· A non-zero fade time.

This window can also be used to edit, duplicate, or delete existing custom filters by selecting
a custom filter from the filter list and clicking the Duplicate, Edit, or Delete buttons under the
Filter list.

One-Click Filters
At the bottom of the timeline screen there is a set of filter buttons that provide quick access to
four popular filters.

This icon… does this…

 All
Shows all fixtures in the Cuelist.

 Selected
Shows just the selected fixtures.

 Cue
Shows the fixtures in the current Cue. Useful for removing
“white space” in the timeline.

 New
Shows just the fixtures with new programming.

Zooming In and Out
At the bottom of the timeline screen there is a set of zoom buttons that let you control the size
of the events in the timeline.

This icon… does this…

 Zoom Out
Zoom out to show more of the Cuelist.

 Zoom In
Zooms in to show more detail.

 Cue
Zooms to show a single Cue.

Zooms out to show all Cues in the Cuelist.
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This icon… does this…

 Zoom All

 Current Selection
Zoom to show the selected Cue(s).

 Auto
Toggles auto zoom on or off. This means that
whatever Cue is selected is automatically zoomed to
fit the window.

The Editor Status Bar
Below the Cuelist navigator there’s a status bar that shows details about the Cuelist you are
working on and the Cue(s) that’s being edited and played:

If you are editing a Cue that is not the one that is playing an alert field also shows:

In the status bar the fields show:

· The Cuelist that is open in the Editor. This field will correspond to the selected

Cuelist tab.

· The Cue that is being edited. This field will correspond to the Cue that is selected

(highlighted with a yellow border) in the Cue navigator bar.

· The Cue that is playing and contributing to the console’s output. This alert field only

appears if you are editing a different Cue to the one that is playing. In the cue tiles
view, the current playing cue is also indicated by the tile being shaded green.

The Cuelist and Cue fields to the left of the Q-View button can be used to navigate between
Cuelists and Cues or open a Cuelist. To do this select either field and type a name or
number. As you type Vista will show a list of matching Cuelists or Cue names. Press enter or
tab to open or jump to the selected item.

The buttons on the status bar control how the Editor interacts with the console’s output and
playback:

This button… does this...

Link joins the Editor and any playback (of the Cue being
edited) to the Cue you're editing.
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This button… does this...

This means that when you click on a Cue, in the Editor it
will play. Likewise, if you play a Cue from the Cuelist being

edited, it will change the Cue selection in the Editor.

If you want to edit a Cue without seeing it on stage, Link

should be de-selected (selecting Q-View automatically
turns Link off).

If you turn Link off and select a different Cue a red alert
field appears in the status bar to show you the Cue that is
actually playing.

Allows you to edit a Cue that is not being played. When Q-
View is selected the Fixture Chooser screen is outlined
with a yellow border.

In Q-View selecting a different Cue does not effect
playback and Link will automatically turn off. This means
you can make a change to an upcoming Cue without
changing the look on stage then click Link again to bring
the Editor back in line with the playback.

If Q-View is on, clicking on the Cue tile that is playing will
automatically turn Q-View off.

The Playhead
When you hit Play, the white playhead line starts moving from left to right
across the event bars in the timeline panel. This line shows where you are
currently at in time while the Cue is playing. If you hit Pause, the line stops
wherever it is on the timeline; if you hit Play it starts from the same spot.
Those familiar with audio and video editing tools would also recognize this
line as a “scrub” line, and it behaves similarly.

You can drag the playhead with the mouse to see how a particular section
plays back.

Timeline Events
The Feature Events created when you store to or edit a Cue provide you with extraordinary
control over the timing and playback of these events.
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About the Event Bars
The timeline event bars are labelled and include graphics to identify their function and edit
status.

Feature Summary Event

Feature summary events are colored to indicate their type (Intensity, Position, Color, Gobo,
Beam or Miscellaneous).

The event label shows:

· The number of fixtures to which the event applies.

· The total fade time the events in this group will use.

Feature Detail Event

You can open a feature summary event by clicking on the “+” button, beside the feature name
in the left column.

The event label shows:

· The event setting. In the example above, this position event shows the raw DMX

pan/tilt settings. Some event types include an icon with further information, such as

for the color of a Color event:  , or a preset name and its icon.

· The fade time.

Snap Events

Events that are set to a zero second (0s) fade time are shaped like a banner with an arrow at
the left end:

When you select a snap event there is only one selection handle (the aqua colored square).
When you drag the handle horizontally, you change it to a fade event and add a length to it,
and a second handle will appear at the start of the event.
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Changed Events

Events that you’ve edited, since the Showfile was last saved and the Cuelist changes
committed, show with a hatched pattern:

Adjusting Events
Each event has three attributes: a start point, a duration, and an end point. The event bars on

the timeline show you where each event starts and ends, and how long it will take to reach its
end point:

To adjust the start and end point of an event, select the event(s), position the mouse pointer
over the event such that the cursor turned into a hand icon, and drag it horizontally along the
timeline. 

Note that the grid has an automatic “snap-to” feature that makes it easy to align start and end
points. To make fine adjustments hold [red/Shift] while moving the start and end points.

To change the duration of an event, click on it, select one of the handles (the aqua square that

appears on either end of the event) and drag it horizontally to shorten or lengthen the event.

In this example, the three separate features of the event have different timings:

· The Intensity event starts at 0s and is complete at 2s

· The Position event starts at 0s and is complete by 1s

· The Color event starts at 0s and is complete at 1.5s

· The Beam event starts at 0s and is complete at 1.75s.
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Selection Handles with Groups of Events
A quick and easy way to create dynamic lighting effects is to skew the events on the timeline.
When you select a group of events, Vista displays a selection box around them with aqua
squares on the corners and sides known as “handles”:

You use these handles to change the duration of the selected events. In this example, the
Intensity events of a set of fixtures are selected. By selecting a handle and dragging it you can
change the start or finish point of the selected events. In the example above the fixtures will
fade in over 1s.

In the next example, we’ve selected the middle handle on the lower edge of the selection and
dragged it right to fade the events over 2 seconds, offsetting the start and end fade times
while retaining the 1 second fade time for the individual fixtures:

The corner handles let you skew the start or end times of the selected events while leaving
the opposite end of the events in place. 

Using the selection handles in this way you can transform the attributes of the selected
events with just a few quick clicks. You can also adjust any of the intensity, color, and beam

features at any time while adjusting the timeline events.

Making Precise Timing Adjustments
If you want to set the start and end times and durations of events to a precise point on the
timeline you can either zoom right in and line them up visually, or enter the actual time values.

Using the Set Timing Window

You can set event timing and optionally scale events using the Event Timing window. To do
this you can either:

· Select the event(s) and select Timeline->Set Event Timing, or
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· Double-click on an event, or

· Right-click on the event(s) and select Set Event Timing.

Vista displays this screen:

This option… does this…

Start Select to set the start time of an event.

Middle Select to set the mid-point of an event.

End Select to set the end time of an event.

Time

(Start/Middle/End)

Enter a time to set the start, middle, or end of an event to

that position on the timeline. If you enter a number with no
units, Vista assumes seconds. Use h for hours, m for

minutes (e.g. 1h2m3.5s).

Duration Enter a time to set the duration (or length) of an event(s). If
you enter a number with no units Vista assumes seconds.
Use h for hours, m for minutes, e.g. 1m2s.

Scale Events Select this option if you want all selected events to be
scaled when the duration is increased or decreased.
Scaling is based on the longest event. If this box is not
ticked, all events will be set to the same duration.

Note that if Timecode is enabled for this Cuelist, a slightly different window will appear to set
event timing. Please refer to the Timecode section of the manual in Chapter 11: Learn Cue
Timing for more information.

Aligning Start and End Points

You can also align the start and end times of selected events. To do this, select the events
and then select Timeline->Align Start or Timeline->Align End. You can also right-click on the

selected event(s) and choose these options from the popup menu.
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Resetting Events to Follow the Default Cue Time
When you adjust the time of an individual event it no longer follows the Cue’s default time. To
reset an event so that it follows the default time for that Cue, select the event and choose
Timeline->Reset to Default Timing, or right-click on the selected event(s) and select Reset to

Default Timing.

Setting the Event Fade Curve
Vista uses the linear fade curve by default, but you can choose from a set of pre-defined fade
path shapes to set how an event will progress.

Select Timeline->Fade Curves, or right-click on the event(s) and choose Fade Curves, to

display the fade curve options:

For more information on the available fade curves, refer to the Fade Curves section earlier in

this chapter.

Creating Release Events
Sometimes it’s useful to have a Cue release control of a feature. For example, a Cuelist might

set some lights to point downstage in the first Cue but in the second Cue you want the lights
to revert to whatever position they were instructed to be in by another Cuelist, or otherwise
their home values.

To do this you need to store Release events for the fixtures and features you want the Cue to
relinquish control of. Select the fixtures you want to release, and do one of the following:
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· Pick the Release option from a feature panel popup menu:

· Select an option within the Tools->Release submenu.

Muting Events
If you want to temporarily prevent an event from being played back, you can mute it. To do

this, select the event(s) and choose Timeline->Mute Events->Mute Events. The event bar will

be greyed and when the Cue is played the event will be ignored.

To un-mute an event, select it and choose Timeline->Mute Events->Unmute Events.

Using Commands Within Cuelists

Commands let you control other Cuelists and trigger other Components from within a Cue.
For example, you could have a Cue in Cuelist 1 invoke a play action on Cuelist 5, or release
Cuelist 7. This can make it easier to break up your show into separate Cuelists but control the
show from one primary Cuelist. You might have a scene where there’s a special effects
sequence that takes dozens of follow Cues; instead of cluttering up your main Cuelist with all
those Cues, you could put them in a separate Cuelist, and have your primary Cuelist use a
command to start that effect Cuelist when needed, and in a later Cue issue a command to
release it when you’re done with it.

To insert commands within a Cuelist:
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1. Open a Cuelist in the Editor and choose Tools->Insert Command. Vista opens the
Insert Command window:

2. Select the command to insert from the Action column:

This option… does this…

Play, Back,
Pause, Assert,
Skip Forward, Skip
Backward,
Release

Acts on the target Cuelist as if you had pressed the
corresponding button on the playback controls for that
Cuelist.

Flash Equivalent to pressing the flash button on a Cuelist’s
playback controls. You can choose from “Flash and Hold”,
“Release Flash”, or “Quick Flash”.  The duration of Quick
Flash can be set in the Cuelist Properties under
Attack/Dwell/Decay times.

Inhibit Inhibits (blinds) or un-inhibits the target Cuelist. You must
enter either On or Off in the Feature box.

Release All Releases All active Cuelists. 

Timecode reset Resets the timecode to 00:00:00:00.

Timecode enable Sets a Cuelist to be activated by Timecode. You must
choose either On, Off, or Toggle in the parameter field.

Jump Allows you to Jump to a specific Cue within a Cuelist. The

transition will use the programmed cue time.

Snapshot Activates the snapshot selected in the feature field.

Release all except Releases all active Cuelists except the one containing this
command.
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This option… does this…

MIDI Control
enable

Sets a Cuelist to be activated by MIDI control.

Load
Superplaybacks

Loads the target Cuelist onto all unlocked Superplaybacks

Set Default Cuelist Sets the target Cuelist to be the Default Cuelist.

Jump in live time Allows you to Jump to a specific Cue within a Cuelist. The
transition will use “live time”

3. Select the Cuelist to be triggered from the Target column.
4. Enter an on or off command or Cue number, if applicable, in the Feature field.
5. Click ‘Insert’ to insert the command and close the window.
6. The command will be placed at the beginning of the selected Cue. If you want to

put it at a different position you can drag the event to a different position.

Commands show up at the top of the Timeline window in a Commands grouping and can be
manipulated or deleted just like any other event. Up to 100 commands can be inserted into a
Cue.
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Chapter 11: Learn Cue Timing

You can program a Cuelist, and then use the Learn Timing window to adjust the Cue start
times based on your actions. This can be useful if you want to synchronize Cue start points to
an audio track, video track, or a timecode source.

Using Learn Timing to Adjust Cue Timing
To use Learn Timing:

1. Open the Cuelist you want to use.
2. Select Tools->Learn Timing. Vista opens the Learn Timing window:

3. To keep the existing timing for Cues, check the Preserve Cue Duration checkbox. If
this box is not checked, all Cues (and their events) will be compressed to match
the time between Cue start times. However, Cue times are never lengthened. If the
time between Cues is longer than the existing time, a delay time is added to the
start of the Cue.

Using Learn Timing to Sync to a Repeatable Sequence
You can adjust Cue start times to match the audio in a Cuelist (see Chapter 13 on adding
Audio to a Cue or Cuelist), or while you are listing to or watching something that has
repeatable timing (such as a video, or a band playing to a click track). To do this:
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1. Click the skip to start button ( ) in the Learn Timing window twice to ensure you
are at the start of your first Cue.

2. Click the Start button to initiate the learn timing function.

3. When you are ready, click the Play button ( )  in the Learn Timing window to set

the start time of the first Cue. The start mode of the first Cue will be set to Halt.
4. Continue to press the Play button whenever you want the next Cue to start. You

can also action Play by pressing the spacebar or by pressing the Superplayback
Play button if you have an appropriate control surface.

5. When you are done learning the timing for this Cuelist, press the Stop button, or
press the discard button if you do not want to keep the timings that were learned.

6. When you are finished, close the Learn Timing window.

Vista automatically changes the subsequent Cues’ start action to Follow and adjusts the start
time in relation to the previous Cue. To see how your Cues will playback in relation to the
timeline and each other, click the View Cues in Layout Mode button:

Using Learn Timing to Sync to Timecode Events
Learn Timecode can also be used to set the trigger times for Cues based on Timecode.
When you have a timecode-enabled Cuelist, the Learn Timing window opens with the Enable
Timecode option checked, which activates the Timecode display in the Learn Timecode
window:

To use the Learn Timecode function with timecode-enabled Cuelists, do this:

1. Click the skip to start button ( ) in the Learn Timing window twice to ensure you
are at the start of your first Cue.
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2. Click the Start button to initiate the Learn Timing function.
3. If it’s not already running, start playing the timecode source material in the

system/program that’s generating the timecode for this Cuelist or using the internal
timecode controls if generating the timecode inside of vista.

4. Click the Play button ( )  in the Learn Timing window or the Superplayback Play

button to set the start timecode of the first Cue. The start mode of the Cue will be
set to Timecode.

5. Continue to press the play button whenever you want the next Cue to start. That
Cue’s start mode will be set to Timecode, and the timecode at the time you clicked
the play button will be recorded as the trigger time for that cue.

6. When you are done learning the timing for this Cuelist, press the Stop button, or
press the discard button if you do not want to keep the timings that were learned.

7. When you are finished, close the Learn Timing window.

The Cues for the timeline will now show timecode timing:
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Chapter 12: SmartFX

Vista provides several effect types:

· Wave effects where Intensity or Color or Position or any other feature of your lights

follows a waveform. With this sort of effect you can create Intensity chases, Position
shapes such as a circle, and Color mix effects including rainbows and more.

· Swing effects where Intensity or Color or Position or any other feature of your lights

crossfade between presets or other IPCGBM settings.

· Video effects that use an animated gif to control the Intensity and Color of a group of

fixtures, arranged in a matrix.

Using Effects
To run an effect on your fixtures you can either:

· Apply one of Vista’s built-in template effects.

· Modify a template effect.

· Create your own effects from the beginning, using the SmartFX window.

Applying a Stored Template Effect
To apply an effect:

1. Select the fixtures you want to use.
2. Select the FX Templates option from a Quick Picker panel. Vista displays the list of

available template effects. The FX Template display can be configured to show the
FX Templates as either Icons, Labels, Icons and Label, or Label as Icon (the
default). 

If the Quick Picker is re-configured to show the templates as either “Icon” or “Icon and Label”,
the icon indicates the effect type:
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This icon… indicates this…

 
An Intensity effect.

 
A Position effect.

 
A Color effect.

 
An effect designed to run on a matrix (See Placing
fixtures in a Matrix in Chapter 6: The Fixture Chooser
Window) consisting of many different fixtures or one or
more multi-element fixtures.

Note: If a template effect is greyed out, it means that the template cannot be applied to the

fixture type(s) you have selected.

1. To apply an effect, click on the one you want. The effect you’ve chosen
starts running on the selected fixtures.

2. To adjust the speed and other settings of an effect, open the
SmartFX window and use the controls to adjust it as described
in the following section.

Creating an Effect from the Beginning
To create your own effect:

1. Select the fixtures you want.
2. Click the SmartFX button on the User Softkey Toolbar, or choose Tools->SmartFX

Editor. Vista displays the Smart Effects window.
3. Click the New Effect button at the bottom of the top pane to display the Create

Effect window.
4. Click on one of the effect type buttons. Vista provides several effect types:

a. Wave effects where the setting for Intensity or Color or Position or any other
feature follows a waveform.

b. Swing effects that that move between two or more presets or IPCGBM settings.
c. Video effects that use an animated gif to control the Intensity and Color of a

group of fixtures – usually arranged in a matrix.
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5. Choose the Feature type you want to use in the effect (e.g. intensity, or position, or
color…).

6. Type a name for your effect in the Label box. (This is optional.)
7. Click OK. The new effect will activate and be displayed in the SmartFX window

(described in more detail below).
8. Adjust the controls in the bottom panel of the window to apply the effect features

you want.

Making Your Effect Swing
If you chose the Swing button in the Create effect window, you must define the initial two
steps of the effect (i.e. where it starts and where it finishes). More steps can be added as
desired to have the effect swing from point to point. In a way, this is very similar to creating
the steps of a chase.

In this case, when you click OK, Vista adds two step points in the feature tab of the SmartFX
window.

To set values for the two points:

1. Click the first Stop button.
2. Use either presets or the feature

controls to set a value for the feature
type you are using.

3. Click the second Stop button and define
its settings in the same way.

4. Click the Run Effect button to start the
effect swinging.

Swing effects always have at least two steps, but
you can add additional intermediate steps to build more complex effects. Click on the “+”
button to add another step. Click on the “-“ button to delete a step.

Saving Your Effect
Once you have an effect running it can be stored into cue (or extract) using any of the store
methods. If you feel you may want to have quick access to this effect again in the future,  and
be able to apply it to different fixture types, you may wish to store it as a template.  

To save a template of the effect you’ve created:

1. Click on the Save Template button. Vista displays a window asking for a name and
location for the effect.

2. Type a name for the effect and choose where to save the effect. You can save the
effect in either the User Library or within the show you are working on. If you
choose “Show”, this effect template will only be available within the current showfile

or versions of it. If you choose “User Library” then this effect template will be
available in all showfiles, including new ones.
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3. Click on the OK button. Vista adds your effect to the list of effects. Next time you
browse  the FX Templates from a Quickpicker or a Components tab, your effect
will be available.

Using the SmartFX Tab to Modify an Effect
To adjust the speed and other features of an effect you use the SmartFX window. By default,
the SmartFX window is docked as a tab in the Sidebar. However, it can also be re-docked to
another edge of the Vista window, or completely undocked and made a floating window. The
SmartFX window can be opened and closed by either pressing the FX button in the User
Softkey Toolbar (also by default the F11 key), or by selecting Tools->SmartFX.

The SmartFX tab has two panes: the effects list in the upper half of the SmartFX panel, and
the effect controls below:

The Effects List

The top pane is normally set to Shows All Effects. You
can filter the list by clicking on the drop-down list button
and selecting one of the other options available. See the
below table for explanations on the filtering options and
the other options available in the top pane.

This option… does this…

Source drop-down
selector

The source popup filters the effects list by source:

Show All: includes all effects
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This option… does this…

Default Cuelist: includes just the effects running on the default
Cuelist.

Editor Cuelist: includes effects running in the Live tab and any
Cuelists (tabs) that are open in the Editor.

Editor Cue: includes effects running in the selected Cue in the
Cuelist being edited.

Active only Filters the effects list to only show effects that are being played—
that is, the ones you can see on stage.

Selected Fixtures Filters the effects list to only show effects that are being run on the
selected fixtures.

New Effect Creates a new effect with your own settings.

Stop Effect Stops the selected effect running. 
Vista uses programmed “stop effect” events to achieve this.
For example: you program an intensity FX in Cue 1, in Cue 2 you
press “Stop FX”. Stop FX events will therefore be programmed in
Cue 2.  When you transition from Cue 1 to Cue 2, the effect will
stop. 

Delete Effect Removes the selected effect.  This does not specifically modify the
current Cue you are editing. It will remove the effect from the
original Cue it was started in. Refer to the Delete Effect section
below for more information. 

Save as template Click this button to save the effect as a template that will appear in
the Components list and Quick Pickers.

When you click on an effect in this list, Vista displays the settings and controls for this effect
in the right-hand pane.

Effect Controls
The SmartFX Control Panel contains:

· Rate controls that apply to all feature types in your effect.

· Size controls that apply to all feature types in your effect.

· Feature type tab(s) (IPCGBM) with controls for the effect waveform, size, rate

multiplier, and direction.

· A Sequence tab with controls for fixture overlap, sorting, spread, and ganging.
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· An Advanced tab, where you can add additional effects and synchronize or offset

the effect waveforms. This tab is also used to set how the effect interacts with other
Cues and effects during playback.

Rate and Size Controls
Effects can include one or more feature types (IPCGBG). The main rate and size controls
apply and are common to all features in the effect.

This option… does this…

Tap Effect Rate This large button allows you to tap out a beat to set the

rate of the effects. Four taps are required to set the rate.

Rate (BPM) Sets the base rate at which the effect runs,
expressed in beats-per-minute (BPM).

Rate Effect Master Drop-
down

Select the effect master that controls this effect’s
rate. (See the section on Effect Masters later in this
chapter.)

Per Cycle / Fixture Drop-
down

This control affects whether the Rate is based on
cycles-per-minute or fixtures-per-minute:

Per-cycle: if the effect is an intensity chase at a rate
of 20 BPM, then the whole sequence will repeat 20
times each minute.

Per-fixture: if the effect is at a rate of 80 BPM, then
the effect will cover 80 fixtures each minute. The
entire sequence time of a per-fixture effect varies
with the quantity of fixtures used and is slower with
more fixtures. This means the fixture-to-fixture rate
will be constant no matter how many fixtures are
used.

If you want to “tap sync” an effect to the beat of the
music during a performance, the chances are that
you want to tap per fixture, so make sure you select
the per-fixture option when creating your effect. By
default, all new effects that are created use “per
cycle”.
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This option… does this…

Size (Percentage) This sets the range in which the effect features
change. For example, if the brightness of your
fixtures in an intensity effect are going too dark and
too bright, reduce the size percentage.

Size Effect Master Drop-
down

Select the effect master that controls this effect’s
size. (See the section on Effect Masters later in this
chapter.)

Enabled The enabled checkbox temporarily enables or
disables the effect selected in the list from running.

The Feature Tabs for Wave Effects
Effects can include one or more feature types (IPCGBG). Vista creates a feature tab for each
type with controls for the effect waveform, size, rate multiplier, and direction.

Click on the feature tab (e.g. Intensity) to see the controls:

     

Note that the feature tab(s) will not appear unless the effect is selected in the top pane.

This option… does this…

Size Size affects how much of the effect waveform is
added to the feature. For example, if you run an

Intensity wave effect, set to size 50%, on a set of
fixtures they will modulate between 0 and 50%
intensity. Changing the fixtures basepoint (Starting
level before effect applied) will affect the range that
this percentage runs over.

For effects that run on more than one feature (i.e.,

Position and Color mix), there is a separate size

control for each channel.
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This option… does this…

Rate To maintain synchronization between the features of
an effect you can scale the rate for each feature as a
multiple of the base rate.

To make a feature run slower than the base rate set
the feature rate to lower value (e.g. x½ or x¼ ).To
make a feature run faster than the base rate set the
feature rate to a higher value (e.g. x2 or x4 ).

The rate multiplier can also be helpful in achieving a
desired spread bmp rate across fixtures if for example
per fixture is too slow or per cycle is too quick.

Cycles Allows you to define how many cycles of the effect
you would like to run. For example, a cycle of 2 would
run the effect twice and then stop. 
Note: you will only see the playback of this when
playing back a programmed cue. 

Direction This controls whether fixtures are sequenced in
ascending (forward), descending (backward) or both
directions (bounce).

Base tab Waveform
buttons

This tab shows the available effect waveforms, in
graphical form. To select a waveform click on one of
the buttons.

When multiple waveforms are being used the buttons
show the effect that will be created. For example:

Position: shows buttons for creating shapes including
a Circle, Square, Can-can, Triangle, Figure 8, Spiral,
Bally Hoo and Spread circle.

Color Mix: shows buttons for a Rainbow wave, RGB,
CMY and more.

Base tab Visual editor

Below the waveform buttons, Vista displays a preview
of the waveform(s) in the effect. For position and color
effects this section also provides size controls for
each of the feature waveforms. For example, a

position effect has one waveform operating on Pan
and another on Tilt.

You can change the offset of the waveform(s) by
clicking in the preview window and dragging the
waveform to the left or right, using the horizontal or
vertical sliders.
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This option… does this…

Customize tab

On this tab you can select the waveform type and the
phase offset of the waveform. For position and color
effects that operate on more than one channel there is
also a waveform, rate multiplier and phase offset
control for each channel.

The Feature Tabs for Swing Effects
For Swing effects there are no size controls since only a value of 100% will reach the steps. 

Note: The feature tab(s) will not appear unless an effect is selected in the list pane.

This option… does this…

Stop Clicking on a Stop icon pauses the swing effect so
that you can set a step value for the feature. Swing
effects have at least two steps, each with a stop
button. To set a value, choose a preset or set a value

in the sidebar feature controls.

Beats Sets the number of beats the effect will remain on
each step before transitioning to the next step.

Feature Shows the type of features included in the steps.

Value Shows a value or graphical representation of the
setting for the step.

Curve Sets the fade curve of the step.

Run effect Click the Run Effect button to start the swing effect
running if it has been stopped.

Click the + (Plus) button to add a step.

Click the - (Minus) button to delete the selected step.
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The Feature Tab for Video Effects
For a matrix, you have the additional option of applying a video effect to the matrix. This maps
the pixels in an animated GIF video file to the array of fixtures in the matrix, with the color
values of the pixels controlling the intensity and color of the fixtures. To use this option:

1. Select the Matrix you want to use and click the New Effect button on the SmartFX
panel.

2. Select Video Effect and click OK. A Video Effect tab will be created where you can
specify the features for this effect:

3. Click the Browse button and select the Animated GIF file you want to use for the
effect.

4. In the Source area, use the red marquee to crop into the part of the GIF that you
want applied to your fixture matrix.

5. Adjust the GIF playback rate with the Frame Rate slider.

Note: The Sequence tab is not applicable/available for Video effects.

The Sequence Tab
When you apply an effect to a number of fixtures you can use the controls on the sequence
tab to set how the effect is applied to those fixtures.
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This option… does this…

Overlap Affects how much each fixture overlaps the next
when the effect is running:

At 0% each fixture runs the effect sequentially—
there is no overlap.

At 100% each fixture executes the effect
simultaneously.

This control works in conjunction with Stagger.

See Overlap and Stagger Examples below.

Stagger Vista dynamically calculates a waveform phase
offset value for each fixture depending upon this
control:

0%: There is no phase offset between fixtures.
Each fixture’s feature will change together.

100%: Each fixture has a unique phase offset
ranging from 0 to 360 degrees, spread evenly
across the effect cycle.

Between 0% and 100%: shifts the phase spread
towards the start of the cycle proportionately.

See Overlap and Stagger Examples below for
more information.

Order When an effect runs you can sort the fixtures in a
number of ways:

ID sorts the fixtures by fixture number.

Selection sorts based on the order in which you
selected them.

Random sorts the fixtures in a random order.
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This option… does this…

Position sorts the fixtures by their position on the
Fixture Chooser layout. Fixtures are sorted from
top left to bottom right.

To reverse the sort order, click on the dropdown

box and choose either Ascending or Descending.

Fan Curve Sets the distribution of fixtures along the effect
waveform. The normal setting is Linear and in this
case the fixtures are evenly distributed. Other
curves, such as square and inverse square will
bunch some of the fixtures together and spread
others out.

Spread Shape The spread shape buttons control how the effect
runs across the fixtures. There are three spread
shapes available:

Linear: The effect starts on the first fixture and
runs to the last.

From Ends: The effect starts on the two end
fixtures and runs into the center.

From Center: Pairs, inside to outside—i.e., the
opposite of From Ends.

Multi-element fixture
options

When an effect runs on multi-element fixtures you
can either:

· Group all elements together and treat the

fixture as a single unit, or

· Run the effect across the individual

elements of the fixture.

Fixture Ganging
Blocking

Sets how the set of fixtures are grouped together.
No blocking number, or a blocking of 1, indicates
that the effect runs across the fixtures one at a
time.

Fixtures can be ganged so that two or more
fixtures are doing the same thing. For example:

When set to 2, adjacent pairs of fixtures are
ganged together in the effect.

When set to 2/1/3 for a set of 12 fixtures they’d be
ganged in a pair, then a single, then threes. Refer
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This option… does this…

to Sorting Fixtures in Chapter 6 for more details on
ganging.

Fixture Ganging Repeats Allows non-adjacent fixtures to be ganged
together.

A repeat of 2 sets every third fixture to be doing the
same thing. A repeat of 3 sets every fourth fixture
to be doing the same thing. 

The Preview panel shows how the fixtures will be
ganged together. Refer to Sorting Fixtures in
Chapter 6 for more details on ganging.

Update Selection Click this button to update the effect fixture
selection to match a new order you have set. You
can add or remove fixtures from the effect using
this method.

Preview Selection Click this button to show the fixture selection order
for this effect in the Fixture Chooser screen. Order
numbers appear temporarily in red on the fixture
icons.

Apply Selection Set the current selection to be the same as what
was originally in effect when the FX was created.
When this button is pressed, the sort button on the
User Softkey Toolbar will reflect that the sort from
the effect is in use: 

Overlap and Stagger Examples

Overlap and Stagger determine how the effect flows across the fixture selection for the effect.
By default, both are set to 100%.

Overlap can be thought of as a divider of how much of each beat of the effect each fixture

takes to run a cycle of the effect.
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100% means that the effect
runs on each fixture for 100%
of one beat of the effect. For
a standard sine wave
pattern, this means that at
the start of an effect beat, the
fixture is at its minimum
value. Halfway through the
beat, the fixture is at its
highest value. At the end of
the beat, the fixture is back at
its lowest value. The
illustration at the right shows
four fixtures with an Overlap
of 100% and a stagger of
0%.

If Overlap is set to 50%, each
fixture runs the effect cycle in
one-half of a beat. Therefore,
at the start of a beat, the
fixture is at its lowest value. A
quarter of a beat later, the
fixture is at its highest value.
Another quarter beat later, it
has returned to the lowest
value and stays there until
the start of the next beat. The
illustration to the right shows
four fixtures with an overlap
of 50% and a stagger of 0%.



Chapter 12: SmartFX 203

If Overlap is set to 0% and
we have four fixtures in the
selection for the effect, each
fixture will run the effect cycle
in one-fourth of a beat—i.e.,
one beat divided by the
number of fixtures in the
selection. The illustration to
the right shows four fixtures
with an overlap of 0% and a
stagger of 0%.

Stagger sets a phase delay from one fixture to the next as to when that fixture starts the

effect cycle within a beat, and exactly what it does depends on the number of fixtures taking
part in the effect.

If there are four fixtures
selected when the effect is
applied, then a stagger of
100% means that the first
fixture starts running the
effect cycle at the start of the
beat; the second fixture is
offset in phase one-quarter
of a beat; the third is offset in
phase one-half of a beat; and
the fourth is offset in phase
three-quarters of a beat. For
those of us who are math
nerds, you can think of this
as the sequence 1/n, 2/n,
3/n, 4/n, … (n-1)/n, where n
is the number of fixtures
selected. (Note that this is
also affected by the ganging
settings as well.) The
illustration to the right shows
four fixtures with an overlap
of 0% and a stagger of
100%.
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If stagger is set to 50%, then
each value in the sequence
described above is cut in
half, resulting in all the
fixtures starting the effect
cycle in the first 50% of a
cycle. The illustration to the
right shows four fixtures with
an Overlap of 0% and a
Stagger of 50%.

Combining these two
settings enables you to
create a wide variety of
patterns in your effect. The
example shown below
shows a sine wave effect
with an overlap of 50% and a
stagger of 50%.
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The Advanced Tab

This tab is used to:

· Synchronize or offset the effect waveforms when there is more than one feature in

an effect—for example, an effect that includes both Intensity and Color features.

· Set how the effect interacts with other Cues and effects during playback.

This option… does this…

Offset Adjusting the Offset value moves the waveshape within its own
window—i.e., adjusts the phase of the waveform. For example, a

0% offset for a sine waveform would start and end at the
midpoint while a 25% offset would have the sinusoid start & end
at the high point.

You can adjust the offset of a feature by either dragging in the
waveform window or entering a value between 0 and 360 in the
offset field.

+ (Add) Click the + icon to add a new effect feature that is synchronized
with the other features(s) in this effect.

- (Delete) Click the - icon to delete the selected effect feature.

Basepoint Sets what happens when fixtures that are running an effect
receive a new setting for the same feature type. For example,

what should happen when a circle position effect is running on a
set of fixtures and a Cue runs that sets those fixtures to a
different position?

· If the basepoint is set to Bound, the effect stops running.

· If the basepoint is set to Free, the effect continues to run

but will take its basepoint from the new event.
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· If the Don’t Use Own Basepoint box is ticked, the effect

will only run on a basepoint provided from a different
event than the one that starts the effect. Usually this

would be another Cuelist.

Synchronize effect
with previous effect on
transitions

Sets what happens as this effect starts when another effect that
is using the same features is already running.

· If checked, the effect starts on the same phase as the

already running effect.

· If not checked, the effect does not run from the same

phase—it always starts from the beginning.

Stopping an Effect
There are two ways to stop an effect and have the fixtures revert to their original or default
values for the feature(s) that were running in the effect:

· You can stop all effects that are running, or

· You can stop just a particular effect, or

· You can stop just a particular feature effect type.

Stopping All Effects
To stop all the effects that are running on your fixtures:

1. Select the fixtures that you want to stop the effect running on.
2. Choose the Tools->Stop Effects->Stop All FX.

Stopping a Particular Effect(s)
To stop one or more of the effects that are running on your fixtures:

1. Select the fixtures that you want to stop the effect running on.
2. Switch to the SmartFX window, by default docked in the sidebar. If it’s not open,

click the SmartFX button on the User Softkey Toolbar (usually F11), or select Tools-

>SmartFX.

3. Select the effect you want to stop from the list of effects.
4. Click on the Stop Effect button.

Stopping Effects Running on a Feature
To stop effects that are running on a feature type (i.e. Intensity, Postion, Color, etc…):

1. Select the fixtures on which you want to stop the effect.
2. Click on the Features tab in the sidebar if it’s not already selected.
3. Click on the popup menu icon for the effect type you want to stop – Intensity,

Position, Color, Gobo, Beam, or Misc. (e.g., the Color popup menu button: )
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4. Vista opens a popup menu:

5. Select Stop Effect.

This could also be achieved by selecting Tools->Stop Effects, and then choosing one of the
individual features. These actions can also be assigned to one of the 12 Function Keys.

Deleting a Running Effect
If you decide that you actually don’t want a particular effect that is running at all (I.e., you don’t
want to merely stop it—you want it to never have started in the first place), you can select the
event in the SmartFX window and pick Delete Effect. This will completely remove the selected
effect. This does not specifically alter the current Cue you are editing; if the effect is active in
the Cue you are currently working on, pressing Delete Effect will look like the effect has
stopped but the way it has been achieved is different from Stop Effect. It has not been
“stopped”—it has been “removed”. 

For example: you program an intensity FX in Cue 1, in Cue 2 you press Delete FX. The effect
will look to have stopped in Cue 2 but what has happened is that the effect has been removed
from the original source—which, in this example, is Cue 1.

Effect Masters
For those with a Vista console or who make use of the Virtual Consoles in the Console
window, Vista has Effect Masters for controlling an effect’s Rate or Size. Effect Masters can
be assigned to playback faders and buttons, giving the operator an easy way to adjust the rate
of multiple effects on the fly. 

New Vista shows come with two Effect Masters by default; additional Effect Masters can be
created as needed.

Assigning an Effect Master to an Effect
To assign an Effect Master to control an effect’s Rate or Size:

1. Select the Smart FX tab in the sidebar.

2. Select the running Effect in the Effect list.
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3. In the Effect Master dropdown next to the Rate or Size, click the dropdown arrow to

open the Effect Master list:

4. Pick one of the existing Effect Masters, or select New Master to create a new Effect

Master.

Using an Effect Master
To use an Effect Master, use the Console window to assign an Effect master to a playback
fader or button. Faders can control either Size of Rate; buttons can only control Rate. See the
Console Window chapter for more information on assigning items to faders and buttons.

When an Effect Master is controlling an Effect’s Rate, a playback fader can be used to vary
the rate from 0% to 200% of the programmed rate value. When assigned to a playback
button, the button becomes a tap rate control to set the rate of the Effect.

When an Effect Master is controlling an Effect’s Size, a Playback Fader can be used to adjust
the effect size from 0 to 100% of the programmed size. Don’t forget, though, that an Effect

Masters default fader action is “rate”, so if you do want to control “Size” on a fader you will
need to explicitly set this fader action within the virtual console window.

Tip: The currently set BPM of all Effects Masters can be saved in a snapshot and therefore
recalled to a certain predefined rate at any point in the show by using inserted commands in
your Cues to trigger the snapshots. Refer to the section on Snapshots in Chapter 16: Using
the Console Window.
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Chapter 13: Assigning Audio to a Cuelist

You can assign an audio track to a Cuelist or Cue and play it in Vista. This can be useful if you
want to program for a particular piece of music or dialogue.

To Assign an Audio File to a Cuelist
1. With the Cuelist open in the Editor, select Edit->Cuelist Properties from the Edit

menu, or right-click on the Cuelist icon in a Quick picker and select Properties.

Vista displays the Cuelist properties window:

2. If it’s not already open, click the Audio tab.

3. Click the browse button and navigate to the folder containing the desired audio file,
select an audio file, and click the Open button. Vista copies the audio file to the
Audio folder inside your Vista Show Resources folder.

4. Click OK to close the Cuelist properties window.
5. When you play this Cuelist Vista plays the selected audio track.

To Assign an Audio File to a Specific Cue
You can also assign audio to a single Cue in Vista. This can be useful to play sound effects or
short pieces of audio. To do this:

1. With the Cuelist open in the Editor, select the Cue then select Edit->Cue Properties,

or right-click on the Cue tile and select Cue Properties.

2. If it's not already open, twirl down the Audio section.

3. Click the browse button and navigate to the folder containing the desired audio file,

select an audio file, and click the Open button. Vista copies the audio file to the
Audio folder inside your Vista Show Resources folder.

4. Click OK to close the Cue properties window.
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Alternative Method for Assigning Audio

Alternatively, with the Cuelist you want to assign an audio file open in a Edit tab, Right-click on
a Cue and pick Select Audio from the popup menu. The Select Audio dialog will open:

From here, you can assign an audio file to the entire Cuelist (similar to doing so by editing a
Cuelist’s properties), or to the specific Cue you right-clicked on (similar to editing a Cue’s
properties). If an audio file is already selected, you can click the Clear button to remove it from
the Cue or Cuelist. Or, you can Browse to select an audio file to assign.

Click OK to complete the action chosen.
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Chapter 14: Automating Playback

Vista provides multiple ways to automate playback of Cuelists. One way is through timecode,
where Vista monitors an incoming or internally generated timecode signal and triggers cues
when the programmed timecode is reached. Another is to trigger a Cue based on a date &
time event—for example, when sunset occurs each weekday evening.

Using Timecode to Control Cuelists
You can use Linear Time Code (LTC) or MIDI Time Code (MTC) to trigger Cues. LTC is
available on some Vista consoles via audio inputs, and via USB or network MIDI devices.
Refer to the MIDI Input part of user preferences in Chapter 2: Getting Started for information
on setting Vista up with MIDI devices.

If you are going to be running Vista in conjunction with a device that generates LTC (aka
SMTPE) or MIDI timecode, you can also simulate the timecode so you can get your show
running without needing the actual timecode from the other device.

To set up Vista to receive timecode:

1. Select File->Timecode. Vista displays the timecode properties window:

2. Set the Timecode source. The options are Disabled, Linear Time Code (LTC), MIDI
Time Code (MTC) or Vista’s Internal clock

3. Set the Frame rate from the dropdown menu to match the incoming timecode
source.

4. Set the Timecode Offset if required. The offset time is added to the incoming
timecode. For example, if the offset is 01:00:00:00 (1hr) and the incoming timecode

is 00:00:10:00 (10 secs) Vista will treat it as though 01:00:10:00 (1hr 10secs) is
received.

5. The Playback Lag compensation field is used to compensate for slow data
transmission. If your Cues are not running at the expected time you may need to
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enter a value in this field. For example, entering 0.5s will mean that all your Cues

run half a second earlier than programmed.
6. The Freewheeling time field is used to cope with dropouts or errors in the timecode

coming from an external device. This field sets the number of seconds Vista will
allow to pass while it simulates timecode and until it relinquishes control.

7. Click OK to accept the new settings.

Vista has a dockable Timecode window you can enable by selecting View->Add Dockable

Window->Timecode. When Timecode is set to an external source, the Timecode window
displays the incoming timecode (left image below). When Timecode is set to be generated
internally by Vista as a programming aid, the Timecode window displays the Timecode being
generated and adds controls for controlling the internal timecode generator.

The controls in the Timecode window are:

 

This button… does this…

Arm all Cuelists Sets all timecode-enabled Cuelists to the Armed
state, which will cause them to respond to
timecode.

Settings Opens the Timecode Properties window (see the
previous section).

Controls the internal timecode playback. Rewind,
Play, Pause, and Fast-Forward buttons. With

Rewind and Play, additional presses will cause
the rate of playback to increase.

Moves the timecode to the time shown on the
button. To change the setting, right-click on the
button and enter a new time in the popup
window.

Opens the Locate to Time window where you
can enter a time in Hours Minutes, Seconds &
Frames.
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Tip: To disable timecode for all Cues, choose the Disable option from the Timecode source
drop down in the Timecode Properties window. This can be useful is you want temporarily to
stop timecode from triggering your Cuelists.

Adjusting the Timecode on Multiple Cues
You can adjust the timecode settings for an entire Cuelist by either setting an explicit
timecode to start, or an amount of time to move all the Cues by. To do this either:

· Select Tools->Set Cuelist Timecode, or

· Right-click on a Cuelist in the playback window and choose Set Timecode Start.

Vista opens the Cuelist Start Timecode window:

This field… does this…

New Start Time Sets the timecode start time for the Cuelist.

Move Cuelist by Adjusts the timecode for each Cue in the selected
Cuelist by the time entered. Negative values cannot
be used.

See Chapter 11: Learn Cue Timing on how you can use the Learn Timing function to
accurately stamp timecode values to individual Cues. 

TIP: If you have multiple Cuelists set to timecode, it is often not desirable to have them all
armed at the same time. An example of this would be where a band is playing to timecode,
with a Cuelist for each song. It would be recommended that you only arm the Cuelists as you
need them, and disarmed them when you do not. If you don’t do this, you may find some
Cuelists jumping to the end if the band decide to play the set out of order (using a later
timecode value). The best way to achieve this is through inserted commands and the
timecode enable action. Please see Chapter 10: The Timeline Window for more information
on inserted commands.



Vista User's Guide, Version 3.3214

Using Date and Time to Control Cuelists

You can set Vista to automatically play Cuelists, trigger snapshots and more based on the
date and time.

Managing Date and Time Events
You can add, delete, edit, duplicate or test date and time events. To do this select Tools->Date

and Time Events. Vista opens the Date and Time Events window:

This window displays a list of all your Date and Time events.

This option… does this…

New Opens a Date and Time Event window where you
can set up an event to be triggered based on the
date and time.

Delete Deletes the selected event.

Edit Opens the selected event so that you can modify its
settings.

Duplicate Duplicates the selected event.

Test Now Click this button to test the event, no matter what the
current time is.

Global Enable You can disable all date and time events by un-
checking this box.

Close Closes the window.

Creating a New Date & Time Event
Date / Time events can automatically control playback and other actions. To create a new
event:
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1. Choose the New Event option from the Date/Time Events window. Vista opens the
New Event window:

2. Select the command to insert from the Action column:

This option… does this…

Play, Back, Pause,
Assert, Skip Forward,
Skip Backward,
Release,

Acts on the Cuelist as if you had pressed the
corresponding button on the playback controls for that
clip. Select the Cuelist from the Target column.

Flash Equivalent to pressing the flash button on a Cuelist’s
playback controls. You can choose from “Flash and
Hold”, “Release Flash”, or “Quick Flash”. The duration
of Quick Flash can be set in the Cuelist Properties
under Attack/Dwell/Decay times.

Inhibit Inhibits (blinds) or un-inhibits the clip. You must also
enter either On, Off, or Toggle in the Inhibit enabled box
to set the flash button action.

Release all Releases all active Cuelists. No other options are
available when this command is selected.

Timecode reset Resets the timecode to 00:00:00:00.
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This option… does this…

Timecode enable Sets a Cuelist to be activated by Timecode. You must
also enter either On, Off, or Toggle in the Timecode
Enabled box to set the Timecode Enable action.

Jump Allows you to Jump to a specific Cue within a Cuelist.
You can select a Cue from the popup menu in the Cue
field.

Snapshot Triggers the snapshot selected in the Target box.

Release all except Releases all Cuelists except the one you select from
the Target column.

MIDI Control enable Enables or Disables MIDI show control and MIDI notes.
You must also enter either On, Off, or Toggle in the
MIDI Control Enabled box to set the MIDI Control Enable
action.

Load Superplaybacks Loads the target Cuelist onto all unlocked
Superplaybacks.

Select Acts on the target Cuelist as if you had pressed the
select button.

Jump in live time Allows you to Jump to a specific Cue within a Cuelist.
The transition will use the Live Time setting.

3. Select the Cuelist or component to be triggered from the target column.
4. Enter an on or off command, rate setting, or Cue number (if applicable) in the

option field.
5. Type a label for the Event in Name box.
6. Select the type of event to create. Options are Time of Day, Sunrise, and Sunset.
7. For Time of Day events, set the time of day, to trigger the event, in the Time box.

The time is displayed as a 24-hour clock. For Sunset and Sunrise events, you have
the option of offsetting the calculated Sunrise and Sunset time by plus or minus a
number of minutes.

8. If you want an event to repeat periodically, check the Repeat box and specify the
number of times to repeat and the Interval (in minutes), between repetitions.

9. Select the days of the week you want the event to run on by ticking the check
boxes.

10.If you want an event to only be activated after a certain date tick the Start Date box
and specify the date when the event should first be triggered.

11.If you want an event to stop running after a certain date tick the End Date box and
specify the date when the event should last be triggered.

12.Tick the Enabled checkbox to activate the event. If this box is not ticked the event
will not run.

13.If you want to test the execution of the event, click the Test Now button.
14.Click the OK button to save the event.
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Tip: if you are using sunrise and sunset triggers you will need to set your geographical
location via the General tab of the User Preferences window (File->User Preferences).
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Chapter 15: The Playback Control Window

When you’ve got a full show going it’s likely that you’ll have multiple Cuelists on the console
and being played back.

To see what’s going on at any time, click the Playback Control button ( ) on the User
Softkey Toolbar. Vista displays the Playback Control window:

This screen lists all the Cuelists in your show and gives you a handy point from which to
control and edit them. The window is made up of two panes that can be resized by clicking on
the vertical dividing line and dragging the divider to the left or right.

Cuelist Pane
The left side of the screen displays a list of all Cuelists and can display up to thirteen columns
that show playback status and some Cuelist properties.

This column… indicates…

ID The Cuelist ID number.

Label The name of the Cuelist.
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This column… indicates…

Current Cue Shows the current Cue name and number. Cuelists that
have not been run show the first Cue name.

Active Shows if the Cuelist is playing (Active).

Priority Shows the priority of the Cuelist and allows you to change
the priority. Options are Low, Normal (default), High, and
Programmer.

Programming Shows the features (Intensity, Position, Color, Gobo, Beam,
Misc) programmed in this Cuelist.

HTP Shows the HTP Intensity property setting, and allows you to
change it.

Timecode For timecode-enabled Cuelists with timecode events
programmed, shows the Timecode setting for this Cuelist,
and allows you to change it. Options are Disabled, Enabled,
and Locked.

Timecode Arm Shows the Timecode Arm status of the Cuelist, and allows
you to change it. Options are nothing and Armed.

Release Time Shows the Cuelist’s release time and allows you to change
it. Options are to bring up the Custom Timing dialog, 0, 2,
and 5 seconds, or the user can directly enter a time value.

Inhibited Shows if a Cuelist has been inhibited (made blind) and
allows you to change it. Options are nothing, and Inhibited.

Notes This column is for notes and comments. To add a note,

double-click on the notes cell.

You can change the setting of a cell by double-clicking on the cell and either selecting from a

list of options or entering a new value. You can also right-click on the cell to open an editing
window for that cell. Not all cells are editable.

You can sort the Cuelist list by clicking on any of the column headings. Click the column
heading again to reverse the sort order.

You can change the order of the columns by clicking and holding on one of the column
headings and dragging to the left or right. 

You can resize columns by clicking between the headings and dragging the column to suit. 

To show or hide columns, right-click one of the column headers and select/deselect the

desired header from the pop up menu.

Cue Panel
The right panel shows the Cues in the Cuelist selected in the left column and is divided into
eleven columns that show Cue detail and progress:
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This column… indicates…

ID Shows the Cue number.

Label Shows the Cue name.

Programming Shows the features types programmed in this Cue.

Click this button to play the Cue.

Progress Provides a visual display of the Cue’s progress and
Shows the progress of the Cue as a percentage.

Click this button to skip to the end of the Cue.

Total Time While playing shows the elapsed time and time
remaining. E.G., “1.0s [4.0s]” means elapsed time is 1

second, and the time remaining is 4 seconds.

When not playing, this cell shows the total fade time.
Total Time is editable by double-clicking.

Up Displays the up-fade time for this cue and allows you
to edit it.

Down Displays the Down-fade time for this cue and allows
you to edit it.

Position Displays the position time for this cue and allows you
to edit it.

Color Displays the color time for this cue and allows you to
edit it.

Gobo Displays the gobo time for this cue and allows you to
edit it.

Beam Displays the beam time for this cue and allows you to
edit it.

Misc Displays the misc time for this cue and allows you to
edit it.

Follow Mode Shows how the Cue starts.

: The cue starts when the operator presses the Go
button.

: The Cue starts ”n” seconds after the start of the
previous Cue.

: the Cuelist starts “n” seconds after the end of the
previous Cue.

: the cue will play when the specified timecode is
reached.

Notes This column is for notes and comments. To add a
note, double click on the notes cell.

The font color of each row will change to indicate the current cue, the cue after the current
cue, the previously played Cues, and the unplayed Cues. These colors are themeable.
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Playback Window Toolbars

There are several toolbars available for controlling your Cuelists as well as setting viewing
options for the Cuelists and Cues. To enable these toolbars, use View->Toolbars. The
toolbars available for the Playback window include Playback Controls, Cuelist View Options,
Cue View Options, and Chase Controls.

Playback Controls

The Playback Controls toolbar provides access to buttons for playing and skipping to different
Cues within the selected Cuelist. If not already visible, select View->Toolbars->Playback

Controls while in the Playback window.

This option… does this…

Skip to Start

If not at the first Cue, pressing this button jumps you to
the first Cue using the Live timing settings. If already at
the first Cue, pressing this button releases this Cuelist
using the Live timing settings.

Skip Back

If not at the first Cue, pressing this button jumps you to
the previous Cue using the Live Timing. If at the first
Cue, pressing this button releases this Cuelist using the
Live Timing.

Pause

Pauses the playback of a transitioning Cue. If pressed a
second time, the current Cue returns to the previous
Cue using the timing of that Cue. 

If a Cue has completed its transition and the Pause
button is pressed, the Cuelist will play backwards using
the Cue’s time. 

Play

Plays the next Cue in the Cuelist or resumes playback of
a paused Cue.

Skip Forward

Jumps to the next Cue using the Live Time settings.

Skip to End

Jumps to the last Cue in the Cuelist using the Live Time
settings.

Release

Releases the selected Cue list using the Cuelist’s
release timing.

Cuelist View Options
The Cuelist View Options toolbar lets you set options that help control what information is
shown to you in the Playback window.
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This option… does this…

Active Cuelists only Displays only the Cuelists that are currently active. This
can help reduce clutter in a large show.

Follow on go When a Cue is played in a Cuelist, the view will change
to display that Cuelist.

Follow on select When a Cuelist is selected, the view will change to
display that Cuelist.

Search Cuelists Brings up a search bar where you can search for a
Cuelist by name. The list of Cuelists will dynamically
change as you type to show those Cuelists whose
names contain the text that is entered. The search is
case-insensitive and matches any text within the Cuelist
name (not merely from the start of the name).

Cue View Options
The Cue View Options toolbar lets you set options pertaining to the list of Cues displayed for
the selected Cuelist.

This option… does this…

Auto Scroll For a long Cuelist, this causes the currently playing
Cue to be centered in the list of Cues when it’s not
towards the beginning or end of the Cuelist.

Draggable Playhead If the “Draggable Playhead” option is enabled, you can
control a Cuelist’s playback by clicking on the overall
progress bar at the top of the windows. You can also
set this option on or off from the View menu.

Click or drag anywhere in the bar to jump to that point.

Search Cues Brings up a search bar where you can search for a
Cue by name. The list of Cues will dynamically change
as you type to show those Cues whose names contain
the text that is entered. The search is case-insensitive
and matches any text within the Cuelist name (not
merely from the start of the name).

Chase Controls
The Chase Controls toolbar lets you adjust the behavior of a chase Cuelist when one is
selected.
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This option… does this…

Playback Rate For Cuelists set to not be a chase, this allows you to
increase or decrease the playback rate of the Cuelist
by the specified percentage. An entry of 50%, for
example, means that a Cue that might normally run in
2 seconds will take 4 seconds to run. This control is
only enabled if the Chase checkbox is unchecked.

Chase Turns on or off Chase mode for the selected Cuelist. 

Direction Sets the direction for a Chase Cuelist. The options are
Forward, Backward, Random, and Bounce. (See
information about the Chase Tab in Chapter 9: Working
with Cuelists for more information on chases.) This is
only enabled if the Chase checkbox is checked.

Rate (BPM) Allows you to adjust the playback rate of the Cuelist
when in Chase mode. This is only enabled if the Chase
checkbox is checked.

Editing in the Playback Control Window
There are two ways you change the editable fields from within the Cuelist and Cue panels in
the Playback control window. You can:

· Double-click on an editable field and edit the field directly.

· Right-click on the editable field and select Edit.

To Edit a Field Directly
1. Double-click on the field.
2. Choose from the list of options or enter a new name, time etc.
3. Press the Enter key or click away from the field.

To use the Edit Field Window
1. Select one or more like cells in the Cuelist or Cue panels. For example, you can

Cuesadjust the follow time for multiple Cues at once by using the shift or control
key.

2. Right-click in the selected field that you want to change and select the edit option.
Vista opens the Edit Field window.

3. Enter a value for the field(s).

4. Click the OK button.
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Chapter 16: Using the Console Window

The Console Window’s primary purpose is to provide a mechanism to configure your Vista
consoles. However, it can also simulate a console and let you control your lighting rig through
virtual consoles. Some consoles like the MV only provide playback controls; others like the EX
provide playback controls, a Superplayback section, and programming controls as well. For
the purpose of this chapter, we will focus on the EX console as the example. To fully
understand the capabilities of the specific console you have purchased, please refer to the
documentation for that product.

Console Window and Consoles
In a new Showfile, when you first select the Console Window, and you have a Vista console
connected, a virtual console for that console will automatically appear and be linked to that
console. If no console is present, Vista will display an EX console. By using Console->Add

Console, you can add other virtual consoles to work with. These additional consoles show up
as tabs along the bottom of the Control window.

If you actually have that console connected to your system, the console displayed in the
Console Window will reflect the state of the controls on that console (for example, fader
positions).

Like most Vista windows, the Virtual Consoles can be undocked and turned into a floating
window which you can position anywhere on your system’s displays. The Window Menu in
the upper-left corner of the Virtual Console windows lets you work with the window’s dock
settings:

For the purposes of describing the operations that can be performed in the Console window,
we will assume an EX console is connected to your system.
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The EX Console

As we are using the EX console as our example, we’ll briefly describe its components:

The EX console features:

· Grand Master fader

· Four playback modules. Each playback module consists of up to 15 playbacks per

page and can be paged up and down individually. The top two modules are
faderless. By default, each module is configured as five playbacks with three
buttons (and a fader) associated with each playback.

· One Superplayback section which consists of:

o Master Cuelist controls

o Eight encoders

o Twelve programming keys

· Twelve user function keys

· Four modifier keys

Grand Master

The Grand Master fader control scales the intensity of all output from Vista system.
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Function Keys

The function buttons are equivalent to the F1 through F12 keys on a standard computer
keyboard and provide quick access to the User Softkey Toolbar buttons. 

The Modifier Keys

The colored (Red, Yellow, Green, Blue) modifier buttons provide alternate functions when you
press a button on the console while programming and during playback.

You can also use keyboard equivalents in place of the modifiers:

· Shift is equivalent to the Red button.

· Control (Command on Macs) is equivalent to the Yellow button.

· Alt (Option on Macs) is the equivalent of the Green button.

· Control + Alt (Control on Macs) is the equivalent of the Blue button.

Virtual Console Display

In leu of digital readouts on the EX and MV consoles, Vista provides a Virtual Console Display
that you can bring up that displays the state of the playback and Programmer controls. It’s
designed such that if you align your physical console directly underneath one of your
computer monitors, you can position the Virtual Console Display to line up with the hardware
controls on the console, providing easy to associate feedback on the state of the controls and
the Cuelists assigned to them. This way of providing feedback enables more informative
graphics to reflect the state of the control than offered by the typical LCD hardware readout.

To activate the Virtual Console Display for a console:

1. Click on the Virtual Console menu in the upper left corner of the Virtual Console
window:

2. Select Virtual console display in the menu.
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3. Position the Virtual Console Display on your monitor(s) such that it aligns well with
your physical console:

The Superplayback/IPCG Controls
These controls are used during programming and playback and have different operating
modes to support each of these. To switch operating modes: 

1. Press the Menu button in this section of the console (or virtual console):

2. Then select from the three options:

· IPCG: stands for Intensity, Position, Color, Gobo, and Beam. In this mode the

buttons and encoder wheels can be used to set Intensity levels, Pan and Tilt,
color, and all the other features of your fixtures.

· Play: puts the controls into playback mode. In this mode the controls and buttons

provide quick access to the regular and advanced Cuelist playback options.

· SFX: stands for Smart Effects. This mode lets you use the buttons and encoders

control the most frequently used effects settings.

IPCG Mode
When you select fixtures, the hardware controls can be used instead of the on-screen

controls to adjust setting for Intensity, Position, Color, Gobo, and Miscellaneous features. If the

controls are not already in IPCG, follow the instructions in the previous section to put them
into IPCG. The Virtual Console Display will update to reflect the operations available in this
mode:
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This button… does this…

I/Pos Press this button to put the encoders and lower six buttons
in Intensity & Position mode. Pressing it again cycles the
controls through any available features or alternate modes
(angular position, and strobe & shutter).

Color Press this button to put the encoders and lower six buttons
in Color mode (HSV). Pressing it again cycles the controls
through any available features or alternate modes (CMY,
RGB, Color Wheel)

Gobo Press this button to put the encoders and lower six buttons
in Gobo mode. Pressing it again cycles the controls through
any available features or alternate wheels or modes.

Beam Press this button to put the encoders and lower six buttons
in Beam mode. Pressing it again cycles the controls through
any available features or alternate modes.

Custom Press this button to put the encoders and lower six buttons
in custom feature mode. For more information on creating
custom encoder pages see Creating Custom Encoder
Pages later in this chapter.

Menu Opens the Superplayback top level menu screen. Double
tap the menu button to switch between Playback and
Programming mode.

Home/
Full

There are three pairs of Home/Full buttons in IPCG Mode,
one pair for each of the encoder wheels. The Home button
sets the feature for the associated wheel to its default or
home value; the Full button sets that feature to its Full
value. 

You can press both together to achieve 50%.

>> For Gobo (or Color) wheel features this button toggles
between the fixture’s wheels – i.e. Gobo wheel 1, Gobo
wheel 2, etc…; or when associated with gobo or color
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This button… does this…

selection, rotates the gobo or color wheel to the next
position.

Mode For Gobo wheels that have rotating gobos this button
toggles the rotation encoder between Index and Spin mode.

Encoders Rotate to set the associated feature to the desired value.

Left arrow

Selects the previous fixture.

 

Right arrow

Selects the next fixture.

Fine Modes

Hold down [Red/Shift] to put the encoders into fine mode.

Hold down [green/Alt/Option] to put the encoders into super-fine mode.

Fixture Selection Buttons

The left and right arrow buttons located just above the encoder wheels can be used to select
the previous or next fixture in a selection. If there are no fixtures selected, pressing the buttons

will cycle through all the patched fixtures. After using the next and previous buttons you can
reselect your entire last selection by pressing both buttons together.

Programmer Live Time

Below the three main encoders there is a pair of faders. The right-hand fader can be used to
adjust the Live time. At the top (100%) position the Intensity, Position, Color and other feature
settings fade in over the Live Time set in the Programmer window. At the bottom (0%)

position the feature settings fade in over 0 seconds—i.e., they snap to the new value.

Superplayback  Section
In playback mode the Super Playback section controls and buttons automatically link to the

Default Cuelist. This means that when you press the Select ( ) button on any Cuelist
playback you can control that Cuelist with the faders, buttons and encoders in this section. If
the controls are not already in Play mode, follow the instructions earlier in this chapter to
change to the Play mode.

You can specifically assign a Cuelist to the Superplayback section by pressing the “Load”
softkey on the console and them pressing a playback control button. It’s also possible to drag
& drop a Cuelist directly onto the Superplayback Control in the Virtual Console window to
assign it to the Superplayback. Selecting a new Cuelist, however, will override this
assignment as the Superplayback section will follow the Default Cuelist.
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To prevent Vista from changing which Cuelist is assigned to the Superplayback section when
the Default Cuelist is changed, press the “Lock” softkey on the console to prevent the
Superplayback section from following the Default Cuelist.

Play Controls

The faders and buttons below the encoders provide quick access to all the Cuelist play
function. When in IPCG mode, the Cuelist transport controls will control the Default Cuelist if
in the “live tab”, and control the Editor Cuelist if working in an open Editor tab.

This button… does this…

If not at the first Cue, pressing this button jumps you to the
first Cue using the Live timing. If already at the first Cue,
pressing this button releases this Cuelist using the Live
Timing settings.

Jumps to the last Cue in the Cuelist in zero time.

If not at the first Cue, pressing this button jumps you to the
previous Cue using the Live timing settings. If at the first
Cue, pressing this button releases this Cuelist using the
Live timing settings.

Jumps to the next Cue using the Live timing.

Pauses the playback of a transitioning Cue. If pressed a
second time, playback returns to the previous Cue using the
timing of that Cue.

If a Cue has completed its transition and the Pause button is
pressed, the Cuelist will play backwards using cue time.

 

Plays the next Cue in the Cuelist or resumes playback of a
paused Cue.

Left
Fader

Controls the output intensity of the selected Cuelist.

Right
Fader

Performs a manual crossfade into the next cue of the
selected Cuelist.

Note that most buttons and faders on a Vista console can be configured to perform a different
function. Refer to Assigning a Component to Playback Controls later in this chapter.
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Superplayback Mode Extended Controls

The top row of buttons let you select from the playback control pages:

This button… does this…

Control Selects the normal Cuelist play mode controls.

Chase Selects the Cuelist Chase controls.

SmartFX Selects the Cuelist SmartFX controls.

Load

/ Clear

Press Load then any key on a normal playback to load that Cuelist
into the Superplayback.

Press [yellow/Ctrl/Command] + Load to Clear the Superplayback.

Lock Locks the current Cuelist onto the Superplayback. When lock is
selected pressing Select (*) on another playback will not change the
Superplayback Cuelist. You can still Load another Cuelist, however.

Menu Opens the Superplayback top level menu screen. Double tap the
menu button to switch between Playback and IPCG mode.

Cuelist Control Mode

In the Cuelist Control mode you can control the playback rate and select from several play
options using the bottom row of buttons:

This button… does this…

Rate Enables the left encoder for rate control of the playback. Turn
the encoder to the left to slow the playback rate and to the
right to speed it up.

100% Resets the playback rate to normal. At 100% the Cuelist plays
back using the fade times set in the Cues.
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This button… does this…

Jump Opens the Cuelist jump window on the main screen. Used to
jump from one Cue to another Cue out of sequence. Select
the Cue you want to jump to in the Jump window (see Using
the Jump Window later in this chapter). 

Press the Play key to fade to that Cue.

Shuttle Enables the middle encoder for manual control of playback.
Move the encoder clockwise to advance and
counterclockwise to go backwards. Shuttle moves through
the entire Cuelist.

Release Releases the Cuelist. Fixtures return to the values from other
Cuelists or to their defaults.

Select Selects the Cuelist as the Default Cuelist.

Cuelist Chase Mode

In the Cuelist Chase mode you can start a Cuelist chasing, change the chase rate and select
the chase direction:

This button… does this…

Rate Enables the left encoder for rate control of playback. Turn the
encoder to the left to slow the playback rate and to the right to
speed it up.

Sync Synchronizes the chase BPM to the tapped rate. Four beat

taps are required to learn the BPM.

Forward Turns the chase mode on and runs it forwards. If the Cuelist
is already chasing forward pressing the button will turn chase
mode off.

Reverse Turns the chase mode on and runs it backwards. If the
Cuelist is already chasing backward, pressing the button will

turn chase mode off.

Bounce Turns the chase mode on in bounce mode (i.e. run from first
to last Cue then back to first Cue, repeatedly). If the Cuelist is
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This button… does this…

already bouncing pressing the button will turn chase mode
off.

Random Turns the chase mode on and runs in a random order. If the
Cuelist is already running in random pressing the button will
turn chase mode off.

SmartFx (Effects) Mode

In the Cuelist SmartFX mode you can control the size, rate and phase of effects that are
running on the console:

This button… does this…

Enabled Enables control from the encoders. To avoid accidentally
changing FX settings, turn the encoders off.

Reset (over Size
encoder)

Resets the effect’s Size to its programmed settings.

Reset (over Rate
encoder)

Resets the effect’s Rate to its programmed settings.

All /Cuelist /
Selected.

(press to toggle)

All: Selects all running effects for adjustment. Note that if more
than one effect is running, the size and rate encoders will
affect all the running effects proportionately.

Cuelist: selects the effects in the selected Cuelist
for adjustment. Note that if more than one effect is
running in the current cue, the size and rate
encoders will affect all the running effects
proportionately.

Selected: The effect selected in the SmartFX panel will be
affected.

Forward /
Backward

Changes the direction of the selected effect(s).
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This button… does this…

/ Bounce

(press to
toggle)

Sync Provides the same functionality as the Tap button in the
SmartFX panel, allowing you to tap out a beat to set the rate of the

effects. Four taps are required to set the rate.

Using the Jump Window
During playback you can use the jump window to quickly select a Cue, out of the normal
sequence, and fade it in.

To open the Jump window:

1. Press a Select button on any playback to bring that Cuelist onto the Play mode of
an unlocked Superplayback. (If you are in IPCG mode you can hold the Select
button and the Superplayback will temporarily change to Play mode while held).

2. Press the Jump button in the Superplayback. 

3. Vista displays the Jump to Cue window: 
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This option… does this…

Cuelist Selects the Cuelist to jump to. This field is automatically set
to the Cuelist on the Superplayback.

Cue Selects the Cue to jump to. To search for the Cue you want
to jump to, type the Cue number or a part of the Cue name in

the search box, or select the Cue from the list.

You can also use the EX encoders to select a cue.

Cue Timing Crossfades using the target Cue’s fade time.

Live Timing Crossfades using the Live time.

Arm & Close Closes the Jump window with the selected Cue ready to play.
Press the Play button to complete the jump.

To complete the Jump and fade in the selected Cue, without using the Arm and Close option:

· Press the keyboard Enter key, or

· Use the Cuelist’s Go button, or

· Click the OK button, or

· Press the Jump button in the Superplayback a second time.

Other ways to open the jump window are:

· Press Jump on a dedicated playback key (see assigning playback buttons).

· Use the command line (for example “Jump 5 enter” would jump to Cue 5 in the

Default Cuelist).

· Use the keyboard shortcut [yellow/Ctrl/Command] J. 

· Select Tools->Jump.

Playbacks with Faders
Depending on your console type you will have one or more Playback with Faders sets
consisting of five playbacks:
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These playbacks consist of:

· A Select button, by default used to select the Playback or its assigned Cuelist.

· A Go button, by default used to play the Cuelist or other component.

· A Fader, by default used to control the intensity of a Cuelist or Group.

· A Flash button, by default used to momentarily flash the intensity of a Cuelist to full.

Playbacks Without Faders
These are button-only playback sets available on some Vista consoles like the EX:

These playbacks have the same buttons as the Playback with Faders section, but do not
have the fader control.
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Page Controls

Each playback module consists of five playbacks. Cuelists and other components can be
assigned to these controls as pages. To change pages:

· Press the Page Up button to advance to the next page number.

· Press the Page Down button to go back to the previous page number.

Every time you assign a component to an empty page, Vista will automatically add a new

additional empty page.

Configuring the Console for Playback

Once you’ve stored a number of Cuelists, Groups, Presets, Extracts, etc…, you can assign
those components to the playback controls the way you want them using the Console
window.

When you click the Console button on the toolbar Vista displays the Console screen:

On this window, the Sidebar (on the right side) shows a Quick Picker where you can display

and filter the components you want to assign to the console. You can:

· Choose a component type (Cuelists, Groups, Presets, Extracts, Smart FX,

Snapshots) from the top dropdown.

· Filter the list by selecting a set from dropdown. For example, you can filter the list to

show just Presets that include Color.

Assigning a Component to the Playback Controls
Once you’ve selected the component type you want you can drag and drop it onto the label
area corresponding to the console’s LCD windows:
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Tip: You can assign any combination of components to the playback controls—Cuelists,
Groups, Presets, Extract, Effects, Favorites, and Snapshots. Exactly what functionality the

playback control will have will depend on the type of component assigned to it.

Multiple components can be quickly assigned across a set of playbacks in one action by
holding shift or control when making a selection of multiple items in the components Quick
Picker.

Splitting Playback Controls
When a component is assigned to a playback it uses all the controls that are available. In the
example below the Cuelist has the default flash, play, and select controls. The extract also

has three controls assigned to it, but by default they will all do the same thing “apply”.

You can split a playback set to increase the number of components that can be placed on a
page.
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Splitting the EX/MV Playbacks

Newer Vista consoles have a slightly different method for splitting the playbacks and older
consoles. To split an MV or EX playback, position the curser within the label area for a
playback and right click the mouse. Pick the Split Vertically option. 

This splits the top playback button from the rest of the playback controls.

Playbacks can be split an additional time, creating three assignable playbacks, by repeating
the procedure.

Through the right-click menu, you can also “unsplit” a button or fader.

Splitting Older Console Playbacks

To do this, move the cursor to the top of the white label area. When the pointer changes to a
split bar [=], click and drag down:

Playbacks can be split up to three ways. To do this, after splitting the playback two ways,
move the cursor to dividing line at the middle of the label area. When the pointer changes to a
split bar [=] click and drag down.
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Tip: You don’t have to split all the playbacks on a page the same way; you can split one
playback two ways, another three ways, and so on.

Expanding Playbacks
Playbacks can also be extended horizontally to provide more physical button controls for
playback of a Cuelist. Up to five playbacks in the group can control a Cuelist:

Expanding the EX/MV Playbacks

As with splitting playbacks, newer consoles like the EX and MV have a different method for
performing the expansion. Move the mouse pointer to the playback display that you want to
expand to include the controls to its right, and right click. Pick Expand Horizontally.

Through the right-click menu, you can also “unexpand” a playback.

Expanding Older Console Playbacks

To expand a Playback move the cursor to the right side of the label area. When the pointer
changes to a split bar [||] click and drag to the right.
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Tip: You can expand a Playback before or after a Cuelist has been assigned, but you can only

expand into an area that is not occupied by another component.

Configuring the Cuelist Playback Buttons and Faders
Normal, split and expanded playbacks have their buttons and faders set up with the default
configuration. To see how the buttons and faders are configured press the Help key [!] on L or
T series consoles. On newer consoles, press the (i) info button. On a Mac or Windows
system, hover the mouse pointer over an item to show a tooltip.

Vista displays the button and fader functions on the LCDs and in the Console window:

You can assign different actions to these buttons and faders to suit your requirements or
playback style.

To assign an action:

1. Click the Console button to display the Console screen.
2. Click on one of the sections of controls shown in the sidebar at the bottom right to

display the control types available. The control groups are Cuelist Buttons, Cuelist
Faders, Group Buttons, Group Faders, FX Master Buttons, FX Master Faders.

3. Click on the desired button or fader action and drag it on top of the button or fader
you want to use for that function.
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Note that Vista will not let you assign a button or fader function not compatible with the
component assigned to the playback. For example, you can’t assign the Group Fader HTP
function to a fader on a playback that has a Cuelist assigned to it.

Cuelist Buttons

The following Cuelist button actions are available:

This button action … does this…

Blank The button has no action.

Skip to Start If not at the first Cue, pressing this button jumps you to
the first Cue using the Live timing settings. If already at
the first Cue, pressing this button releases this Cuelist
using the Live timing settings.

Skip Back If not at the first Cue, pressing this button jumps you to
the previous Cue using the Live timing. If at the first
Cue, pressing this button releases this Cuelist using
the Live timing.

Play Plays the next Cue in the Cuelist or resumes playback
of a paused Cue.

Pause Pauses the playback of a transitioning Cue. If pressed
a second time, the current Cue returns to the previous
cue using the timing of that cue. 
If a cue has completed its transition and the “pause”
button is pressed the Cuelist will play backwards
using cue time.

Skip Forward Jumps to the next Cue using the Live timing.

Skip to End Jumps to the last Cue in the Cuelist using the Live
timing.

Jump Opens the Jump window. See Using the Jump window
earlier in this chapter.

Inhibit Stops the Cuelist playback, Intensity is reduced to 0
and all other features revert to values coming from
other Cuelists, otherwise their defaults. Press the

button again to enable or re-assert the Cuelist.

Flash Momentarily flash the Cuelist intensity to full. 

Edit Opens a Cuelist, for editing, in the Editor window.

Release Releases a Cuelist using the release timing.

Select Selects the Cuelist to become the Default Cuelist.

Re-assert Re-asserts a Cuelist that has been overridden.

Flash Latch Toggles the Cuelist intensity between full and off.

Solo Flashes the Cuelist intensity to full and blackouts all
other output.

Chase Toggle Toggles between Chase on and Chase off.
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This button action … does this…

Chase Direction Cycles between the available chase directions in this
order: Forward, Backward, Bounce, Random.

Chase Forward Sets the Chase direction to forwards (the normal
setting). N.B. if the chase is already running forwards
the button will toggle between chase off and chase
forwards.

Chase Backward Sets the Chase direction to backwards (or reverse).

N.B. if the chase is already running backwards the
button will toggle between chase off and chase
backwards.

Chase Bounce Sets the Chase direction to bounce. N.B. if the chase
is already bouncing the button will toggle between
chase off and chase bounce.

Chase Random Sets the Chase direction to random. N.B. if the chase
is already set to random the button will toggle between
chase off and chase random.

Tap Chase Rate Tap the button to set the beats-per-minute rate of a
chase.

Tap FX Rate Tap the button to set the beats-per-minute of the FX
running in the cue.

Exit Loop Stops a loop and goes to the next Cue.

Play Toggle Plays the Cuelist or releases the Cuelist if it is already
playing.

Play / Release Acts as a temporary play. When the button is held the
Cuelist will play. The Cuelist will release as soon as
the button is released.

Smart Flash Flashes the Cuelist intensity to 100% if the Cuelist
fader level is below 95%. If the Cuelist fader level is
above 95% the intensity level will flash to 0%. 

Cuelist Faders

The following Cuelist fader actions are available:

This fader action … does this…

Blank Fader has no action.

Intensity Sets the fader to control the Intensity of a Cuelist. This
is the default assignment for all Cuelist faders.

Crossfade Sets the fader to manually crossfade between Cues. 

Chase rate Adjusts the chase rate of a Cuelist running in Chase
mode, or the playback rate if not running in chase
mode.
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This fader action … does this…

FX size Controls the size of effects in the current Cue.

FX rate Controls the rate of effects in the current Cue.

FX phase Controls the phase offset of effects in the current Cue.

Chase Crossfade % Proportion of time spent fading vs. time spent at each
step of a chase.

Live Timing Controls the Live fade time. When the fader is at
100%, the set Live fade time is used. When less than
100%, it scales the Live fade time to be proportionately
slower.

Tip: You can save the button / fader configuration as a default to be used whenever a Cuelist is
assigned to a playback. To do this, right-click on a Cuelist playback control and choose Save

as default Cuelist config.

Playback Status Indication
For Cuelists the LCD displays and LEDs (if applicable) inside the console playback buttons
indicate the current status of each playback. For older consoles prior to the MV & EX
consoles, the status indicators are:

Normal (2 Button Playback) Split (1 Button)

Lower Button Upper Button LCD Button

Current Inverted

Active Green

Paused Green Flashing Green Flashing

Running Green Green

Completed Red Red

Overridden Red Flashing Red Flashing

For the EX and MV consoles, playback status is indicated in Virtual Console Display (and the
Console Window as well). The colors used are customizable in the Vista Themes settings,
under the Console section. When using the factory “Artusa Light” theme, the colors used are:

Select Button Play Button Text Display

Selected Green Outline Cuelist label has
yellow
background

Active Yellow Outline Cue label has
dark green
background with
lighter green
progress bar
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Select Button Play Button Text Display

Paused Green
Flashing
Outline

Cue label has
dark green
background with
lighter green
progress bar

Running Green Outline

Completed Red Outline

Overridden Red Flashing

Playback Popup Menu
You can make changes to Cuelists Pages and other components using the Playback context
menu. To open this menu right-click on the label area of any playback control. Vista displays
the context menu:

Below the split and expand options (which were described previously), there are:

This option… does this…

Set default Cuelist Sets the Cuelist assigned to this playback as the
Default Cuelist.

Edit Cuelist Opens an Editor tab for this Cuelist.

Cuelist Properties Opens the Cuelist properties window. Refer to
Chapter 9: Working with Cuelists for details on the
Cuelist Properties window.

Group Properties Opens the Group properties window. Refer to Chapter
8: Components for details on the Group Properties
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This option… does this…

window.

Set as default Cuelist
config

Sets the selected Cuelist’s buttons and faders as the
defaults for all new Cuelists.

Lock/Unlock item Locks or unlocks the selected component.
Components that have been locked will not be altered
or replaced when a new Page or Snapshot is loaded.

Clear item Clears the selected playback. The assigned
component is removed from the control.

Clear page Clears all playbacks on the current page. The
assigned components are removed and a blank page
is left.

Delete page Deletes the current page.

Copy page Copies the current page.

Copy all pages Copies all pages on the playback set.

Paste page(s) Paste the page or pages.

Set as default playback
layout.

Sets the selected Cuelist’s buttons and faders as the
defaults for all new Cuelists.

Adjust contrast Adjusts the contrast of the selected LCD window

Pages
Each Playback module can be paged independently of the others, allowing for a wide variety
of console configurations. To change pages, press the Up or Down arrow buttons located to
the side of each playback module.

Locking a Playback to Prevent Changing
Components can be locked, so that they are not affected by Page changes. To do this right-
click on the LCD in the Console window and choose Lock Item. A small triangular indicator

with the letters “LK” showing the Playback is locked is added to the upper-left corner of the
LCD display.

Page Holdover
If a Cuelist is playing when you change pages, it is held and that playback does not load the
contents of the new page. The playback that is held will join the new page when the Cuelist is
released, fully over-ridden, or you press the page up and down buttons simultaneously. A
small triangular indicator with the letters “HD” showing the Playback is held over is added to
the upper-left corner of the LCD display.

Note: The Page Holdover functionality can be disabled in the Console section of User
Preferences.
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Group Masters

You can assign any Group to a playback for quick HTP control of a selection of
fixtures. To do this:

To assign an action:

1. Click the Console button to display the Console window.

2. Select Groups from the drop-down menu at the top of the sidebar.

3. Drag and drop the desired Group onto a playback position. A Group can be

controlled by a single button, or by a playback with a fader and/or multiple buttons.

Once you have assigned a Group to a playback you can select actions for the
buttons and fader associated with the Group.

To assign an action:

1. Click the Console button to display the Console window.

2. Click on the Group Faders or Group Buttons tab in the sidebar.

3. Click on the required fader or button action and drag it on top of the button or

fader you want to use for that function.

Group Fader Functions
The following fader actions are available:

This Group fader type does this…

Inhibitive Scale ( - ) Reduces the intensity of fixtures in the group. When a
Scale(-) fader is pulled down, while a Cuelist is being
played, the intensity of fixtures in that group will be
reduced from their programmed values to 0%.

Additive Scale ( + ) Increase the intensity of fixtures in the group. When a
Scale(+) fader is pushed up, while a Cuelist is being
played, the intensity of fixtures in that group will be
increased from their programmed values to 100%.

HTP

(Highest takes
precedence)

Controls the intensity of fixtures in the group on an
HTP basis. Any fixture in the group set to a lower
intensity that what the group fader is currently set at
will be increase to the group fader level. Any fixture in
the group that is already at a higher intensity level will
be unaffected.

This is the default fader setting for groups.

Note that fixtures with levels in the live programmer
will override HTP levels coming from Groups or
Cuelists.
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Group Button Functions
The following button actions are available:

This button action … does this…

Blank The button has no action.

Select Selects the group. This is the default button setting for
groups on playbacks with a single button .

Flash(-) When a Flash(-)button is pressed the intensity of
fixtures in that group will go to 0%. Releasing the
button restores the previous fixture levels.

Flash(+) When a Flash(+)button is pressed the intensity of
fixtures in that group will go to 100% regardless of the
priority of any Cuelist controlling these fixtures.

Releasing the button restores the previous fixture
levels.

Flash HTP

(Highest takes
precedence)

When a Flash HTP button is pressed the intensity of
fixtures in that group will go to 100% This is the default
flash button setting for groups.

Solo Brings the intensity of fixtures in the group to 100%
and blacks out all other fixtures. Releasing the button
restores the previous fixture levels.

FX Masters
FX Master controls are tied to FX Master components, enabling the user to control the rate
and/or size of an effect through a button or fader.

FX Master Button Functions
The following button actions are available:

This button action … does this…

Tap Rate Sets the beat-per-minute rate of any effect bound to
the associated FX Master.

Reset Rate Returns to the base rate set when creating the FX
master.

Restart Restarts the effect from the beginning of its cycle.

Reset to tapped rate Resets the rate to the last tapped rate.

Double rate Doubles the current rate.

Temp double rate Doubles the current rate while held.

Half rate Halves the current rate.

Temp half rate Halves the current rate while held.

Quadruple rate Quadruples the current rate.
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This button action … does this…

Temp quadruple rate Quadruples the current rate while held.

Quarter rate Quarters the current rate.

Temp quarter rate Quarters the current rate while held.

Zero rate Sets the rate to 0.

Temp zero rate Sets the rate to 0 when pressed; press a second time
to deactivate..

Temp zero rate and
size

Sets the rate and size to 0 when pressed; press a
second time to deactivate.

FX Master Fader Functions
The following fader actions are available:

This fader action… does this…

FX Rate 0-200% Scales the rate to between 0% and 200% of the
effect’s programmed, or tapped, rate.

FX Size Scales the size value to between 0% and 100% of the
programmed size.

FX Rate and Size Scales both the rate and size values to between 0%
and 100% of the programmed rate and size.

Snapshots

Snapshots allow you to store and recall the state of the console’s Cuelist output, fader level,
console pages, window layouts, and other controls. They can be used to quickly re-configure
the controls for playback, programming or a mixture of both. For example, you may have a
snapshot set up for each song or part of a show. You might also have a snapshot for
programming with the playback buttons assigned to provide quick access to Groups, Presets
Extracts and Effects.

Snapshots can not only recall Page and Cuelist settings but also the state of the Cuelist. For
example, if a Cuelist is active and in Cue 3 when the snapshot is recorded then the same

state can be recalled.

To Record a Snapshot
Click the Create Snapshot button (normally [green/Alt/Option] + F9) on the main toolbar. Or
select Components->New Snapshot. Vista displays the Create Snapshot window: 
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This option… does this…

Label Sets the name for the snapshot

Record Sets the options for the snapshot:

Playback State Records the state of active Cuelists. For example, if

a Cuelist is active in Cue 2 when the snapshot is
recorded it will also be active in Cue 2 when
recalled. Likewise, Cuelists that were not playing at
the time of recording the snapshot will be released.

Fader Levels Includes the current Cuelist fader levels in the
snapshot.

FX Masters Saves the state of all FX Masters.

Console Workspace Saves the current page number of each playback
module and also the Superplayback state.

Window Workspace Saves the state of the window layouts including
dockable windows and their current position/filter.

Live Timing Saves the Live Timing settings.

Clear Live Programmer
When Applied

When checked, the Live tab will be cleared when
this Snapshot is recalled and applied.

Note: Locked components are protected from any changes by snapshots. If a Cuelist is part
of a snapshot and it is also running on a Playback that will not be affected by the snapshot
there can be a conflict.

In this situation:

· If the Cuelist is active on the unaffected module, it is not changed.

· If the Cuelist is inactive on the unaffected module, it is restored to the state stored in

the incoming snapshot (i.e. activated or released).

Assigning a Snapshot to a Playback
You can assign a Snapshot to a playback button in the Console window.
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Recalling a Snapshot
To recall a Snapshot, you can either:

· Use a playback button that has been set up as a snapshot.

· Right-click on a snapshot icon and select Apply.

· Click on the snapshot in one of the Quick picker windows.

· Use the command line.
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Chapter 17: The User Configurable,

External, and Dockable Windows

Vista provides two features that help you configure Vista’s user interface in a way that best
serves you. One is the User Configurable Window, and the second is two External Windows.
These share the same functionality, but with one difference: the User Configurable Window is
one of the main Windows in the Vista interface, selectable via the User Softkey Toolbar; the
External Windows are floating windows that can be placed anywhere on your computer
monitor(s) and maximized to take up an entire monitor. The External Windows are primarily
intended to enable Vista to support systems with multiple monitors, making it easier for you to
make the best use of your monitor real estate.

To make this chapter easier to read, we will simply refer to the User Configurable window,
and unless stated otherwise, all this information also applies to the two External Windows as
well.

Dockable Windows
The panels that we describe here are all also available as dockable windows that can be
sized and placed outside of any containing window. To create any of these panels as a
Dockable Window, select the desired window type from View->Add Dockable Window.

External Windows
To open up an External Window, enable it from View->External Window. There are two possible

external windows, depending on how many displays connected to your system. Systems with only 1

display will not be able to add an External Window. 
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Configuring the User Configurable Window

When you first open the User Configurable Window by either picking View->User

Configurable Window, or pressing the User Configurable Window button on the User
Softkey Toolbar, the window is empty except for a vertical toolbar on the right side of
the window. This toolbar enables you to add a variety of panels to your User
Configurable Window. In order from top to bottom, the panels are:

1. A Quick Picker
2. A Fixture Chooser
3. An Output Panel
4. A Playback Control Panel
5. A DMX Output Display
6. And an Add Dockable Window button. 

The Add Dockable Window button brings up a menu which allows you to pick from all
available dockable panels and add them to your User Configurable Window:

Each panel can be resized and dragged to new positions in the User Configurable Window.
To resize, drag the separator bar between panels; to move the position of a panel, drag the
header bar of that panel. The configuration you set will be remembered when you restart
Vista, and the configuration can also be stored in a Snapshot to be recalled when that
snapshot is applied. Multiple snapshots can be saved with different window configurations

and quickly recalled.

Each panel in the User Configurable Window has a configuration menu, accessible from the
top-left corner of the panel:
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The options in this menu are:

This menu item… does this…

Send to window Lets you move this panel to another user configurable
window.

Settings Accesses the settings window for this specific panel.
Explanations of the settings can be found in the
chapter that covers this type of panel. E.g., the
settings for the Quick Picker panel can be found in the
chapter discussing Quick Pickers.

Compact This is a Quick Picker panel option, setting the Quick
Picker’s interface into Compact mode. Compact
mode hides the component and filter drop-down
menus providing you with more vertical space.

Lock Locks this panel so that it cannot be moved or
resized.

Close Closes this panel, removing it from the User
Configurable Window.

Panel Types
Some of the panels that can be added have been described earlier in this chapter. For
instance, the Fixture Chooser panel’s functionality is largely identical to the Chooser Window.
However, there are some panels that are unique to the User Configurable Window which we
will describe here.

The Output Panel
You use this screen to display the output to your fixtures. By default, the fixture list is sorted by
Fixture ID, but the list can be sorted by any of its columns by clicking in the column header.
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Adding Output View Tabs

You can create as many different views of the output as you like, each arranged in its own
way. To create a new output view, right-click on the tab section at the bottom of the Output
panel and pick Add View.

To switch between layouts, click on the tab you want to use.

Configuring the Output Panel

The Output panel has a popup menu that lets you configure how the Output information is
displayed. Right-click within the Output panel to show the configuration options:
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This option… does this…

Values Mode Shows the actual values of the features. If a feature is
set to a preset value, the name of the preset will be
displayed rather than the value.

Source mode Shows where each feature is coming from. For
example, a fixture might have Intensity and Position

coming from a Cuelist and Color from the Live tab.

Show all fixtures Shows all fixtures.

Show selected
fixtures only

Filters the window to only show the selected fixtures.

Show active fixtures
only

Displays only the fixtures that currently have features
set.

Follow Fixture
selection

Shows the selected fixtures at the top of the view.

Add selected fixtures Adds the fixtures, selected in the Fixture Chooser
screen, to the output window.

Remove selected
fixtures

Removes the selected fixtures from the output window.

More icon detail When in Values mode, additional information will be
shown along with the value Icon.

Less icon detail When in Values mode, less information will be shown
along with the value Icon.

Resize all columns Resizes all columns to their default size.

The Source view shows the source of control for each of the features. For example, if a

fixture’s color settings have come from a Cuelist named “Rainbow”, that name will be
displayed in the Color column for that fixture.

Selecting Fixtures

If you click on a row for a fixture in the Output panel, Vista selects that fixture. If you hold
[red/Shift] when doing so, it will add that fixture to the fixture selection.

The DMX Panel
The DMX panel displays the DMX values being output to the various universes, regardless of
where the values are coming from (Programmer, or Cuelist, or group fader…):
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Use the Universe text area at the upper-left area of the panel to select which universe you
want to view.  Add multiple DMX panels to monitor more than one universe at a time.

The Vista Statistics Panel
The Vista Statistics window provides information on the performance and status of all devices
in a Vista network group:

This window is primarily intended to provide information to Vista by Chroma-Q technical
support staff to help diagnose any issues a user may be encountering. Should you be having
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an issue for which you’re communicating with technical support, they may ask you to provide
them with information from this window.

The Clock Panel

What needs to be said?—it’s a clock!

The Timecode Panel
This is a duplicate of much of the Learn Timing window when Timecode is enabled, minus
the controls for actually learning the cue timing:

Refer to the Timecode section of the manual for more information on these controls.
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The Keypad Panel

The Keypad panel is designed to assist with using the command line; it can be particularly
useful when using Vista with a touch-screen. Common command functions are available as
buttons, and a copy of the Vista command line is also present. See the chapter on the Vista
Command Line for more information about working with Vista via the command line.
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Chapter 18: Merging Showfiles

The Merge function of Vista makes it easy to bring in elements from another show file for use
in your current show file. This can save significant time in programming a new show that has
elements in common with other shows you’ve created.

Some of the ways Merge can be helpful are:

· Populate a new Showfile with a previous show’s patch and specific Cuelists and

components. This can be quicker than opening the original show file and deleting the
elements you don’t need from the original Showfile.

· Import complete Cuelists from a previous show that utilizes the same patch into

your current Showfile. For example, a church may have a Showfile with a Cuelist for
each worship song they’ve ever programmed. You can import the Cuelists for just
the songs being utilized in this week’s service from that Showfile into the Showfile
for the current week’s service to keep that service’s Showfile more manageable.

· Import a Cuelist with its cue timings and structure without the patch or programmed

events, giving you a framework within which to program new fixtures or looks. For

example, you may once again be working with a band that you have worked with on
a previous tour. You can import all of the song Cuelists, with nothing but the timings
and names, allowing you to easily program this tours new fixtures and looks.Cues
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How It Works

To merge in data from another
Showfile, select File->Merge. You will
be prompted for the Showfile you
want to merge from, and then the
Merge Show window will appear.
The Merge Show window lets you
select the components you want to
merge from the specified Showfile.
By default, no items are selected.
You can pick all Cuelists by checking
the box next to the Cuelists option;
or, you can twirl down the Cuelists
option and pick specific Cuelists to
merge into your show. In the
screenshot to the right, we’ve only
asked for the Act I, Act II, and
Houselights Cuelists to be merged
into our show.

Similarly, you can pick other features
to merge into your show, such as
groups, fixtures, layouts, etc….
Refer to the screen shot of the
Merge Show window to see the
complete list of items that can be merged. Note that if the Showfile you are merging from
does not contain certain element types (such as Extracts, for instance), there will be no
checkbox next to that element type.

If you select to merge in a Cuelist but no fixtures, the fixture programming in the Cuelist will be
preserved if the exact fixtures used in the Cuelist already exist in your current Showfile. (See
below on how this is determined—it’s less obvious than you might think.) If the fixtures do not
exist, you will get the Cuelist with its Cues and associated timings and properties, but there
will be no events programmed into the Cuelists, because the fixtures do not exist in your
show. If, however, the fixtures already exist in your show, the events for which fixtures exist
will also be merged into your show.

If you want all the fixture programming to come over with the Cuelists you are merging, and
the fixtures are not already in your show, you must select to merge fixtures as well, or at least
the fixtures which are used in the Cuelists you are merging.

This concept applies to other elements as well. For example, if you choose to merge groups
but no fixtures, the groups will come over with no fixtures programmed into them unless those
fixtures already exist in your show.

If you merge in elements that have the same user ID numbers, Vista will automatically assign
new user ID numbers to those elements. The Merge Show window displays those new
assignments.
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To Merge, or Not to Merge?

That IS the question. When merging a Showfile, how does Vista determine if a fixture already
exists in the Showfile you are merging into?

One might logically think that if you are merging in a Cuelist that references Fixture ID 15, and
there’s a fixture with ID 15 in your current Showfile, then it’s a match. And you would be
wrong. To understand how the matching of fixtures and other elements occurs, we need to
peek under the hood of Vista a little. 

Every item created in Vista is assigned an internal ID, called a UUID (Universally Unique
Identifier, for the nerdy amongst us….) No two created fixtures will ever be assigned the same
UUID. And it’s the UUID that matters when matching elements in a merge operation. 

Therefore, if in my new Showfile I manually recreate the patch from the Showfile I eventually
merge from, creating the same fixtures, with the same fixture profiles, and assign the same
user IDs and patch assignments—i.e., make it appear to perfectly match the patch from
another Showfile—and then merge in just a Cuelist from that other Showfile, the Cuelist will
contain no event programming, because the UUIDs of the fixtures will not match. Vista will
think that the fixtures in the original Cuelist do not exist in your current Showfile.

So, if you want those Cuelists to come over with their event programming, you need to merge
in the fixtures as well. Which will cause an entirely new set of problems in our example,
because now you will appear to have duplicate fixtures, and you’ll not be able to patch these
new fixtures that get merged in because you’ve already created fixtures that are patched to
those addresses.

The correct way to approach this is to plan ahead, and when you create your new Showfile,
merge in the patch (and any other needed elements) from the existing Showfile to ensure that
the UUIDs will match. Don’t try to create any of those elements manually.
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Chapter 19: The Vista Command Line

Vista features a Command Line Interface (CLI) that provides keypad syntax for patching,
selecting fixtures, setting features, storing Cues, and more. The Command Line is
synchronized with the graphical interface so that when you type a command you see the
equivalent action happen on the fixture icons and feature panels of the Sidebar. By default,
Vista displays the CLI at the bottom of the main Vista window. If it cannot be seen, select
View->Command Line option from the View menu. 

The information conveyed around the command line is:

· Top: the last command.

· Left: the Default or Editor Cuelist.

· Right: the selected fixtures.

Vista 3 includes a virtual Keypad for use with a touch screen or with a mouse. You can enable
the virtual Keypad by adding it to the User Configurable Window, an External Window, or as a
dockable window (Refer to the chapter on the User Configurable Window):

This is particularly useful when using Vista with a touch-screen display.

Keyboard Shortcuts
The following keyboard shortcuts are available when the CLI or Virtual keypad is being used:
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This key does this...

Q Cue

W Cuelist

E FX (Effect)

R Renumber

T Time

Y Delay

U Update

O Q-Only

P Preset

A, or @, or * At

AA, or @@, or ** Full (at 100% intensity)

S Store

D Edit

F Fixture

FF Recalls last fixture selection

[green/Alt/Option] + F Cycles through previous fixture selections

G Group

H Home

J Jump

K Release

L Label

Z Out (0% intensity)

X Extract

B Block

N Snapshot

M Move in Black (M.I.B.)

[green/Alt/Option] + T Delay

[green/Alt/Option] + I Intensity

[green/Alt/Option] + P Position

[green/Alt/Option] + C Color

[green/Alt/Option] + G Gobo

[green/Alt/Option] + B Beam

[green/Alt/Option] + M Misc features

[green/Alt/Option] + D Delete

[green/Alt/Option] + .
or ,

Properties

[green/Alt/Option] + L Renumber

[green/Alt/Option] +
Enter

Recalls last command
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This key does this...

/ Through

[green/Alt/Option] + 0-9 can also be used on a keyboard to mimic the virtual keypad functions,
shown in the orange letters in the image below. 

Command Line Syntax Rules

Default Cuelist
Without explicitly specifying otherwise:

· The Default Cuelist is always the target destination for Store All and Store Part

operations.

· The store behavior is to always create a new Cue at the end of the Cuelist. 

There is a new prefix panel to the left of the command line. The Default Cuelist will be shown
here: 

If a Cue within the Cuelist is active, it will be shown underneath the Cuelist name:

The green header bar indicates that you are in the Live tab.

All command line actions will target the Default Cuelist. For example, you could use “label
enter” to label the current Cue or “properties enter” to open the Cuelist properties, all without
having to specify the Cuelist or Cue number. 

The first Cuelist created within a new Showfile will automatically become the Default Cuelist.

You can still explicitly specify other store destinations, or command line actions, should you
wish. For example, “store Cuelist 2” would create Cuelist 2 Cue 1. If you pressed “store”
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again the console will have returned to wanting to store to the Default Cuelist (which is Cuelist
1 in the above example).

There is only one “Default Cuelist” at any moment in time. You can change the “Default
Cuelist” by:

· Pressing the “Select” button on a console playback.

· Using the command line (For example, “Cuelist 2 enter”).

· Using an inserted command “select” action.

· Using the GUI (dashed square) “select” button within a Cuelist edit tab:

· Use the Cuelist right-click contextual menu:

Editor Cuelist
The Editor Cuelist is any Cuelist that is open within an editor tab. You can edit a Cuelist by:

· Pressing Edit within the User Softkey Toolbar, or selecting Components->Edit

Cuelist.

· Using the command line (for example “edit Cuelist 2 enter”)

· Pressing an edit playback button 

The Editor Cuelist will temporarily become the target for Store All and Store Part operations,
plus the command line focus. 

The command line prefix will change to represent this:

The orange header bar indicates that you are in an Editor tab.

Whenever you close the Editor Cuelist you will always return to the Live tab and the Default
Cuelist will once again become the default target for store and command line operations. 
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There is only ever one Editor Cuelist; if you have multiple Cuelist Editor tabs open, you will

notice that the Editor Cuelist automatically follows your selection. 

If the Default Cuelist is also open in a Cuelist Editor tab, this will be indicated by the Cuelist

icon on the tab changing from blue to green:

Command Line Examples
The best way to learn the command line syntax is through examples. In these examples, we
will use the name of the function followed by the key you will actually type in curly brackets.
Therefore, when we give the example of selecting fixtures 1 through 10 as “Fixture {F} 1
Through {/} 10 {Enter}”, what you would type on your keyboard is “F1/10” followed by the Enter
key. Note that the keyboard shortcuts are not case-sensitive—For “Fixture”, you can type
either a lower- or upper-case “F”. 

Some commands are designed to either be stand-alone or as part of a longer command
string; for example, you can do just a fixture selection, or do a fixture selection and change the
features of those fixtures (such as setting the intensity). Commands that require an Enter
press are indicated with this symbol: 

Some commands can be typed in more than one string order. These alternative orders for the
same command are marked by italics.

Selecting Fixtures

To... Use this syntax...

Select fixtures Fixture {F} 1 through {/} 10 + 20 through {/} 30 

Select sub-elements 2 through 8,
on fixtures 1 through 5

Fixture {F} 1.2 through {/} 5.8 

Select Group 1 except for Fixture
10

Group {G} 1 - Fixture {F} 10 

Select Groups 1 through 3, and
also Fixture 10

Group {G} 1 through {/} 3 + Fixture {F} 10 

Recall last fixture selection Fixture {F} Fixture {F}

Cycle through previous fixture
selections

[green/Alt/Option} Fixture {F}

Add to last selection Fixture {F} Fixture {F} + Fixture {F} 4 + Group {G} 5
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To... Use this syntax...

Deselect fixtures Fixture {F} 

Selections made in the fixture chooser window or by using group buttons are automatically
written to the command line.

Setting Fixture Levels and Features

To... Use this syntax...

Set Fixtures 1 through 10, except for fixture
5, to 40% intensity

Fixture {F} 1 Through {/} 10 - 5 @ 40 

Set Fixture 2 to full intensity Fixture {F} 2 @ @

Decrease the intensity of the current
selection of fixtures by 20%

@ -20 

Increase the intensity of the current
selection of fixtures by 20%

@ +20 

Go to 50% of set output for the selected
fixtures

@ /50 

Set the intensity of fixtures 101 through 103
to 0%

Fixture {F} 101 Through {/} 103 Out {Z}

Set intensity of the currently selected
fixtures to 0%

Out {Z}

Set fixtures 2 through 5 to their Home
settings for all features

Fixture {F} 2 Through {/} 5 Home {H}

Set Fixture 2’s Intensity and Position to their
home values

Fixture {F} 2 Intensity {[green/Alt/Option] I}

Position {[green/Alt/Option] P} Home {H}

Set Fixture 2’s features except for its

position feature to its Home setting.

Fixture {F} 2 – Position {[green/Alt/Option]

P} Home {H}

Copy the Position setting from Fixture 2 to
Fixture 1

Fixture {F} 1 @ Fixture {F} 2 Position

{[green/Alt/Option] P} 

Copy the features on the fixtures in Group 2
to the fixtures in Group 1. Selection order
stored in the source group is mapped to the
fixtures in the selection ordered stored in
the destination group.

Group {G} 1 @ Group {G} 2 

Clear fixture 1 Fixture {F} 1 @ 

Clear the position information for fixtures 2
through 4

Fixture {F} 2 through {/} 4 position

{[green/Alt/Option] P} @ 
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To... Use this syntax...

Clear intensity and position from Fixture 1 Fixture {F} 1 – Intensity {[green/Alt/Option]

I} – Position {[green/Alt/Option] P} @ 

Convert fixture 1’s events to release event Fixture {F} 1 @ . 

Timing

To... Use this syntax...

Set Fixture 1’s position and
color events to 5 seconds

Fixture {F} 1 Position {[green/Alt/Option] P} Color
{[green/Alt/Option] C} Time {T} 5 

Set the delay time on Fixture 1’s
Position event to 5.5 seconds

Fixture {F} 1 Position {[green/Alt/Option] P} Delay {Y}
5.5 

Set the delay time for all events
in Cue 3 of List 1 to 2 seconds

List {W} 1 Cue {Q} 3 Delay {Y} 2 

Set Fixture1’s feature times to
their defaults

Fixture {F} 1 Time {T} 

Set Fixture 1’s position and
color event timings to their
default settings

Fixture {F} 1 Position {[green/Alt/Option] P} Color
{[green/Alt/Option] C} Time {T} 

Set Cue Timing (all features) Cue {Q} 1 Time {T} 3 

Set Cue 3 of List 1’s fade-up
time to 3 seconds and fade-
down time to 4 seconds

List {W} 1 Cue {Q} 3 Time {T} 3/4 

Set the default Cue Timing for
intensity events in Cue 1 to an
up time of 3 and fade-down time
of 5.

Cue {Q} 1 Intensity {[green/Alt/Option] I} Time {T} 3/5 

Set the default color event
timing for color events in Cue 1
to 4 seconds

Cue {Q} 1 Color {[green/Alt/Option] C} Time {T} 4 

Reset the default Cue timings Time {T}  

Reset the default color timings
in Cue 1

Cue {Q} 1 Color {[green/Alt/Option] C} Time {T} 

Notes:

· Commands act on the Cuelist that is open in the Editor, otherwise the Default

Cuelist.
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· It's possible to set time and delay in the same syntax: Fixture {F} 1 Time {T} 1 Delay

{Y} 2 .

· It's possible to set multiple times in the same syntax. Time {T} 2 Intensity

{[green/Alt/Option] I} Time {T} 3 .

Patching
To use the Patch commands, you first need to switch to the Patch window.

To... Use this syntax...

Patch new fixtures 1 through 5, using the
selected fixture from the library on the
selected Universe, starting at address 200

Fixture {F} 1 through {/} 5 @ 200 

Patch new fixtures 1 through 5 using the
selected fixture from within the library in
universe 2 starting at address 5.

Fixture {F} 1 through {/} 5 @ 2.5 

Multi-Patch Fixture 1, placing part 1 at
universe 2 address 1, and part 2 at
universe 3 address 4.

Fixture {F} 1 @ 2.1 + 3.4 

Unpatch fixtures 1 through 10 Fixture {F} 1 through {/} 10 @ 

Move fixtures 1 through 5 to address 105 in
the Patch

Fixture {F} 1 through {/} 5 @@ 105 

Delete fixture 1 Fixture {F} 1 Delete {[green/Alt/Option] D} 

Delete {[green/Alt/Option] D} Fixture {F} 1 

Notes:

· A secondary “Enter” press is required to confirm the deletion of fixtures from the

patch.

Deleting Events and Components Within a Timeline Cuelist Edit

To... Use this syntax...

Delete all the events for fixtures 1 through 4
in the current Cue.

Fixture {F} 1 through {/} 4 Delete
{[green/Alt/Option] D} 

Delete {[green/Alt/Option] D} Fixture {F} 1
through {/} 4 

Delete the color events from fixture 1 in the
current Cue.

Fixture 1 Color {[green/Alt/Option] C} Delete
{[green/Alt/Option] D}

Delete {[green/Alt/Option] D} Color
{[green/Alt/Option] C} Fixture {F} 1 
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Labelling
When using the label command, upon pressing “Enter” in the command line, Vista’s Label
window will appear. At this point users can input their label text.

To... Use this syntax...

Label Fixtures 1 through 4 Fixture {F} 1 Through {/} 4 Label {L}

Label {L} Fixture {F} 1 through {/} 4 

You can also select fixtures in the fixture
chooser and then type: Label {L} 

Label Group 2 Group {G} 2 Label {L} 

Label {L} Group {G} 2 

Label currently playing Cue of the Default or
Editor Cuelist

Label {L} 

Label Cue 1 Label {L} Cue {Q} 1 

Cue {Q} 1 Label {L} 

Label Cues 1 through 5 Label {L} Cue {Q} 1 Through {/} 5 

Label Cues 1 through 5 except for Cue 2 Label {L} Cue {Q} 1 Through {/} 5 - 2 

Label Cuelists Label {L} Cuelist {W} 1 

Cuelist {W} 1 Label {L} 

Label Cuelists 1 through 5 Label {L} Cuelist {W} 1 Through {/} 5

Label Extract 1 Label {L} Extract {X} 1 

Extract {X} 1 Label {L} 

Label Preset 1 Label {L} Preset {P} 1 

Preset {P} 1 Label {L} 

Label Snapshot 1 Label {L} Snapshot {M} 1 

Snapshot {M} 1 Label {L} 

Rename Effects Label effect 1 

Effect 1 Label  

Renumbering Fixtures and Components
When using a renumber command, you will be presented with a window to specify a new
starting number after pressing Enter on the command line.
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To... Use this syntax...

Renumber Fixtures 1 through 4 Fixture {F} 1 Through {/} 4 Renumber {R} 

Renumber {R} Fixture {F} 1 through {/} 4 

Renumber Group 2 Group {G} 2 Renumber {R} 

Renumber {R} Group {G} 2 

Renumber the currently playing Cue in the
selected Cuelist

Renumber {R} 

Renumber Cue 1 of the selected Cuelist Renumber {R} Cue {Q} 1 

Cue 1 Renumber Enter 

Renumber Cues 1 through 5 of Cuelist 4 Renumber {R} Cuelist {W} 4 Cue {Q} 1

Through {/} 5 

Renumber Cuelist 1 Renumber {R} Cuelist {W} 1 

Cuelist {W} 1 {R} 

Renumber Cuelists 1 through 5 Renumber {R} Cuelist {W} 1 through {/} 5 

Renumber Extract 1 Renumber {R} Extract {X} 1 

Extract {X} 1 Renumber {R} 

Renumber Preset 1 Renumber {R} Preset {P} 1 

Preset {P} 1 Renumber {R} 

Renumber Snapshot 1 Renumber {R} Snapshot {M} 1 

Snapshot {M} 1 Renumber {R} 

Renumber Effect 1 Renumber {R} Effect {E} 1 

Effect {E} 1 Renumber {R} 

Cues and Cuelists

To... Use this syntax...

Select Cuelist 1 as the Default Cuelist Cuelist {W} 1 

Store a new Cue to the Default Cuelist
or the Cuelist open for editing

Store {S} 

Store specific parameters to a Cue Store Intensity {[green/Alt/Option] I} Color
{[green/Alt/Option] C} 

Store certain fixtures to a Cue Store {S} Fixture {F} 1 Through {/} 5 

Fixture {F} 1 Through {/} 5 Store {S} 

Store certain fixtures and parameters Store {S} Color {C} Intensity {I} Fixture {F} 1

through {/} 5 
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To... Use this syntax...

Store to a certain Cue number Store {S} 5 

Store to a number of Cues. The first
Cue will have the parameter
information, and the following Cues will
be empty.

Store {S} Cue {Q} 5 + 10 

Cue {Q} 5 + 10 Store {S} 

Store to a number of Cues with filtered
fixtures and features. The first Cue will
have the parameter information, and
the following Cues will be empty.

Store {S} Cue {Q} 5 through {/} 10 Color

{[green/Alt/Option] C} Intensity

{[green/Alt/Option] I} Fixture {F} 1 through {/} 5

Store Cue with timing Store {S} Cue {Q} 3 Time {T} 5  

Cue {Q} 3 Time {T} 5 Store {S} 

Store Cue with up and down timing Store {S} Cue {Q} 5 Time {T} 5/10 

Store Cue with feature-specific timing Store {S} Intensity {[green/Alt/Option] I} Time

{T} 2 Color {[green/Alt/Option] C} Time {T} 4

Delay {Y} 2 

Update the currently selected Cue Update {U} 

Update a specific Cue Update {U} Cue {Q} 4 

Cue {Q} 4 Update {U} 

Update a specific feature Update {U} Color {[green/Alt/Option] C} Beam
{[green/Alt/Option] B} 

Update a specific fixture

Update {U} Fixture {F} 1 Through {/} 5 

Update a specific fixture & feature Update {U} Intensity {[green/Alt/Option] I}

Position [[green/Alt/Option] P} Fixture {F} 1

Through {/} 5 

Fixture {F} 1 Through {/} 5 Intensity
{[green/Alt/Option] I} Position
{[green/Alt/Option] P} Update {U} 

Store Cue Q-Only Store {S} Q-only {O} 

Store specific features Q-Only Store {S} Color {[green/Alt/Option] C} Q-only

{O}  

Note: Update works similarly for Cue-
only

Store {S} Q-only {O} Color {[green/Alt/Option]
C} 

Block the currently selected Cue Block {B} 

Block a specific Cue Block {B} Cue {Q} 10 

Cue {Q} 10 Block {B} 
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To... Use this syntax...

Block multiple Cues Block {B} Cue {Q} 5 Through {/} 10 

Mark current Cue (i.e. move in black) MIB {I} 

Mark a specific Cue MIB {I} Cue {Q} 2 

Mark currently playing/selected Cue
and specify the features you want
marked

MIB {I} Position {[green/Alt/Option] P} Color

[[green/Alt/Option] C} 

Mark specific fixtures MIB {I} Fixture {F} 1 through {/} 5 

Mark specific features and fixtures

MIB {I} Color {[green/Alt/Option] C} Position

{[green/Alt/Option] P} Fixture {F} 1 through {/} 5

Show properties of the selected
Cuelist 

Properties {[green/Alt/Option] .} or {,} 

Show properties of a specific Cuelist Cuelist {W} 5 Properties {[green/Alt/Option] .}

Properties {[green/Alt/Option] .} Cuelist {W} 5 

Show properties of the selected Cue Cue {Q} Properties {[green/Alt/Option] .} 

Show properties of a specific Cue Cue {Q} 5 Properties {[green/Alt/Option] .} 

Properties {[green/Alt/Option] .} Cue {Q} 5 

Delete currently selected Cue Delete {[green/Alt/Option] D}  

Delete a specific Cue Delete {[green/Alt/Option] D} Cue {Q} 5 

Cue {Q} 5 Delete {[green/Alt/Option] D} 

Delete a number of Cues Delete {[green/Alt/Option] D} Cue {Q} 5 through
{/} 10 + 15 

Delete a Cue Q-Only Delete {[green/Alt/Option] D} Cue {Q} 5 Q-Only
{O} 

Delete {[green/Alt/Option] D} Q-Only {O} Cue
{Q} 5 

Cue {Q} 5 Delete {[green/Alt/Option] D} Q-Only
{O} 

Edit default Cuelist Edit {D} 

Edit specific Cue (of default Cuelist) Edit {D} 9 

Edit {D} Cue {Q} 9  

Cue {Q} 9 Edit {D}  

Edit specific Cuelist Edit {D} Cuelist {W} 2  

Cuelist {W} 2 Edit {D} 
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To... Use this syntax...

Open the Jump Window Jump {J}  

Jump to Cue 9 in the default Cuelist Jump {J} 9 

Jump {J} Cue {Q} 9 

Cue {Q} 9 Jump {J} 

Jump to Cue 5 in Cuelist 2 Jump {J} Cuelist {W} 2 Cue {Q} 5 

Cuelist {W} 2 Cue {Q} 5 Jump {J} 

Open the jump window of a specific
Cuelist

Jump {J} Cuelist {W} 2 

Cuelist {W} 2 Jump {J} 

Release default Cuelist Release {K} 

Release Cuelist 2 Release {K} Cuelist {W} 2 

Cuelist {W} 2 Release {K} 

Release a number of Cuelists Release {K} Cuelist {W} 1 + 3 

Release {K} Cuelist 1 through {/} 5 

Cuelist {W} 1 through {/} 5 Release {K} 

Notes:

· Storing without specifying a Cuelist will always store to the Cuelist open in the

Editor, or if no Cuelist is open, it will store to the Default Cuelist. In the case of a new

Showfile, Vista will store to and create Cuelist 1.

· When pressing “Enter” on Store or Update commands, Vista will open the Store and

Update windows. A secondary “Enter” press is required to complete the action.

· When the Store window is open, users can directly assign this to a playback by

double-tapping the desired empty playback.

· Update without specifying a Cuelist/Cue will always update the Default Cuelist /

current Cue.

· If no Cue number is specified when storing, Vista will store to the next whole number

after the currently playing Cue. Vista will always store to the end of the Cuelist.

· Blocking a Cue that is already blocked will unblock it.

Groups

To... Use this syntax...

Store group (with current fixture chooser
selection)

Store {S} Group {G} 

Store group 10 Store {S} Group {G} 10 

Store group with specified fixture selection Fixture {F} 1 Through {/} 5 Store {S} Group

{G} 
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To... Use this syntax...

Update group with current fixture chooser
selection

Update {U} Group {G} 5 

Update group 5 with fixtures 10 through 20 Fixture {F} 10 Through {/} 20 Update {U}

Group {G} 5 

Delete group 1 Delete {[green/Alt/Option] D} Group {G} 1 

Group {G} 1 Delete {[green/Alt/Option] D} 

Delete multiple groups Delete {[green/Alt/Option] D} Group {G} 1

through {/} 5 

Open group properties for Group 1 Group {G} 1 Properties

{[green/Alt/Option] .} 

Group {G} 1 Properties {,} 

Open and set multiple group properties at
once

Properties {[green/Alt/Option] .} Group {G}
1 Through {/} 5 

Properties {[green/Alt/Option] .} Group {G}
1 Through {/} 5

Notes:

· When storing, after pressing “Enter”, the Store Group window will open and the user

can immediately name their group. A secondary “Enter” press is then required to
complete the action.

· When the Store Group window is open users can directly assign this to a playback

by double-tapping the desired empty playback.

· Users can specify a group ID number when storing if required, otherwise Vista will

use the next whole free number.

· A secondary “Enter” press is required to confirm and delete groups. Deleting groups

does not delete the fixtures.

· Commands in Italics represent syntax structure which can be reversed

Presets

To... Use this syntax...

Apply preset 2 to current fixture selection Preset {P} 2 

Apply preset on fixtures 1 through 5 Fixture {F} 1 Through {/} 5 @ Preset {P} 2

Apply for color features of preset 1 to fixture
1

Fixture {F} 1 @ Preset {P} 1 Color

{[green/Alt/Option] C} 

Delete Preset 5 Delete {[green/Alt/Option] D} Preset {P} 5

Preset {P} 5 Delete {[green/Alt/Option] D} 
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To... Use this syntax...

Delete presets 1 through 5 Delete {[green/Alt/Option] D} Preset {P} 1

Through {/} 5 

Preset {P} 1 Through {/} 5 Delete
{[green/Alt/Option] D} 

Notes:

· When storing, after pressing “Enter”, the Store Preset window will open and the

user can immediately name their preset. A secondary “Enter” press is then required
to complete the action.

· When the Store Preset window is open users can directly assign this to a playback

by double tapping the desired empty playback.

· Users can specify a preset ID number when storing if required, otherwise Vista will

use the next whole free number.

· A secondary “Enter” press is required to confirm and delete presets.

· Commands in Italics represent syntax structure which can be reversed

Effects

To... Use this syntax...

Activate effect 501 on fixtures 10 through
15

Fixture {F} 10 Through {/} 15 FX {E} 501 

Activate effect 502 on current fixture
selection

@ FX {E} 502 

Activate effect 1 on groups 2 and 3 Group {G} 2 + 3 FX {E} 1 

Activate the position and color parts of
effect 2 on the current fixture selection

@ FX {E} 2 Position {[green/Alt/Option] P}

Color {[green/Alt/Option] C} 

Stop all effects FX {E} Stop {@} 

Stop all effects of a particular feature Effect {E} Color {[green/Alt/Option] C} Stop
{@} 

Stop all effects on selected Fixtures Fixture {F} 10 Through {/} 20 Effect {E}

Stop {@} 

Stop all effects on Group 1 Group {G} 1 Effect {E} Stop {@} 

Stop a certain effect feature on currently
selected fixtures

@ {Backspace key} Effect {E} Stop {@}

Intensity {[green/Alt/Option] I} Color

{[green/Alt/Option] C} 

Stop the running effect 5 Effect {E} 5 Stop {@} 

Notes:

· When activating FX the ID number refers to the FX template number.
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· When stopping FX the ID number refers to the instance number listed in the

SmartFX active effects list.

Extracts

To... Use this syntax...

Store a new Extract Store {S} Extract {X} 

Store a new Extract with ID number 4 Extract {X} 4 Store {S} 

Store an Extract of a Cue 5 from Cuelist 2 Cuelist {W} 2 Cue {Q} 5 Store {S} Extract
{X} 

Store color and position features to an
Extract

Store {S} color {[green/Alt/Option] C}
Position {[green/Alt/Option] P} Extract {X} 

Store {S} Extract {X} Color
{[green/Alt/Option] P} Position 

Store color and position features for
fixtures 1 through 5 to an Extract

Store {S} Extract {E} Color
{[green/Alt/Option] C} Position
{[green/Alt/Option] P} Fixture {F} 1 through
{/} 5  

Store the entire Cuelist 3 to an Extract Cuelist {W} 3 Store {S} Extract {X} 

Store only the position and color features
of the entire Cuelist 2 to an Extract

Cuelist {W} 2 Store {S} Extract {X}
{[green/Alt/Option] P} Position
{[green/Alt/Option] C} Color 

Store Cues 3 through 6 of Cuelist 1 to an
Extract

Cuelist {W} 1 Cue {C} 3 Through {/} 6 Store
{S} Extract {X} 

Activate Extract 2 Extract {X} 2 

Activate only the Color features of Extract
3

Color {[green/Alt/Option] C} Extract {X} 3 

Extract {X} 3 Color {[green/Alt/Option] C} 

Activate only the beam features of Extract
1 on Fixture 1

Fixture {F} 1 {[green/Alt/Option] B} Extract
{X} 1 

Edit Extract 5 Edit {D} Extract {X} 5 

Extract {X} 5 Edit {D} 

Delete Extract 5 Delete {[green/Alt/Option] D} Extract {X} 5 

Extract {X} 5 Delete {[green/Alt/Option] D} 

Delete multiple Extracts Delete {[green/Alt/Option] D} Extract {X} 5
Through {/} 10 

Extract {X} 5 Through {/} 10 Delete
{[green/Alt/Option] D} 

Notes:
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· When storing Extracts, on pressing “Enter” Vista’s store extract window will appear.

A secondary “Enter” press is required to complete the action.

· When applying extracts to a Cuelist open for editing, Vista will use the user

preference defined in editing tab of the user preferences - insert, merge or prompt.

· When the Store Extract window is open, users can directly assign this to a playback

by double tapping the desired empty playback.

· Users can specify an Extract ID number when storing if desired, otherwise Vista will

use the next whole free number.

· A secondary “Enter” press is required to confirm the deletion of extracts.

· Commands in Italics represent syntax structure which can be reversed

Snapshots

To... Use this syntax...

Store Snapshot 5 Store {S} Snapshot {N} 5 

Snapshot {N} 5 Store {S} 

Activate Snapshot 5 Snapshot {N} 5 

Update Snapshot 5 Update {U} Snapshot {N} 5 

Snapshot {N} 5 Update {U} 

Delete Snapshot 5 Delete {[green/Alt/Option] D} Snapshot {N} 5

Snapshot {N} 5 Delete {[green/Alt/Option] }
D} 

 Delete Snapshots 5 through 9 Delete {[green/Alt/Option] D} Snapshot {N} 5
Through {/} 9 

Snapshot {N} 5 through {/} 9 Delete
{[green/Alt/Option] D} 

Notes:

· When the Store Snapshot window is open users can directly assign this to a

playback by double tapping the desired empty playback.

· The Store Snapshot window will automatically remember the checkboxes you last

used.

· Users can specify a snapshot ID number when storing if desired, otherwise Vista

will use the next whole free number.

· A secondary “Enter” press is required to confirm and delete snapshots.
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Additional Keyboard Non-Command Shortcuts

Pressing / doing this... Does this...

[blue/Ctrl+Alt/Control] 1 Opens patch view

[blue/Ctrl+Alt/Control] 2 Opens virtual console view

[blue/Ctrl+Alt/Control] 3 Opens fixture chooser view

[blue/Ctrl+Alt/Control] 4 Opens timeline view

[blue/Ctrl+Alt/Control] 5 Opens playback view

[blue/Ctrl+Alt/Control] 6 Opens output view

[yellow/Ctrl/Command] 1 Opens/closes feature browser

[yellow/Ctrl/Command] 2 Opens/closes components

[yellow/Ctrl/Command] 3 Opens/closes FX editor

Holding [red/Shift] Fine control of feature pickers or events in
the timeline

Selects all events / Cues / list items
between first and last selection

Holding [yellow/Ctrl/Command] Apply currently selected Fan 

Selects multiple events / Cues / list items

Holding [green/Alt/Option] Super Fine control of feature pickers or
events in the timeline

Allows you to move components around in
the Quickpickers, into new pages or
favorites.

Brings Quickpicker selections into the
command line

Holding [blue/Ctrl+Alt/Control] Releases Cuelist when pressed in a
Quickpicker

Dragging and dropping a Cue in the open
edit Dragging and dropping a Cue in the
open edit while holding [red/Shift] 

Copies the look of the Cue

Copies the Cue but performs a “paste
special” action giving you options for
tracking and creating Alias Cues

[yellow/Ctrl/Command] S Saves Showfile

[yellow/Ctrl/Command + Shift] S Saves Showfile as

[yellow/Ctrl/Command] Z Undo
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Pressing / doing this... Does this...

[yellow/Ctrl/Command] X Cut / clear (selected fixtures) from
Programmer

[yellow/Ctrl/Command] C Copy

[yellow/Ctrl/Command] V Paste

[yellow/Ctrl/Command + Shift] V Paste Special

[yellow/Ctrl/Command + Shift] X Delete / Cut Cues (in open Cuelist edit)

[yellow/Ctrl/Command + Shift] C Copy Cues (in an open Cuelist edit)

[yellow/Ctrl/Command] W Close open Cuelist

[green/Alt/Option] S Save changes to open Cuelist

[yellow/Ctrl/Command]  M Marks Cue / MIB (in an open Cuelist edit)

[yellow/Ctrl/Command] B Blocks Cue (in an open Cuelist edit)

[yellow/Ctrl/Command + Shift] B Superblocks Cue (in an open Cuelist edit)

[yellow/Ctrl/Command] U Opens update window

[yellow/Ctrl/Command] J Opens Jump window

[yellow/Ctrl/Command] H Turns on highlight

[yellow/Ctrl/Command + Shift] H Turns on Solo

Spacebar

[yellow/Ctrl/Command] Spacebar 

[red/Shift] Spacebar

Cntrl/CMD + ALT + Spacebar

Note that the option “Spacebar acts as
Play on open Cuelist” must be enabled in
User Preferences

Acts as play on Default/Editor Cuelist

Acts as Pause/Play backwards on
Default/Editor Cuelist 

Acts as Release on Default/Editor Cuelist

Acts as a skip backwards on Default/Editor
Cuelist

[shift] left arrow Skip to start of the Default/Editor Cuelist
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Pressing / doing this... Does this...

[shift] right arrow Skip to end of the Default/Editor Cuelist

[yellow/Ctrl/Command] left arrow Skip backward in the Default/Editor Cuelist

[yellow/Ctrl/Command] right arrow Skip forward in the Default/Editor Cuelist

[yellow/Ctrl/Command] K Release all

[yellow/Ctrl/Command] [green/Alt/Option] C Clear

[green/Alt/Option] [red/Shift] S Stealth

[yellow/Ctrl/Command] [red/Shift] I Insert Cue before selected (in an open
Cuelist edit)

[yellow/Ctrl/Command] [green/Alt/Option] I Insert Cue at Playhead (in an open Cuelist
edit)

[yellow/Ctrl/Command] I Insert Cue after selected (in an open
Cuelist edit)

[yellow/Ctrl/Command] [green/Alt/Option] F Puts application in/out of full-screen mode
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Appendix 1: Menu & Toolbar Reference

The menu set is briefly described here. Refer to the relevant sections of the manual for full
explanations of the features. Keyboard shortcuts are displayed below the menu item name
when relevant.

File Menu

This option… does this…

New Show Creates a new show file, opening the Patch
window.

Open Show Opens an existing Show file.

Save Show
([yellow/Ctrl/Command] S)

Saves the current show.

Save Show As

([yellow/Ctrl/Command]
[red/Shift] S)

Saves the current show with a new name.

Save a Copy As

([yellow/Ctrl/Command]
[green/Alt/Option] S)

Saves the current show with a new name, but
continues to edit the original Showfile instead of the
new copy.

Export Show Summary Opens the Export window where you can export a
CSV of your Cuelists as they would be shown in the
Playback Window. Fixture intensity levels on a per-
cue basis can also be seen.

Tracking Backup Opens the Tracking Backup window where you can
setup connections with other Vista consoles for
tracking backup. (See “Appendix 3 – Tracking
Backup” for more information.)

Merge Merge components from another Showfile into this
Showfile.

User Preferences Opens the system User Preferences window
where you can configure preferences for naming
formats, patching, console hardware
characteristics, serial and MIDI inputs and
playback.
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This option… does this…

Timecode Opens the Timecode properties window where you
can enable or disable timecode and set the
timecode source, frame rate and offset.

Lock:

Lock entire console Prevents any operation of the console.

Disable editing Only allows playback.

Disable merging Prevents the merging in of data from other
Showfiles.

Disable saving Prevents the saving of a Showfile.

Control panel (consoles
only)

Opens the system properties window where you
can calibrate the screens; and configure displays,
local area network and date settings if you are
using Console Mode.

Quit Application Close Vista application and exit. The user will be
prompted to save any modified Cuelists, and to
save the Showfile if modified.

Edit Menu

This option… does this…

Undo …

([yellow/Ctrl/Command] Z)

Cancels your last action.

Redo 

([yellow/Ctrl/Command] Y)

Repeats your last action.

Cut 

([yellow/Ctrl/Command] X)

Cuts the selected objects.

Copy 

([yellow/Ctrl/Command] C)

Copies the selected objects.

Paste 

([yellow/Ctrl/Command] V)

Pastes the selected objects.

Paste Special

([yellow/Ctrl/Command]
[red/Shift] V)

Opens the Paste Special window so you can
choose which features of the objects you copied to
paste.

Remove Cue Alias Removes the alias link from the selected Cue.

Cut Cue(s)

([yellow/Ctrl/Command]
[red/Shift] X)

Cuts the selected Cues.

Copy Cue(s) Copies the selected Cues.



Appendix 1: Menu & Toolbar Reference 285

This option… does this…

([yellow/Ctrl/Command]
[red/Shift] C)

Delete 

(Del)

Removes the selected event(s) from the timeline.

Live Properties Displays the Properties window so you can make
adjustments to the Priority and Stop Effects mode
of the Live tab.

Cuelist Properties Displays the Properties window so you can adjust
the selected Cuelist.

Cue Properties Displays the Properties window so you can adjust
the selected Cue.

Highlight Opens a submenu where you can select options
to edit, update, or reset the Highlight settings.

Lowlight Opens a submenu where you can select options
to edit, update, or reset the Lowlight settings.

Home Opens a submenu where you can select options
to edit, update, or reset the Home preset.

Components Menu

This option… does this…

New Cuelist Opens a new empty Cuelist. Switches to the
Fixture Chooser screen if the Fixture Chooser or
Timeline screen is not the active screen.

Edit Cuelist Opens the Select Cuelist window where you can
open an existing Cuelist for editing.

Close Cuelist
([yellow/Ctrl/Command] W)

Closes the Cuelist currently open in the Editor.

Save changes to Cuelist.
([yellow/Ctrl/Command] S)

Saves all changes made to the Cuelist currently
open in the Editor.

Discard changes to Cuelist Removes all changes made since the Cuelist was
opened or Save Changes was selected.

Duplicate Cuelist Opens the Copy Cuelist As window where you can
save a copy of the selected Cuelist with a new
name and number (ID).

New Preset Opens the Create New Preset window where you
can save a preset.

New Extract Opens the Create Extract window where you can
save an extract.

New Snapshot Opens the Create Snapshot window where you
can save a snapshot.
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This option… does this…

New Effect Opens the Create Effect window where you can
create an effect.

New Fixture Group Opens the Create Group window where you can
save a group of fixtures.

Tools Menu

This option… does this…

Cue only editing Turns on a mode where changes made in the Cue
being edited will be undone in the subsequent Cue,
if it exists.

Mark Cue (Move in Black)

([yellow/Ctrl/Command] M)

Opens the Move in Black window. This enables
you to cause non-Intensity events to occur in a
previous Cue when the fixture is at 0 intensity so
that the changes cannot be seen while they are
occurring.

Insert Command Opens the Insert Command window. This lets you
add commands in the Cuelist’s timeline to activate
other Cuelists or perform other actions.

Edit Command Opens the Insert Command window to allow
editing to the selected command.

Date & Time events Opens the Date and Time Events window where
you can configure actions, such as playing a
Cuelist, based on the date and time.

Block Cue

([yellow/Ctrl/Command] B)

Copies all tracked information to the current Cue
and automatically adds release events for other
feature types in this Cuelist. Refer to “Chapter 9:

Working with Cuelists” for more information.

Unblock Cue Removes all events added caused by Blocking a
Cue. Refer to “Chapter 9: Working with Cuelists”

for more information.

Superblock Cue 

([yellow/Ctrl/Command]
[red/Shift] B)

Copies all tracked information to the current Cue
and adds release events for other feature types.
When a superblocked Cue is run any other Cues
being playing that would affect the look of this Cue
are released. Refer to “Chapter 9: Working with
Cuelists” for more information.

Store All Opens the Store All window where the output of
Vista can be saved as a Cue.

Store Part Opens the Store Part window where a new Cue
can be saved with options for tracking, blocking,

and more.
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This option… does this…

Update 

([yellow/Ctrl/Command] U)

Opens the Update Dialog window where the
contents of the Programmer can be used to
update a Cue or preset.

Clear Opens a submenu with options to clear all events,

or events by feature type, from the selected Cue or

the Editor’s Live tab.

Release Opens a submenu with options to create a release
event in the current Cue (if editing a Cuelist), or in
the Programmer if in the Live tab, for all events, or

events by feature type.

Clear / Close Clears the Live tab or closes the selected Cuelist
tab. If the Cuelist has unsaved changes, Vista
opens the Save Cuelist Changes window where
any changes can be committed or discarded.

Clear selected Clears all events from the selected fixtures.

Home selected Inserts events to send all features of the selected
fixtures to their home values.

Remove selected Opens the Remove Programming from Cuelist
window where you can remove events for the
selected fixtures from the entire Cuelist.

Cues Opens the Cues submenu with commands to:

Append a new Cue at the end of the Cuelist.

([yellow/Ctrl/Command]
[red/Shift]  I)

Insert a new Cue before the selected Cue.

([blue/Ctrl+Alt/Control] I) Insert a new Cue at the playhead position.

([yellow/Ctrl/Command]  I) Insert a new Cue after the selected Cue.

Delete the selected Cue(s).

Merge the selected Cues.

Renumber the selected Cue(s).

([yellow/Ctrl/Command]
Left arrow)

Select the Previous Cue.

([yellow/Ctrl/Command]
Right arrow)

Select the Next Cue.

Edit the follow mode of the current Cue.

Adjust the timing of the selected Cues.

Select Audio to play in the selected Cue.

Fan mode Opens a submenu where you can set the fan
mode for fixture selections.

Jump 

([yellow/Ctrl/Command] J)

Opens the Jump window to jump to a different cue
in the Default Cuelist.



Vista User's Guide, Version 3.3288

This option… does this…

Highlight 

([yellow/Ctrl/Command] H)

Turns highlight on or off. When on the selected
fixture(s) are set to the values stored in the
highlight preset (normally 100% intensity, open
white).

Solo

([yellow/Ctrl/Command]
[red/Shift] H)

Turns solo on or off. When on only the selected
fixtures will be visible at their programmed values.
All other fixtures will go to 0% intensity.

Solo and Highlight can be used together to achieve
Solo Highlight

Stop Effects Opens a submenu where you can stop All effects
or effects by feature type that are running on the
selected fixtures.

SmartFX editor 

([yellow/Ctrl/Command] K)

Opens the SmartFX panel in the sidebar where
you can create a new effect or edit a running
effect.

Stealth Holds all output from the Editor in its current state,
which allows you to visually program a new look
with a number of different changes in blind, and
then execute it over the live timing when Stealth is
deactivated.

Release All Releases all active Cuelists.

Arm Timecode Cuelists Sets all Cuelists, that include timecode Cues, to
listen for incoming timecode.

Remove redundant Cuelist
events

Removes events that don’t make any changes to
the tracked state of the Cuelist.

Learn timing Opens the Learn Timing window where you can
set Cue timecode values by playing the Cuelist, in
the Editor, and hitting the Go button at the time you
want the Cue to start.

Set Cuelist Timecode Opens the Cuelist Start Timecode window where
you can edit the Start Timecode or a set an offset.

Clean up show Removes orphaned programming.

MIDI Show Control Enables or disables MIDI Show Control (MSC).

Patch Menu

This option… does this…

Delete fixtures Removes the selected fixtures from the patch.

Label fixtures Opens the Rename window where you can enter
a custom name for the selected fixture(s).
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This option… does this…

Renumber fixtures Opens the Renumber window where you can
change the ID number for the selected fixture(s).
The number must not be in use already.

Multi-patch fixtures Creates a copy of the selected fixture, with the
same ID and places it in the pool. The new fixture
can then be dragged to an available address on
one of the universe tabs. Multi patching lets you
treat 2 or more fixtures as one.

Label Universe Edit the label of the selected DMX Universe.

Customize Gobo and Color
Wheels

Lets you change the color wheel colors and Gobo
wheel patterns for the selected fixtures.

Customize fixture
arrangement

Lets you customize the arrangement of elements
within a multi-element fixture.

Change Fixture type Opens the Change Fixture type window where you
can change a fixture to a different type while
maintaining its programming.

Change Fixture type (All of
selected type)

Opens the Change Fixture type window where you
can change all fixtures of the selected type to a
different type.

Clone Fixtures Makes a copy of the selected fixtures and their
programming and places it in the Fixture pool at
the bottom of the Patch window.

Extract selected fixtures to
user library

Creates a copy of the selected fixtures’ profiles in
the User library.

Fixture Editor Opens the Fixture Editor where you can create a
new fixture file or edit an existing one. (Refer to
“Appendix 9 – The Fixture” for more information.)

Import Patch file Opens the Import Patch file window where you
can select a suitably formatted (.csv) patch file to
import. This will overwrite the current patch.

Export Patch file Export a CSV file of the Patch information.

Import Fixture Profiles Import a new fixture profile.

Export Fixture Profiles Lets you pick a custom fixture profile to export to a
fixture profile file.

Import Media Server
thumbnails.

Open the CITP window where you can select a
media server which supports CITP and import
copies of the fixture’s media thumbnails.

Check for updated fixture
profiles

Checks the fixture library for newer versions of all
patched fixtures.

Use default media Used to reset fixtures to use their default colors,
gobos and media.
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This option… does this…

Connect Universes Opens the Connect Universes window where you
can connect Vista universes to DMX outputs (for
consoles); sACN, Artnet, and Pathport devices;
and the Chroma-Q UD512 USB to DMX cable.

Lamp on Sends a lamp on command to the selected
fixtures.

Lamp off Sends a lamp off command to the selected
fixtures.

Reset Sends a reset command to the selected fixtures.

Park Fixtures Holds the fixture in its current settings.

For example, to provide fixed lighting for

backstage, or set a minimal level of house lighting.
Once you’ve parked a fixture it may still be
programmed, however its output will ignore all
instructions until it is un-parked. Parked levels will

not get programmed into Cues.

Unpark Fixtures Sets a parked fixture to operate normally.

Console Menu

This option… does this…

Assign Custom Encoders Opens a window where you can assign features to
the encoders and save custom pages.

Rescan for USB devices Scans the USB bus for Vista USB devices – EX,
MV, S3, S1, M1, E2, or UD512

Add Console Opens a sub-menu for adding a specific
console/console type to the Console window.
These windows can be dragged outside the main
window.

Chooser Menu

This option… does this…

Select All Fixtures Selects all fixtures on the current Fixture Chooser
tab.

Deselect All Fixtures Deselects all fixtures across fixture chooser tabs.

Invert Selection Deselects all selected fixtures and selects all other
fixtures on the current layout.

Select Active Selects all fixtures whose intensity is above 0%.

Select Programmed Selects all fixtures that have active programming
on the current layout.
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This option… does this…

Previous Selection Deselects the selected fixtures and selects the
fixtures that were previously selected.

Next Selection If the Previous Selection function has been used,
this will return you to the next selection.

Previous Fixture Selects the previous fixture.

Next Fixture Selects the next fixture.

Selection Tool Displays a submenu to select the Rubberband,
Lasso, or Dragover selection tool.

Colors and Background Displays a submenu to customize the appearance
of the Fixture Chooser screen and icons. Refer to
“Chapter 6: The Fixture Chooser Screen” for more
information.

Shrink to Fit Zooms the layout to fit the available window space.

Label Position Displays a submenu where you can set the label
position, for the selected fixture(s) to the top,
bottom, left or right.

Manage Layouts Opens the Layouts window where you can
customize the current layout. Refer to “Chapter 6:
The Fixture Chooser Screen” for more information.

Duplicate Layout Create a copy of the current layout with a new
name.

Layout Options Displays a submenu where you can choose
display options that apply to all layouts:

Show Selection Order

Show Grid

Snap to Grid

Show Intensity Value

Show Names

Show IDs

Auto Add New Fixtures

Preview Refresh Rate

Detail Level

Timeline Menu

This option… does this…

Show tracked events Shows or hides features that are tracking through
from previous Cues. Tracked events are shown as
lighter bars that cannot be selected.

Align start Aligns the start points of the selected events.

Align end Aligns the end points of the selected events.
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This option… does this…

Set Event Timing Opens the Event Timing window where you can
edit the timing information for the selected event.

Reset to default timing Resets the selected event(s) so that it follows the
default timing for its feature type.

Fade Curve Sets the fade type for the selected event(s).

Convert to Release Event Converts the selected event so that it releases the
control of the feature.

Untrack events (Cue only) Undo the effect of the selected events in the
following Cue.

Stop Free Effects Opens a submenu where you can choose to stop
or not stop free events for the same feature type.

Mute Events Opens a submenu where you can mute or unmute
an event. Muting an event prevents the selected
event(s) from being played back. The event bar will
be greyed and when the Cue is played the event
will be ignored.

Ignore Move in Black Opens a submenu where you can set the selected
fixtures / events(s) to ignore Move in Black or not
ignore Move in Black.

Don’t Ignore Move in Black Removes the ignore Move in Black setting.

Grid

Snap to Grid Sets events to snap to the timeline gridlines.

Grid Size Sets the gridline increments. The default is Auto.

Grid Origin Sets how the timeline ruler shows timing:

Start of Cue, shows 0s at the start of each Cue.

Start of Cuelist, shows a single continuous
timeline.

Current Position, sets the 0s position to the
current position of the playhead.

Timecode, shows timecode values
(HH:MM:SS:Fs).

View Menu

This option… does this…

Show full screen

([blue/Ctrl+Alt/Control] F)

Toggles full-screen mode.

Sidebar Displays a submenu with options to set which
Sidebar tab is active:

(Ctrl + 1) Features

(Ctrl + 2) Components
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This option… does this…

(Ctrl + 3) SmartFX

Command Line

(~)

Shows or hides the Command Line window at the
bottom of the Fixture Chooser & Timeline screens.

Increase Font Size

([yellow/Ctrl/Command] +
[+])

Increase the font size in the current window.

Decrease Font Size

([yellow/Ctrl/Command] +
[-])

Decrease the font size in the current window.

Window Themes Opens Vista Themes window where you can
customize the color of window elements or load
one of the alternate themes.

Console Softkey Labels Shows the F1 – F12 softkey labels at the top of the
screen, intended for Vista Consoles.

External Window 1 - 2 Opens a touch-screen-friendly window with

options to display a variety of window types.

Table view Switches the Patch window to the (default) table
view.

List view Switches the Patch window to the list view.

DMX view Switches the Patch window to the DMX view.

Patch

([blue/Ctrl+Alt/Control] 1)

Switches to the Patch window

Console

([blue/Ctrl+Alt/Control] 2)

Switches to the Console window

Chooser

([blue/Ctrl+Alt/Control] 3)

Switches to the Chooser window

Timeline

([blue/Ctrl+Alt/Control] 4)

Switches to the Timeline window.

Playback

([blue/Ctrl+Alt/Control] 5)

Switches to the Playback window.

User Configurable Window

([blue/Ctrl+Alt/Control] 6)

Switches to the User Configurable window.

Add Dockable window Displays a submenu where you can select a
window to open initially in an undocked
configuration. Refer to “Chapter 17: The User
Configurable, External, and Dockable Windows”
for more information.

Lock All Dockable Windows Locks all dockable window to prevent them from
being reconfigured.

Unlock All Dockable
Windows

Unlocks all dockable windows.



Vista User's Guide, Version 3.3294

This option… does this…

Recover Dockable
Windows

Re-opens any dockable windows that have been
moved off-screen.

Toolbars Displays a submenu to show or hide optional
toolbars. The available toolbars depend on the

current window.

Playback Window Only

Active Cuelists Only Only show Cuelists that are being played back.

Follow on Go Automatically view the last played Cuelist.

Follow on Select Automatically view the Cuelist selected to be the
Default Cuelist.

Search Cuelists Opens a search box so you can find a Cuelist by
name.

Auto Scroll Automatically scrolls the list of Cues so that the
Cue being played is always visible.

Draggable Playhead Allows the ”position” bar to be dragged to play the
Cuelist.

Search Cues Opens a search box so you can find a Cue by
name.

Help Menu

This option… does this…

About Vista Displays information about your system including:

Vista version and build number.

Build date.

Available DMX channels.

The Fixture Library version number.

Host ID.

The path to your User Data directory.

Revision History Displays information on the versions of Vista that have
edited the open Showfile.

Export logs… Opens a window where you can save diagnostic and
error log files. Always save and attach this file when
opening a support request.

Add Message to Log Allows you to add a text message to the log. This can
be used to annotate the log file with information about a
software issue at the time it occurs.
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Appendix 2: Tracking Backup

With Vista’s tracking backup feature, you can connect a computer running the Vista

application, or a second Vista console, and have it synchronize its show file and settings with

your primary Vista system. The backup system automatically copies the show programming

from the primary system, keeping the information in sync in real time. If the primary system
fails for any reason, the backup system will automatically take control.

Setting Up a Tracking Backup
To set up a tracking backup, the Vista systems must be physically connected via their

Ethernet ports and their network settings must be configured correctly.

Connecting the Backup Vista System
To connect the Primary and Backup Vista systems you can either:

· Connect the Vista systems using an Ethernet cable.

· Connect the Ethernet port of the Vista systems to a stand-alone Ethernet switch.

· Connect the Ethernet port of the Vista systems to the Local Area Network (LAN) in

your building. Note, however, that it is recommended that your Vista control system
runs on its own network.

Configuring the Network Settings
All consoles or computers being used in a tracking backup system need an IP address on the
same subnet as the others. If you are using a LAN with a DHCP server, it can automatically
assign IP addresses, provided your Vista system’s network interface is set to use DHCP. If
you are using a stand-alone switch or direct Ethernet connection between the systems, you’ll

need to set static IP addresses on all the Vista devices in your lighting rig.

Vista Console Network Settings

To configure the network on a Vista console or computer running in Console mode:

1. Select the File->User Preferences. Vista opens the User Preferences window.
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2. Click the Network tab; the section we’re working with here is the Network Settings
section:

This field… does this…

Hostname This displays the network name of the console.

IP Address Set this field to DHCP if you are connecting to a LAN that has
a DHCP server.

If there is no DHCP server, set this field to a unique private IP

address. For example, 10.0.0.1.

Your backup system must be set to a different address in the
same range. For example, 10.0.0.2.

Subnet Mask Normally this field should be set to 255.0.0.0. If connecting to

a network that has a DHPC server, this will be assigned
automatically. 

Some existing networks will require you to be on a closed or
more limited subnet (255.255.255.0). Users should seek the
direction of their network administrator if unsure.

Default gateway If you are using a DHCP server this field will be set
automatically.

If you are connecting with a switch or crossover cable, or

there is no DHCP server, set this field to the same address

as the console.

3. Click OK to close the network window.

Computer Network Settings

Configuration of the network settings on your Vista computer will vary depending on the OS
you are using, but what you’ll need to enter is similar to the information detailed above. Refer

to the documentation for your operating system for details on how to change your network
settings. On a Windows system you can find the network adaptor setting in the Network and
Sharing Center part of the Control Panel. On a Mac it’s in the Network section of System
Preferences.
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The most important thing is that each console or computer should have a unique IP and be on
the same subnet. If you are using DHCP this will be taken care of automatically. If you are
using static Ips, make sure each IP address is unique. For example, if the primary Vista

system’s IP is 10.0.0.1, your backup device could be 10.0.0.2 (or any number between 1-254
except for 1).

If you have changed your network settings, restart the system and confirm that the new

settings have taken effect.

Starting the Tracking Backup
To start a Tracking Backup do this:

On the primary Vista system, select File->Tracking Backup. Vista opens the Tracking Backup
window:

Other Vista devices will appear here as they are detected on the network.

This field… does this…

Name Shows the name of Vista systems that are detected on the
local network. The system you are working on is indicated by
a * next to its name.

Group Indicates the Group each device belongs to. Only devices
that are in the same group can connect to each other.

Devices that are not in the same group or are running a
different software version are shown in red.

To change the name or group of any device, select the item in

the list and press Edit Configuration.

Type Shows the console model or device type.

Licensed
Channels

Shows the number of channels each device is licensed for. In
a tracking backup system, the number of available channels

is the sum of all connected devices.

Address Shows the IP address of each device.

Network Role Shows the role of each device.

Sync / Re-Sync Syncs or re-syncs the show file to all devices in the group.
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This field… does this…

Manual
Connections

Opens a window where you can enter an IP address for a
known device that doesn’t appear in the Network window.

Add to … Group Sets the selected device to the same group as the local
console and opens a window where you can sync the show.

Edit
Configuration

Open a window where you can set the name or group of any
device on the network.

Disconnect Disconnect the selected device from the current group. You
will be asked to assign it a different group name.

Failover Press this button to have the slave console take over the
show.

Configure each device that you want to use for tracking backup or distributed processing by
selecting the device and clicking the Add to Group button. When a device is added to an
existing group Vista opens the Tracking Backup window on the Master device:

1. On the Master click the Sync Now button to copy the show to the slave device or

No to cancel and sync later. If you are on the Slave console and don’t want to join
the detected group, click the Start a New Vista Network button, or the Quit button.

2. If you didn’t sync the show file to all group devices at step 1, use the Connect To

button to start the process.
3. Once all devices are configured, click the Close button.

Alternatively, once a Master is running on the network, if another Vista instance is started in
the same Vista group on another machine, the new instance of Vista will get this message:
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Simultaneously, the existing Master will get prompted to sync the show to the new instance of
Vista. When the Master is told to Sync, this window will close and the new instance of Vista
will become a tracking backup for the pre-existing Master Vista instance.

What Happens if the Master Fails
If the master or slave fails, an alert window appears on both consoles:

Master Slave

On the slave console there are two options:

· Click on the Abort button to prevent the slave console from taking over the show.

· Click on the Failover Now button to have the slave console take over the show.

If neither button is clicked, the slave will take over when the countdown is finished.

Note: If you are using networked DMX such as sACN or Art-Net, output will automatically be
transferred to the backup system. However, if you are using the DMX outputs on your Vista

console or console you must swap your DMX cables from the master to the backup console
in the event of a failure.
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Manually Switching to the Backup Console

To manually switch to the slave device, click on the Failover Now button in the Tracking

Backup window.

Licensed Channel Count on Failover

Your slave system does not need to have the same licensed channel count as the master for
tracking backup to support your show fully. Should the master fail, as long as the machine
that continues to operate (now as the master) has at least half as many channels on its
dongle as the other now-offline machine, it will continue to include all of the offline machine's
channels. This lasts until the Vista application is exited.

If the remaining online machine has less than the number of channels given above, it will fall
back to only having access to the channels on its own dongle; this will result in the
occasionally blackouts that use of unlicensed channels causes.

Distributed Processing

Another advantage to utilizing tracking backup is that Vista will distribute the processing of
Ethernet-based DMX universes (sACN and Art-Net) between the Master and Slave, evening
out the workload between the two machines. This can provide better performance in shows
with large numbers of universes being utilized. In addition to the Slave console, there can be
other additional consoles connected and synchronized to further distribute the processing
across machines.

The assignment of universes is determined by Vista; there are no user options available to
specify which universe is processed by which machine.

Troubleshooting
If you cannot see your slave console in Vista Network window:

1. Check all your Ethernet cables and connections.
2. If you are using a computer turn off any firewall or port blocking.
3. Check that the Group name is exactly the same on all devices in your backup

system.
4. Check that both the master and slave have IP addresses that are on the same

subnet.
5. Try adding the slave console’s IP address in the manual connections window.
6. On your Vista console you can check the IP by opening File->User Preferences and

selecting the Network tab.
7. On a Windows system you can find the IP address in Control panel > Network and

Sharing Center. On a Mac it’s in System Preferences > Network. In Vista, ensure
the correct network adaptor you have configured is chosen in the Network tab
under File->User Preferences.

8. Check that the broadcast address (on the network tab of user preferences) is
suitable for the network and the same on both the master and slave.
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9. On a Mac or Windows PC make sure that only one Network Interface is active.
Having both the wired and wireless interfaces active may cause tracking backup to
fail.

10.Check that you can Ping from the Master to the Slave and vice versa. Information
on sending a ping request from one computer to another can be found online and
will depend on your operating system.

11.Power down and re-start the Vista systems you are using.



Vista User's Guide, Version 3.3302

Appendix 3: Using MIDI Show Control

You can activate and control Cues by sending MIDI Show Control (MSC) messages via:

1. the MIDI in port on Vista L-series or Vista I-series consoles.

2. a USB-to-MIDI cable or MIDI interface card connected to a Mac or Windows

system.

3. a Mac or Windows network MIDI port.

Configuring the MIDI Port
Before you use MIDI you have to set a MIDI Device ID that Vista will listen on. This should
correspond to the ID the MIDI controller is sending on. To set the device ID, refer to the MIDI

section on User Preferences in Chapter 2: Getting Started.

MSC Lighting Messages
MIDI controllers use standard terminology for lighting Cues and Cuelists:

This MSC term is equivalent to this Vista component…

Q_number Cue Number

Short <Q_list> Cuelist Number

<Q_path> Not used

Vista supports all the most commonly used MSC lighting messages:

This message… does this…

Go If a Q_number is specified, that Cue plays. If no
Q_number is specified, the next Cue in numerical order
will play.

Go_Jam Starts a transition or fade to a Cue simultaneous with
forcing Vista’s internal timecode clock to the specified Go
Time if the Cue is a Timecode Cue. If no Cue Number is
specified, the next Cue in numerical sequence plays and
the clock of the appropriate Cue List jams to that Cue's
time. If the next Cue in numerical sequence is a Manual
Cue (i.e., if it has not been stored with a particular Go

Time, the Go/Jam_Clock command is ignored.

Go_Off Releases the Cuelist.
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This message… does this…

Timed_Go Starts a timed fade to a Cue. If no Cue Number is
specified, the next Cue in numerical sequence plays.
Time is in the MSC standard time specification with
subframes, providing anything from instant to 24 hour
transitions.

Stop Halts currently running transition(s). If no Cue Number is
specified, all running transitions STOP. If a Cue Number is
specified, only that single, specific transition STOPs,
leaving all others unchanged.

Resume Causes Stopped transition(s) to continue running. If no
Cue Number is specified, all Stopped transitions Resume.
If a Cue Number is specified, only that transition
Resumes, leaving all others unchanged.

All_Off Turns all Cuelist intensity output to 0% without changing
any other features. Equivalent to fading the Grand Master
to 0%.

The console status prior to All_Off can be re-established
by using the Restore command. Equivalent to fading the
Grand Master to 0%

Restore Re-establishes operating status to exactly as it was prior
to ALL_OFF.

Reset Releases all running Cues.

MIDI Control Options
You can send a message (for example Go) to several Cuelists at once. To do this you first
send an Open message to each of the Cuelists. Vista supports the MSC messages to open
and close Cuelists.

This message… does this…

Open_Cuelist Makes a Cuelist available to all other commands and
includes any Cues it may contain in the current show.

When OPEN_CUE_LIST is received, the specified Cue
List becomes active and Cues in it can be accessed by
normal show requirements. Q_list in Standard Form must
be sent.

If the specified Cuelist is already open, or if it does not

exist, no change occurs.

Close_Cuelist Makes a Cuelist unavailable to all other commands and
excludes any Cues it may contain from the current show.

When CLOSE_CUE_LIST is received, the specified
Cuelist becomes inactive and Cues in it cannot be
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This message… does this…

accessed by normal show requirements, but the status of
the Cues in the list does not change.

If the specified Cuelist is already Closed or if it does not
exist, no change occurs.

MIDI Timecode Options
You can also control Vista’s internal timecode clock with MIDI commands.

This message… does this…

Start_Clock Starts Vista’s internal timecode clock. If the clock is
already running, no change occurs. If the clock is paused
it continues counting from the time value which it
contained while it was paused.

Stop_Clock Stops Vista’s internal timecode clock. If the clock is
already stopped, no change occurs. While the clock is
stopped, it retains the time value which it contained at the
instant it received the STOP command.

Zero_Clock Resets the internal clock. 

Set_Clock Sets internal clock to the specified time in the MSC
command.

Activating Snapshots with MIDI
Vista Snapshots can be activated with the MSC Fire command.

This message… does this…

Fire Activates the specified Snapshot.

The Fire command Macro number activates the
corresponding Snapshot ID number.

Unsupported MSC Commands

Vista does not support the following MSC commands:

· Close_Q_Path

· Load

· Open_Q_Path

· Sequence_Minus

· Sequence_Plus

· Set

· Standby_Minus
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· Standby_Plus
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Appendix 4: Using Serial Communication to

Control Cuelists

You can activate and control Cues by sending text commands via the serial port on a Vista
System. Mac users will need a USB to Serial converter, such as the Keyspan 19H, to receive
serial commands.

Connecting to the Serial Port
The cable that connects from the triggering device to Vista should be a standard serial cable
(also called a null-modem cable, or serial printer cable), not a serial cable extension. The
important feature is that pin 2 at one end needs to be connected to pin 3 at the other end, and

vice-versa.

Enabling the Serial Port
The computer or other device sending the commands and Vista must have their serial ports
set to match each other. To set Vista serial port select File->User preferences  and click on
the Serial tab. Please see the Serial section of Chapter 2: Getting Started for more
information on adjusting the serial port settings.

Playback Commands

All commands should be sent to Vista as single lines of text followed by Return or Enter.

With serial commands you can only play the next Cue in a Cuelist. It is not possible to play a
play a Cue out of order.

The syntax for sending commands is:

Command Cuelist, where Cuelist can be one of:

· Cuelist ID

· Name 

· ID:Name

The supported commands to playback and load shows are:

This command… does this…

Go Cuelist Plays the next Cue in the Cuelist. Examples: Go 1, or
Go Dimmers, or Go 1:Dimmers
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This command… does this…

Pause Cuelist Halts playback of the specified Cuelist. Example:
Pause 5

Rego Cuelist Resumes play of a paused Cuelist. Example: Rego 5

Release Releases playback of the specified Cuelist. Example:
Release 1

Load Show_Filename Loads a show file. The full path to the Showfile must
be specified. Example:

Load C:\Shows\MyShow.v3s

Setting Fixture Levels
You can also send commands to set Fixture levels in the Editor. The Syntax is:

{fixture id(s)} @ {level}

Where the fixture id is any combination of number, +, > (for “through”), and minus, and level is

a value between 0 and 100 or just f (or F) for full.

Examples:

To do: Send this:

Set Fixture 1 to full 1@F

Set fixtures 1 thru 10 except 5 to 75% 1>10-5@75

Set fixtures 1, 2, 8, 9, and 10 to 100% 1>10-3>7@F

Serial Command Acknowledgements
Vista does not echo characters sent to the serial port but does send acknowledgements to
confirm that commands have been received and either been accepted or have failed. There
are three response types:

Commands that are Understood and Could Be Executed.
Successful commands return the complete command appended with “OK”. For example, “go
1:List” would return “go List:1 OK”.

Commands that are Understood but Could Not Be Executed.
If the command is good but the object of that command is not known an error message will
be returned. For example, if there was no Cuelist 100, “go 100” would return “100 Unknown”.

Invalid Commands
If the command is not understood, the message “ILLEGAL COMMAND” is returned.
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General Notes

· Make sure that there is an end of line character (return or enter) at the end of each

command.

· Commands and Cuelist names are *not* case sensitive.

· Spaces before or after commands and Cuelist names do not affect the behavior.
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Appendix 5: The Fixture Editor

The Fixture Type Library Editor is a separate application to the Vista software. On a Windows
installation it can be found as an alias on the desktop and can be launched like any other
Windows program. For systems running in Console Mode, it is launched by selecting Patch-

>Fixture Editor.

When launched, a window is presented with
an expanded directory of all fixtures, listed
in manufacturer sub-directories, within the
factory default directory. Once this directory
is collapsed, another directory is visible—
this is the User Fixture Library and will
initially be empty.
Fixtures in the Factory directory cannot be
modified, however, copies can be made
and these will be placed in the User Fixture
Library and are fully editable.

It is recommended that the latest software
library be installed and an exhaustive
search of the fixture library be carried out to
determine if the fixture required is not
already in the library before writing your own
fixture profiles.

Note that a profile for a new fixture that does
not already exist in the Fixture Library can
be requested from the Support menu at
www.vistabychromaq.com. This is the

preferred route to take. It may take up to ten
days for the new fixture profile to be
delivered to you, however, so the Fixture
Editor is a handy tool for creating your own
if you can’t wait. 

Creating a Fixture Profile
For this tutorial, collapse the Factory directory and select the User Fixture Library, and select
Fixture->New Fixture.

A new, blank fixture window will open with five tabs across the top:

http://www.vistabychromaq.com
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This tab… is for…

Main entering general fixture data.

DMX Chart All DMX channel assignments and channel range values are
entered in this tab

DMX Macros Control macros, including lamp on, lamp off, and reset are
entered here.

Notes Personal notes relating to the fixture profile can be entered
here.

History A chronological history of the fixture profile can be kept here.
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Main Tab

This window is used to enter general information values for your fixture. To add or edit a value,

double-click in the field and either type directly in the field or select from the field’s popup

menu.

This field… is for…

Manufacturer The name of the company that makes the fixture.

Full Name The complete, unabbreviated name as supplied by the
manufacturer.

Short Name An abbreviated name, of your choice, for the Fixture.
This name will be used in the Fixture Chooser window
when Show Short Name is selected.

Fixture Status Choose from the popup menu to select the
appropriate status of the fixture file.

Beam Type Choose from the popup menu to select the
appropriate beam type of the fixture.
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This field… is for…

Frame Type Choose from the popup menu to select the
appropriate frame type; choose No Frame if the fixture
has no framing mechanism.

Movement Type Choose from the popup menu to select the
appropriate movement type.

Physical Type Choose from the popup menu to select the
appropriate physical type.

Light Generation Choose from the popup menu to select the
appropriate light source.

Maximum Pan Degrees Enter the maximum pan degrees as supplied by the
manufacturer. This value is required in order for the
flip function to work correctly. This information is
generally not found in the DMX charts for a fixture, but,
is usually found in the manufacturer’s specification
sheet.

Maximum Tilt Degrees Enter the maximum tilt degrees as supplied by the
manufacturer. This value is required in order for the
flip function to work correctly. This information is
generally not found in the DMX charts for a fixture, but,
is usually found in the manufacturer’s specification
sheet.

Element Count
Horizontally

Enter the number of horizontal, individually
controllable elements within the fixture. Used for
single fixtures with multiple elements such as LED
fixtures with multiple cells.

Element Count
Vertically

Enter the number of vertical, individually controllable
elements within the fixture. Used for single fixtures
with multiple elements such as LED fixtures.

Is a Scroller Defines whether the fixture is a scroller mechanism.

Patch Part Count Determines how many patchable parts there are for
the fixture. i.e. a par with a color scoller will have two
parts. One for the par and another for the scroller.

UUID This is a unique identifying number assigned to the
fixture by the fixture editor and cannot be changed.

Compatibility ID This number is for advanced use. When an existing
Factory fixture is duplicated and modified it will retain
programmed features of the original (such as Preset
information etc.) so long as this number is not altered.
Once altered the fixture will become an independent
fixture and lose those programmed features.

Revision A revision number can be added here to keep track of
multiple versions of the same fixture.

Factory Version This is a factory library version tracking number.
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This field… is for…

Carallon Version This version number is supplied by the Carallon
database and is not relevant when writing fixture
profiles.

DMX Chart Tab
Most of the work to define a new fixture profile will take place in the DMX Chart tab. This is
where you specify all the DMX channels, their ranges, and what types of features they control.

This icon… does this…

Opens the Add DMX Channel window

Adds a DMX range to an existing channel. This button remains
disabled until a channel is created.

Adds a Custom Mode to a channel, used when a feature range
is not mappable to a generic control. i.e. Iris Pulse or Gobo
Shake

Adds a slot to a color or gobo wheel channel. This button
remains disabled until a channel is created.

Use this button to delete selected DMX channels, ranges,
modes, or slots.

Add DMX Channel Window
To add a DMX channel to your fixture profile, click the Add DMX Channel button. The Add DMX
Channel window appears:
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This field… is for…

Feature Class This determines which control panel the feature will
reside in. Intensity Class reside in the Intensity panel,
Beam in the Beam panel, etc….

Feature Type This determines which controls on the panel will
control which feature. For example, one Beam Type

may be Iris and another Zoom. Both features appear
on the Beam control panel, mapped to their
respective controls.

Feature Name This value is automatically set by the software
unless a custom feature is created. In this case, a

user-assigned name must be supplied.

DMX Channel – Type This will determine if the feature is 8 bit or 16 bit. The
Fine channel field becomes active if 16 bit is
selected here.

DMX Channel – Channel Is the high byte (or only byte) channel for the feature.

DMX Channel – Fine
Channel

Is the low byte channel for the feature (if applicable)

DMX Channel – Default
Value

This is the default DMX value for home and clear. 

Note: the Default Value field, for a 16-bit channel, can be either a full 16-bit value (ranging from
0 to 65535), or can by just the high-byte value (ranging from 0-255 as for an 8-bit channel). To
determine the entry mode for 16-bit channels, select View->Course Fine Channels As to

select which way you want to work with default values. For the example below, we are
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assuming that this is set to “Course”, which means we will use an 8-bit representation of just
the high byte to specify the defaults.

The DMX Chart window is used to enter all channel information for your fixture. Using the
manufacturers DMX specification sheets, all DMX channel information will be entered via this
window. Additionally, range mapping, slots for colors and gobos, mode settings for channels,

and any other information required to operate the fixture is entered here.

Creating a Fixture Profile: An Example
Using the sample DMX specification for a VL1100D (I) Iris Model fixture, this section will

document how to enter data in the DMX tab for it.

DMX channel specification for a VL1100D (I) Iris Model:

Adding Channel 1: Intensity
Click the DMX button to open the Add DMX Channel dialog. By default, the dialog opens for the

first time as below, it will open in the last opened state from then on. Notice the values happen
to already be correct for the fixture’s Intensity channel. Click OK to create this DMX channel
entry.
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The Intensity 8-bit channel 1 has been created in the DMX Chart window.

Adding Channel 2 and 3: Pan, a 16-bit Channel
Click the DMX button to open the Add DMX Channel dialog. Select Position for the Class
setting and Pan in the Type setting. In the DMX channel section, select 16 bit and assign the

correct channel numbers. The Default value should be set to 127 as it is a midpoint default
feature and the Hi Byte value only need be set. Click OK to create.
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The Pan 16-bit channels 2 and 3 have been created in the DMX Chart window.

Add Tilt, Edge, Zoom, and Diffusion
Similarly, create the Tilt, Edge, Zoom, and Diffusion channels using the Add DMX Channels
settings shown here:

Class [Feature]
Type

[DMX]
Type

Channel Fine
Channel

Default
Value

Tilt Position Tilt 16 bit 4 5 127

Edge Beam Focus Standard 6 N/A 127

Zoom Beam Zoom Standard 7 N/A 127

Diffusi
on

Beam Frost Standard 8 N/A 0

Note that some features such as Tilt, Edge, and Zoom, are normally set to their mid-point by
default. Sometimes the DMX chart for fixtures will tell you; most of the time you rely on your
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experience to guide you in what makes sense. And while the fixture documentation specifies
Diffusion as a channel, that maps to Frost in Vista’s vernacular.

Once you have created these channels, your Fixture window will look like this:

Add the CMY Color Mix Channels
Next we will add the three color mixing channels. This will be as easy as adding the Intensity
value. Use these values as you add the three channels:

Class [Feature]
Type

[DMX]
Type

Channel Fine
Channel

Default
Value

Blue Color Mix Cyan Standard 9 N/A 0

Amber Color Mix Yellow Standard 10 N/A 0

Magenta Color Mix Magenta Standard 11 N/A 0

After you add these three channels, the Fixture window will look like this:
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Add the Gobo Wheel
Gobo Wheels are a bit more work to add, as they can have several modes of operation, utilize
ranges of DMX values to control things like spin speed, and have images associated with
each slot. And when you add a Gobo wheel, you provide a wheel number, as fixtures can
have multiple gobo wheels.

First, add a Gobo Wheel class channel, of Type Gobo Wheel, and this is Gobo Wheel
Number 1. This is a standard 8-bit channel, and should be added at channel #12. The default
value is 0. After you add it, the DMX Chart will look like this:

Note that the Fixture Editor already adds the three typical modes for you already, which we
will expand upon next.

Wheel Modes

Index Mode: Expand this section and select the range value section as below.
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From the DMX chart for the fixture, we see that this channel’s indexing function ranges from
DMX values 0 through 127. Therefore, we need to edit these values for the Index Mode’s
range to match. Click on the Range line; on the right-hand side of the DMX Chart window the

DMX range information will appear. Make the change as seen below.

The change to the channel range is reflected in the DMX Range column.

Rotation Mode: Expand this section and you will see the default rotation rages values as

shown below:

As the specification requires the range for Gobo Wheel Rotation is to be 128-255, only one
range of values is required. By default, most fixtures have clockwise and counter-clockwise

values as well as a stop value. The editor places ranges for these by default. The mechanism
in our fixture only rotates in one direction so the first thing that is required is to delete the
Counterclockwise range. Select this range and press the Delete button at the top-right of the
Fixture window.

The Stopped range can remain and stay set to 127 if desired. This will make zero rotation on
the controls stop the wheel spinning at the last indexing value. 

As the ranges for Stopped and Clockwise rotation are the same as the manufacturers
specification no other changes are required. The ranges for gobo wheel rotation are now set:
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Wheel Slots

Expand the wheel slot section and Select it. Notice a single Open slot is loaded with a range
of 0,0:

Use the Add Slot  button to create as many slots as is required. In this case, add five

slots to make a total of six:

As the Open slot values are already correct, select Slot #2. On the right-hand side of the DMX

Chart window, controls are now available to add appropriate data for the selected slot:

A Name may be applied, a Slot Type can be set (for Color Wheel slots as well as for Gobo
slots), a Category can be assigned (Category is used in Vista to automatically determine a
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new gobo pattern when changing fixture types), and an image can be set for previewing the
gobo on the console.

The DMX Range section is used to set the values for which this gobo will be selected, as the
specification below (from the manufacture’s data sheet) indicates, different values are
required to operate the slot in either Indexing or Rotating modes.

Set the DMX Range values for Slot #2 as shown below, follow the same procedure for the
remaining slots. Vista will automatically output the correct value for Slot #2 (18 or 146)
depending on whether indexing or rotation is selected in the Vista Gobo controls.

Gobo Slot DMX Value for Index DMX Value for Rotate

0 0 128

1 18 146

2 41 169

3 63 191

4 86 214

5 108 236

Lastly, we should select an image for the Gobo slot so that Vista can show us what the gobo
looks like. In the case of common gobo styles, Vista comes with over 2,000 gobo image files.
Or, for a custom gobo, you can create and select your own image

Click the Select Image button to open up the Images window, navigate to the gobos directory,

look for the image required, select it and click open.
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Tip: Switch the window view to Large Icons for image previews.

Once the Gobo image is selected, give the gobo slot a user-friendly name in the Name field.
Your slot information should look something like this:

Repeat this process for the other four gobo wheel slots.

Add the Gobo Rotation Channel
Click the DMX button to open the Add DMX Channel dialog. Select Gobo Wheel in Class and
Gobo Slot Rotation in Type. In the DMX channel section select 16 bit and assign the correct
channel number 13 for Channel and 14 for Fine Channel. The Default value should be set to
127 as it is a midpoint default feature as the high-byte default value only need be set (because
we have the Course Fine values as Course setting turned on from earlier). Click OK to
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create. The Gobo Wheel Slot 16-bit channels 13 and 14 have been created in the DMX Chart

window:

Expand the Index Mode and Rotate Mode ranges:

Select the range to edit and adjust the values on the right-hand side of the DMX Chart window

in the DMX range section. As we can tell from the DMX chart given at the start of this
example, this fixture’s rotation clockwise and counter-clockwise are reverse to the default
values inserted, therefore the ranges need to be edited. Apply the change as shown below to

the counter-clockwise range and click apply. Repeat this procedure for the Clockwise range,

inserting the correct values.

Counter-clockwise range values:

Clockwise range values:

As the default value for Stopped is already 127, this need not be adjusted. The Index Mode
values supplied by default are the same as the fixture specification, therefore, it requires no
adjustment.

After these edits are applied, the Gobo Slot Rotation channel should look like this:
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Add the Iris Channel
Click the DMX button to open the Add DMX Channel dialog. Select Beam in Class and Iris in
Type. In the DMX channel section select Standard and assign channel number 15. The
Default value should be set to 255 as the best default for an Iris is fully open. Click OK to
create.

The Iris 8-bit channel 15 has been created in the DMX Chart window:
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Add the Custom Timing Channels

This lighting fixture provides three timing channels to
set the speed at which the Focus, Color, and Beam
mechanisms will transition to a new setting. These
three channels differ from the previous channels
created in that they do not map to any generic controls.
They will be Custom Feature channels that are
associated with the Class of the feature the affect.

For the Focus Time channel 17 (in Varilite terminology,
Focus refers to pan and tilt, not the focus of the beam)
click the DMX button to open the Add DMX Channel
dialog. Select Custom Position in Class, Custom
Position will automatically be assigned to Type and as
we are creating a Custom Feature and a feature name
needs to be assigned, type in “Focus Time”. In the
DMX channel section select Standard and assign the
correct channel number. The Default value should be
set to 0 as it is a 0-default value feature.

Click OK to create.

Repeat this process for the remaining channels 17 and
18. Channel 17 will need Class and Type set to Custom Color and named Color Time,
channel 18 will need Class and Type set to Custom Beam and named Beam Time.

After these are created, your DMX Chart should look like this:

Add the Control Channel
The Control channel is also created as a Custom feature. The Class needs to be set as
Custom Misc and Name to Control. This will create the channel, and the values for the control
macros will be set in the DMX Macros tab. If one desired, custom DMX ranges could be
added to make explicit to the user which DMX values perform what function.

The Control 8-bit channel 19 has been created in the DMX Chart window:
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DMX Macros Tab
To assign control macros, open the DMX Macros tab and enter the relevant information using
the specification from the manufacturer.

Please refer to the Macros section of Chapter 5: Patching Your Rig for details on the macro
syntax.

Saving the Fixture
Once all channel ranges have been created, spend a few minutes checking them against the
manufacturer’s specification. Click the OK button then choose OK from the resulting Save
Fixture and Exit dialog.

To use the fixture, you will first need to exit the Fixture Library Editor. Click Apply and then OK

to close the Fixture Editor window. A confirmation window will be presented. Click OK, the
library will regenerate the library catalogues to incorporate your new fixture. Please be patient
as this takes some time. The new fixture will now be available for patching from the User
Fixture Library in the patch window of the Vista application.
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Channels with Custom Ranges

While all the main features of fixtures are represented by generic controls on the console, the
ranges that do not fit the generic model are controlled by Custom Modes and Custom
Ranges. A simple example of this is an Iris channel with pulse ranges:

· Iris closed to open: 0 – 128 

· Iris Pulse-1 slow to fast: 129 – 190 

· Iris Pulse-2 slow to fast: 191 - 255 

Create the custom ranges as below using the “+ Range” button:

The Iris Pulse controls will be found in the Vista application inside the Custom Iris widget in
the Features panel, under the Beam features panel:

Double click the widget to open the Custom Feature Browser, in order to access the custom
Pulse range controls:
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Clicking on one of these three custom ranges in the top-right section sets the iris channel into
this range, and places this range onto the top slider on the left side of the Custom Feature
Browser window. Moving this slider adjusts the Iris channel constraining it to within the
selected range. The bottom slider always lets you adjust the channel to its full range of
values, regardless of which range is selected.

Note that the generic control for the feature will always work the first range value in the profile
by default. In this case, the generic slider in the beam panel will work the range of this fixture
named “Iris” because it’s the first range specified. Therefore, it’s beneficial to think this
through when you are defining ranges for DMX channels.
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Appendix 6: Log Files & Memory Dumps

Log files help the Vista development team to diagnose and fix issues you may be
experiencing.

Log Files
Log files are generated and saved every time you start and end the Vista application. Up to 12
previous versions are stored in your “Vista 3 > Logs” folder contained in Vista’s User Data
folder. (Select Help->About Vista to see the location of the User Data folder.) Upon opening
Vista for the 13th time the oldest log file will be overwritten.

There may be an occasion where a member of the Vista technical support team asks you to
submit a copy of your log files. The Vista application provides an easy way to do this. Select
Help->Export Logs and specify a save destination. Upon doing so all of your existing log files
will be zipped together within a single package, which can be attached to your support ticket
or email.

If you are experiencing repeatable issues, a best practice would be to “add a message” to the
log file at the time of the incident. To do this select Help->Add Message to Log and type a brief
description of the problem. This greatly helps the developers to quickly identify potential
incidents within the log. You can add multiple messages to the log files. Once complete,
export the log files as detailed above. 

Another best practice would be to export the log files as soon as you suspect you might need
to submit the files for examination, even if you don’t have the time to submit a support request
for a few days or weeks. This method ensures that the log files are remotely saved from this
moment in time and that they won’t be automatically overwritten on future launches of the
Vista application. 

Memory Dumps
Windows operating systems also have the option to create “memory dumps” upon identifying
an application crash. These files provide additional resources to the Vista development team.
 The option to enable the generation of these files is set to on by default, but can be manually
turned off during the application installation process. Please refer to Chapter 2: Getting
Started for more information on disabling this feature.

If generated, the dump files can be found in the “Vista 3 > Logs > CrashReports” folder within

the User Data folder.
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